none
SPF 2010 Groupes AD <-> SPF sync ? RRS feed

  • Question

  • Bonjour,

    J'utilise SPF 2010 avec un AD tournant sur Win 2003 R2.

    J'ai quelques groupes contenant mes utilisateurs.
    J'ajoute le groupe AD x dans SPF (le groupe visitors de mon site principal par exemple).

    La connexion des membres du groupe x se fait très bien.

    Je rajoute un compte AD dans le groupe x, nommons le y. Ce dernier se voit refuser l'accès au site principal.
    Je dois l'ajouter explicitement dans le groupe des visitors sur SPF.

    J'ai bien essayé de supprimer le groupe x du groupe visitors sur SPF et de le rajouter mais sans effet.

    Une recherche google m'a donné quelques articles mais ces articles sont orientés SP Server 2010 (forefront... que je n'ai pas).

    Existe-t-il un moyen pour éviter d'ajouter les nouveaux comptes d'un groupe AD manuellement dans SharePoint Foundation ?

    jeudi 5 avril 2012 12:52

Toutes les réponses

  • Bonjour,

    L'accès de y devrait être autorisé dès que vous ajouter le compte y au groupe x.

    Le comportement que vous constatez n'est pas normal. 

    Pouvez-vous vous assurer :

    • Que les sites SharePoint de votre collection héritent des permissions du site parent
    • Que le groupe "visitors" a bien accès au site sur lequel vous tentez de vous connecter avec y

    Sébastien PICAMELOT - http://blogs.developpeur.org/gribouillon/


    jeudi 5 avril 2012 15:00
  • Bonjour,

    • L'utilisateur est il reconnu par le "people picker" ?
    • ajouter le groupe x, avec l'utilisateur y, à la RACINE de votre site
    • Assurez-vous que l'héritage soit mise en place .. Si l'héritage cassé, refaite le ..

    Bonne chance, Gokan


    My blog SharePoint Pirate: http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    SharePoint Server 2010 Contributor on BTgonulluleri.com

    jeudi 5 avril 2012 17:48
  • Bonjour,

    Avez-vous fermé puis réouvert la session windows de ce compte après l'ajout dans le groupe AD ?

    De plus, quelle est la topologie Active Directory de votre entreprise ? En effet, il peut y avoir une latence au niveau réplication si l'ajout d'un utilisateur se fait sur un domain controler et que l'authentification s'effectue sur un autre domain controler. Il vous faut alors soit attendre la réplication, soit la forcer dans l'AD soit s'assurer que la mise à jour du groupe et l'authentification s'effectue sur le même controleur de domaine.

    En espérant que cela puisse vous aider

    Pierre


    Pierre Vivier-Merle - MVP SharePoint Server
    http://blogs.developpeur.org/pierre | http://www.vnext.fr
    Merci de valider les réponses qui correspondent à votre problème afin qu'ils apparaissent comme résolus.

    jeudi 5 avril 2012 21:36
    Modérateur
  • Bonjour à tous,

    Mr. Grégory, merci de nous tenir au courant concernant votre souci et de nous fournir les infos demandées.

    Cordialement,

    Dan


    Dan BAJENARU, MSFT    Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    mercredi 11 avril 2012 09:27
  • Bonjour à tous,

    Je vous prie de m'excuser, anciennement je recevais automatiquement des alertes emails lors d'une réaction sur un thread. Apparement ce n'est pas le cas automatiquement.

    Merci pour vos réponses, voici mes réponses:

    1) Oui l'ajout se fait sur le site racine ainsi que la tentative d'accès.

    2) Le groupe visitors est celui de base lors de la création de la site collection. Les droits du groupe sont respectés.

    3) Je suis en Foundation, je n'ai malheureusement pas le people picker :(

    4) Concernant l'AD, c'est un serveur windows 2003 et il n'y en qu'un seul. Quand vous parlez de réplication, vous sous entendez quoi comme intervenants dans cette réplication ? Le site SP ?

    Merci d'avance !

    vendredi 13 avril 2012 13:56