none
Incorrect SharePoint 2013 Build Version after CU upgrade

Toutes les réponses

  • Few things you can check,

    Whats the version build number, if you check via powershell?
    1. Run below PS command

    (Get-SPFarm).BuildVersion

    2. Navigate to Central Admin ->system Settings->Manage servers in this farm->Check whether the Configuration database version is updated or not

    3. Check Central admin > Upgrade and migration > Check product and patch installation status-> make sure latest CU installed.

    4. See running this command

    Get-SPServer | Where{ $_.NeedsUpgrade -eq $true}

    Make sure missing binaries are installed.

    4. Check if running psconfig vis command helps, instead of wizard.

    -Ashok Yadala


    Best Regards, A-Yadala Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    jeudi 17 mai 2018 11:53
  • Hi Ashok,

    I already mentioned the output of the command and also by going to Manage servers in farm page I am getting the version as 15.0.5009.1000

    In product and patch installation status latest CU is installed.

    All the binaries are installed properly since the PSConfig wizard has successfully completed without issues.

    I have executed both the PSConfigUI.exe(i.e. wizard) and also the PSConfig.exe command through Powershell

    Best Regards,


    Vaibhav Antriwale

    jeudi 17 mai 2018 13:37
  • Hi,

    Please open Windows Control Panel > Programs and Features, check the version of the SharePoint server. Open Windows Control Panel > Programs and Features > View installed updates, which will list all the fixes installed on the box, verify the update patch lists there.

    Note: All servers in the farm must have the same updates.

    The possible cause of error "The expected version of the product was not found on the system":

    https://blogs.technet.microsoft.com/stefan_gossner/2013/11/20/common-error-message-the-expected-version-of-the-product-was-not-found-on-the-system/

    An article about the information of SharePoint build version, which may be helpful to you:

    https://blogs.technet.microsoft.com/stefan_gossner/2016/08/23/sharepoint-does-not-have-a-build-version-full-stop/

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 18 mai 2018 01:59
    Modérateur
  • Hello Linda,

    Thanks for the details. Please read the below points:

    1. The issue I am facing is on a single server farm.

    2. I installed the March 2018 CU patch and then executed PSConfigUI.exe(i.e. wizard) successfully completed.

    3. Executed the PSConfig.exe(powershell).

    4. Executed stsadm -o localupgradestatus command and got 0 components can be upgraded or needs upgrade.

    5. As per above concluded, CU upgrade successfully completed .

    6. Checked the version number at various locations

         a) (Get-SPFarm).BuildVersion

         b) Manage Servers in Farm

         c) Check Product and Patch Installation page(able to see latest CU with KB no.)

         d) Versions table in Config database and various Content Databases.

    Everywhere I am getting the version as 15.0.5009.1000. Only exception Check Product and Patch Installation page in central administration.  It shows Update for Microsoft SharePoint Enterprise Server 2013 (KB4018302) 64-Bit Edition 15.0.5015.1002.

    My concern is not that it has not updated the version. My concern is that it is showing the version(15.0.5009.1000) which is not mentioned in any MS blog or article. I have tried to search this version number in different articles/ blogs and unable to find this version.


    Vaibhav Antriwale

    vendredi 18 mai 2018 08:47

  • Stefan explained some scenarios here not to compare config db number with patch level: ( could be, but not sure)

    https://blogs.technet.microsoft.com/stefan_gossner/2014/10/23/common-question-why-does-the-version-number-on-the-servers-in-farm-page-not-change-after-installing-october-cu/

    https://blogs.technet.microsoft.com/stefan_gossner/2018/03/13/march-2018-cu-for-sharepoint-2013-product-family-is-available-for-download/

    Please check with him once in his blog!

    Hope it helps!


    Ashok Yadala | Please remember to mark the replies as answers if they helped

    vendredi 18 mai 2018 09:46
  • Hi Vaibhav,

    I am having the same issue , did you find a solution for this ? 

    Thanks,

    SA


    • Modifié sanka_a jeudi 24 mai 2018 09:49
    jeudi 24 mai 2018 09:49
  • Anyone find a resolution?

    We have the same issue, but with installing the May 2018 CU.

    In our case build versions display as 15.0.5023.1000 (April 2018 CU)

    Checking both installed updates as well as Manage Patch Status show that we're on 15.0.5031.1000 (May 2018 CU).

    This has caused an issue preventing us from restoring a site collection from a separate farm that was patched to May 2018 CU.

    SharePoint reports April 2018 CU and won't accept the restore.

    mercredi 30 mai 2018 21:14
  • Hi,

    We are also facing the same issue with May 2018 CU. Are you able to find any solution for this?

    Thanks,

    Swathi

    mardi 5 juin 2018 08:40
  • Hi All,

    Still unable to fix the version number issue. My farm is running fine but with incorrect version number.

    Best Regards,


    Vaibhav Antriwale

    mardi 5 juin 2018 10:01
  • Hi All,

    I am also having same issue. First I did applied March 2018 CU, but the build number was showing as 15.0.5011.1001 which is useless and I don't find the same build number no where in the web. Tried all possible ways to configure and checked all suggested articles but no use. Finally I decided to install May 2018 CU. After doing so, the build number is - 15.0.5023.1000 and which is equivalent to April 2018 CU.


    vamsi

    mardi 12 juin 2018 09:15
  • I'm having the same issue with June 18 CU... it shows incorrect build # that correspond to March18CU...

    wc

    vendredi 3 août 2018 21:08