locked
MDT : ne récupère pas le profile migré d'USMT RRS feed

  • Question

  • Bonjour à tous,

    J'ai un petit soucis :

    Environnement : serv 2003 avec WDS / MDT 2008
    Lors d'un déploiement LTI, je ne parviens pas à récupérer la sauvegarde que j'ai effectuer via USMT. En fait, je créé ma sauvegarde en lancer le script BDD_autorun.wsf, qui installera puis lancera scanstate.exe par le processus LTI. J'ai bien mon dossier %computername% créer avec mes données dedans dans mon UDShare. Le problème, c'est qu'en déployant ma task sequence de MDT, tout se passe bien et est entièrement automatisé, sauf le nom du PC que j'ai délibérement laisser en manuel, pour justement remettre le même nom qu'avant la réinstallation. Et là, au moment de récupérer mes données par le script LTI via loadstate, il ne se passe rien et j'ai le message Warning de LTI en fin de déploiement :

    No user state folder (USMT 3) found at \\monserveur\Dossier\MININT-50BJDS3. Unable to restore user state.

    Le problème : MININT-50BJDS3 est le nom aléatoire donné par mon process LTI. Pourtant j'ai bien spécifier le nom voulu avant le déploiement, et mon PC se nomme bien comme je veux ! par exemple si je spécifie pc-1 il s'appellera bien pc-1 et est bien join à mon domaine.

    Pourquoi cette erreur? pourquoi USMT ne récupère pas le bon nom d'ordinateur?

    Toute aide serait la bienvenue... J'espère avoir été clair...

    Merci,
    Sunbeamtech
    • Déplacé Shrikant Maske jeudi 4 février 2010 04:53 Forums Consolidation (Origine :Windows Server 2003 – Installation et déploiement)
    mercredi 15 avril 2009 16:55

Réponses

  • Pour les français qui ne comprennent pas beaucoup l'anglais, j'ai posté depuis plusieurs semaines également sur le forum US. J'ai finit par trouver la solution à ce problème, à l'aide d'un senior MS (Henk Hofs) que je remercie énormément.

    Si un jour quelqu'un essaie de faire la même chose que moi sans passer par SCCM/SMS ou encore la base MDT, voici la solution :

    En fait la TS ne parvient pas à écrire par dessus des paramètres envoyés via le customsettings.ini. C'est pour ça que la variable %computername% ne met pas à jour avec le nom du PC que l'on peut donner via le Wizard du MDT. Pour paré à ce "problème", il faut enlever la variable UDDir=%computername% du customsettings.ini et la mettre directement dans la TS avant le restore state. Pour se faire : Add / General / Set TaskSequence variable

    variable : UDDir
    Donnée : %computername%

    A ce moment là la TS met le nom de la variable à jour et permet à ZTIUserState d'utiliser le bon paramètre, à savoir le nouveau %computername%.

    Pas très compliquer mais il fallait y penser !
    J'espère que ça vous servira ! Si quelqu'un a un commentaire, qu'il n'hésite pas.

    A bientôt,
    SunbeamTech
    MCTS BDD
    • Marqué comme réponse sunbeamtech jeudi 14 mai 2009 14:21
    jeudi 14 mai 2009 14:21