locked
Lenteur ouverture fichiers Office 2003 - 2007 sur le réseau depuis Windows 7 RRS feed

  • Question

  • Bonjour,

    Nos systèmes:

    • Serveur de fichier: Windows Serveur 2008 R2 64
    • Poste client: XP pro, Windows 7 Ultimate et Windows 7 Entreprise
    • Pack Office: 2003 sp3 ou 2007 sp2 et 2010 en version d'évaluation

     

    A la suite d'une migration de notre serveur de fichiers Windows Serveur 2003 R2 sp2 vers Windows Serveur 2008 R2, nous rencontrons actuellement un problème de lenteur lors de l'ouverture de fichiers Office à partir du réseau et uniquement depuis les postes en Windows 7. Il faut environ 30 à 60 secondes pour pouvoir ouvrir le document ( Word, Excel, PP ...)

    Nous avons testé les solutions suivantes:

     

    ---Depuis un poste XP---

    L'utilisation depuis un poste XP: FONCTIONNE, ouverture à partir du réseau très rapide (env 1 à 3 sec)

     

    --Depuis un poste Windows 7---

    Solutions qui n'ont aucun impact :

    • Réinstallation Office 2003 ou 2007: Problème toujours existant
    • Désactivation Antivirus et Pare-feu: Problème toujours existant
    • Vérification de présence de modèles ou modules complémentaires: Problème toujours existant, aucun modèle ou module complémentaire présent
    • Ré-installation complète du système d'exploitation: Problème toujours existant
    • Modification de chiffrement des connexions de partage de fichiers à 40 ou 56 bits: Problème toujours existant
    • Désactivation de la découverte de réseau: Problème toujours existant

    Solutions qui contournent le problème :

    • Ouverture du fichier en local avec Office 2003 ou 2007: Plus de problème
    • Désactivation de la couche réseau SMB2: Plus de problème
    • Installation Office 2010: Plus de problème

    Pour essayer de cibler le problème, nous avons essayé d'ouvrir ces mêmes fichiers avec d'autres logiciels qu'Office (OpenOffice par exemple) : le problème n'existe pas.Il semble donc être vraiment lié à MS Office


    Malheureusement aucune des 3 solutions n'est envisageable :

    • Nous n'avons pas prévu de migration vers Office 2010
    • Nous ne souhaitons pas désactiver SMB2
    • Il n'est pas envisageable de demander à nos utilisateurs de travailler avec des fichiers en local sur leur poste.

     

    Avez-vous une solution à ce problème qui devient un véritable handicap pour l'ensemble de nos utilisateurs?

     

    Cordialement.

    mardi 28 décembre 2010 10:58

Réponses

  • Bonjour,

    je rencontre le meme genre de probleme

    infra reseau gigabit tout neuf

    domaine active directory 2003

    serveurs de fichier 2003

    postes de travail win 7 pro 64b

     

    l'ouverture d'un fichier Word ou Excel peut mettre 1 minute, l'enregistrement 2 ou 3 minutes... quand ca n'echoue pas en generant un fichier TMP portant un nom aléatoire...

    ici c'est l'horreur, impossible de travailler (et je vais finir a la porte !)

    j'ai essayé:

    de desactiver les Anti virus sur le serveur et les poste de travail sans succes

    desactiver SMB2 sur les postes de travail sans succes

    http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

     

    je ne sais plus quoi faire ... evidement, le graphiste charge des fichiers 'toshop ou indesign de plusieurs centaines de Mo sans problemes..

    il me reste qq postes en WinXP SP3 office 2003 et 2007 qui ne rencontre pas le pb non plus...

     

    bref, je suis desepéré...


    Bonjour à tous,

    Je viens donner ma contribution à ce problème car j'ai enfin trouvé la solution après 5 mois de recherche.

    Il faut vous rendre sur services.msc et trouver le service WebClient sur la machine Win7. Vous mettez le démarrage en automatique et vous démarrez le service.

    Et au grand miracle l'ouverture d'office 2003 ou 2007 est quasi instantané.

    Je vous souhaite une bonne fin de journée à tous.

    Amicalement,

    Jonathan

    • Proposé comme réponse whise59 jeudi 5 mai 2011 13:39
    • Marqué comme réponse arch21Editor vendredi 23 décembre 2011 14:28
    jeudi 5 mai 2011 13:35
  • Pour résoudre totalement le problème sur tout les postes en Windows 7, j'ai ajouté une clé de registre sur le serveur de fichier (dans mon cas Serveur 2008 R2)

    1. Exécuter "regedit "

    2. Développer et localiser, comme suit

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

     

    3. Ajouter une nouvelle cléREG_DWORD avec le nomde" SMB2" ( sans guillemets )

    Value name: Smb2
    Value type: REG_DWORD
    0 = disabled
    1 = enabled

     

    4. Mettre la valeur à 0 pour désactiver SMB2.0 , ou la fixer à 1pour la réactiver

    5. Redémarrer le serveur

    Tampis je ne bénéficierait pas des avantages du protocole SMB2.

    mercredi 5 janvier 2011 17:06

Toutes les réponses

  • Bonjour,

    Ce sujet tombe à pic ! Je rencontre effectivement le même problème depuis la mise en production d'un serveur de fichiers sous Windows 2008R2.

    Je viens de tester les solutions indiquées par mon voisin du dessus, et j'arrive exactement aux mêmes conclusions.

     

    Merci d'avance pour les réponses que vous pourrez apporter !

    Bien cordialement,

     

    Florian M.

    mardi 28 décembre 2010 11:11
  • Pour résoudre totalement le problème sur tout les postes en Windows 7, j'ai ajouté une clé de registre sur le serveur de fichier (dans mon cas Serveur 2008 R2)

    1. Exécuter "regedit "

    2. Développer et localiser, comme suit

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

     

    3. Ajouter une nouvelle cléREG_DWORD avec le nomde" SMB2" ( sans guillemets )

    Value name: Smb2
    Value type: REG_DWORD
    0 = disabled
    1 = enabled

     

    4. Mettre la valeur à 0 pour désactiver SMB2.0 , ou la fixer à 1pour la réactiver

    5. Redémarrer le serveur

    Tampis je ne bénéficierait pas des avantages du protocole SMB2.

    mercredi 5 janvier 2011 17:06
  • Bonjour,

    je rencontre le meme genre de probleme

    infra reseau gigabit tout neuf

    domaine active directory 2003

    serveurs de fichier 2003

    postes de travail win 7 pro 64b

     

    l'ouverture d'un fichier Word ou Excel peut mettre 1 minute, l'enregistrement 2 ou 3 minutes... quand ca n'echoue pas en generant un fichier TMP portant un nom aléatoire...

    ici c'est l'horreur, impossible de travailler (et je vais finir a la porte !)

    j'ai essayé:

    de desactiver les Anti virus sur le serveur et les poste de travail sans succes

    desactiver SMB2 sur les postes de travail sans succes

    http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

     

    je ne sais plus quoi faire ... evidement, le graphiste charge des fichiers 'toshop ou indesign de plusieurs centaines de Mo sans problemes..

    il me reste qq postes en WinXP SP3 office 2003 et 2007 qui ne rencontre pas le pb non plus...

     

    bref, je suis desepéré...

    mercredi 12 janvier 2011 18:23
  • Pour résoudre totalement TON problème, ajoute une clé de registre sur le SERVEUR de fichiers (dans Ton cas Serveur 2003)

    1. Exécuter "regedit " dans une fenetre de l'invite de commande en mode administrateur (démarre l'invite de commande avec un clique-droit, démarrer en tant qu'administrateur)

    2. Développer et localiser, comme suit

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

     

    3. Ajouter une nouvelle clé REG_DWORD avec le nom de " SMB2 " ( sans guillemets )

    Value name: Smb2
    Value type: REG_DWORD
    0 = disabled
    1 = enabled

     

    4. Mettre la valeur à 0 pour désactiver SMB2.0 , ou la fixer à 1pour la réactiver

    5. Redémarrer le serveur ET tous les postes de travail

     

    Il était écrit plus haut... en fait, j'ai copié collé et corrigé la marche à suivre :) Bonne semaine!

    dimanche 27 février 2011 11:44
  • Bonjour,

    je rencontre le meme genre de probleme

    infra reseau gigabit tout neuf

    domaine active directory 2003

    serveurs de fichier 2003

    postes de travail win 7 pro 64b

     

    l'ouverture d'un fichier Word ou Excel peut mettre 1 minute, l'enregistrement 2 ou 3 minutes... quand ca n'echoue pas en generant un fichier TMP portant un nom aléatoire...

    ici c'est l'horreur, impossible de travailler (et je vais finir a la porte !)

    j'ai essayé:

    de desactiver les Anti virus sur le serveur et les poste de travail sans succes

    desactiver SMB2 sur les postes de travail sans succes

    http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

     

    je ne sais plus quoi faire ... evidement, le graphiste charge des fichiers 'toshop ou indesign de plusieurs centaines de Mo sans problemes..

    il me reste qq postes en WinXP SP3 office 2003 et 2007 qui ne rencontre pas le pb non plus...

     

    bref, je suis desepéré...


    Bonjour à tous,

    Je viens donner ma contribution à ce problème car j'ai enfin trouvé la solution après 5 mois de recherche.

    Il faut vous rendre sur services.msc et trouver le service WebClient sur la machine Win7. Vous mettez le démarrage en automatique et vous démarrez le service.

    Et au grand miracle l'ouverture d'office 2003 ou 2007 est quasi instantané.

    Je vous souhaite une bonne fin de journée à tous.

    Amicalement,

    Jonathan

    • Proposé comme réponse whise59 jeudi 5 mai 2011 13:39
    • Marqué comme réponse arch21Editor vendredi 23 décembre 2011 14:28
    jeudi 5 mai 2011 13:35
  • est ce qu'il ya un risque au niveau de la sécurité si j'active ce service sur mon poste(web client)??

    Merci

    lundi 29 avril 2013 13:28