none
VPN to internal web site - strange RRS feed

  • Question

  • Hello,

    I have a strange issue and I am not sure where to check.

    • I have an internal web server (intranet site, windows authentication) accessible only from inside the lan (uses port :8080).
    • From inside the LAN you can access the site using any browser (IE, Mozzilla, Chrome, etc.).
    • I also have a forefront TMG as gateway (policies are ok, all traffic is allowed for vpn clients no restrictions).
    • The problem is when a user connects from home through PPTP VPN (TMG) they cant access the site (Team Foundation site) neither by name, fqdn or ip.
    • name resolution is not an issue. Every resource resolves fine and can be accessed.
    • However they can access other websites on the server with no problem (standard http port 80).
    • Now the Strange thing... the user that is connected through VPN and tries to connect to http://server.domain.com:8080/tfs/web can connect using Opera browser fine. But not with other browsers.

    What I have tested:

    • i have changed the binding in IIS for the TeamFoundatinSite and assigned it to a different port like :7777. It works through VPN with any browser using any other port but Http 80 OR HTTPS 443. The problem is that it connects to some other sharepoint component that is using also 8080 and I have to change too many things withouth having a clear explanation.
    • telneted through vpn to 8080 and it is opened.
    • used wireshark to trace but all I see is requests that don't get answered. The webpage keeps loading indefinately without any error like 401, 404 etc but like I said on Opera it opens instantly.
    • Configured it tu use a certificate for HTTPS but same story as HTTP 8080. Again If I assign any other port it's ok.
    • Configured a TMG policy to specifically allow 8080. No luck.

    If you have any ideeas no matter how crazy, tell me I will try them. Thanks.


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/



    jeudi 15 mars 2012 09:00

Réponses

  • The issue was resolved. There were some filters applied to the HTTP protocol. I disabled them and it started working.

    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    mardi 20 mars 2012 15:09