none
Calendar not recognizing Regional Settings for user in another time zone.

    Question

  • I have a calendar in a 2016 SharePoint site.  The Default Time zone for the Web Application is Pacific Time (where most of our users, and the servers are).  The Regional Settings for the site the Calendar is in is set to Mountain Time. I have a user who is on the east coast.  His machine is set to Eastern Time.  His regional settings in his user profile is set to Eastern Time, and "Always use my personal settings" is ticked.  When we both go to the same calendar, the dates and times are identical.  I am in Mountain time too.  What could cause this?
    jeudi 17 mai 2018 20:47

Réponses

  • Cache wasn't the problem, it's a hybrid scenario, and I could get the same issues with SharePoint Online.  There's a check box way down at the bottom that says "Use Language and Regional settings"  It was unchecked.  On the surface the question makes no sense, why would you fill out the rest of this area if you didn't want to use it.  But I checked it.  You see warnings that this takes time, and after two days when I went back to check, whala, it was working across On-Prem/SharePoint Online and all.  Hope this helps someone.

    • Marqué comme réponse csedwilliams vendredi 25 mai 2018 14:47
    vendredi 25 mai 2018 14:47

Toutes les réponses

  • Hi,

    Each user can set their time zone in their profile (or you can set it directly via User Profile services).

    Open up the profile, switch to Language and Region settings and update the timezone. Now when they interact with the Calendars they show the appropriate times.

    They may have to change a setting to say to use their regional settings vs. admin specified before they can change the time zone. 

    Please make sure this user only change the time zone for himself.

    Please select the Only me for this user.

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 18 mai 2018 03:01
  • Those settings are already there.  Including the Only Me settings, they are identical.  I did even try changing the Timezone from Everyone to Only Me in case that's what you meant. Still no difference.
    vendredi 18 mai 2018 16:13
  • Hi,

    Please clear the browser cache.

    You need to suggest all users in the SharePoint to do this.

    Besides, you can use the IE compatibility view.

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 25 mai 2018 02:54
  • Cache wasn't the problem, it's a hybrid scenario, and I could get the same issues with SharePoint Online.  There's a check box way down at the bottom that says "Use Language and Regional settings"  It was unchecked.  On the surface the question makes no sense, why would you fill out the rest of this area if you didn't want to use it.  But I checked it.  You see warnings that this takes time, and after two days when I went back to check, whala, it was working across On-Prem/SharePoint Online and all.  Hope this helps someone.

    • Marqué comme réponse csedwilliams vendredi 25 mai 2018 14:47
    vendredi 25 mai 2018 14:47