none
Problème de réplication DFS-R RRS feed

  • Question

  • Bonjour à tous,

    Dans un domaine mono forêt mais multi sous domaine j'ai ajouté des nouveaux DC en 2016 (Tout le reste est en 2012).

    J'ai un soucis de zone Stub sur les nouveau en effet je n'arrive pas les charger. J'ai toujours une erreur 6534. Je n'ai aucun soucis avec mes anciens serveurs DC.

    J'ai ce problème avec n'importe quel zone stub sur mes deux nouveaux DC en 2016.

    Sur les serveurs qui hébergent la zone dans l'onglet "Zone transfers" j'ai coché "A tous les serveurs" en vain.

    Merci d'avance pour vos retours.


    mardi 30 avril 2019 08:01

Réponses

  • D'ou pourrait venir mon soucis de synchro SYSVOL ?

    Il faut que tu trouves la GPO qui a le numéro :{B6543FFB-2B3B-41C1-8335-BB20D3F2B921}, son contenu doit poser problème sur un ou plusieurs DCs. Tu peux éventuellement la supprimer et la refaire...

    Si je lance l'outil AD Replication Tool je n'ai aucune erreur sur aucun de mes serveurs !!

    Il y a deux type de réplication dans l'AD DS différent et indépendant, la réplication de l'annuaire (repadmin ou ad replication status tool) et la réplication de fichiers pour le contenu de sysvol (ce qui pose problème). Il est important de vérifier la réplication AD même si ce n'est pas directement le sujet, les infos des GPO étant stocké dans l'AD, alors que les paramètres sont dans sysvol.

    jeudi 2 mai 2019 12:28

Toutes les réponses

  • Bonjour.

    Ta zone DNS de stub est intégrée dans l'AD ?

    mardi 30 avril 2019 09:01
  • En recherchant bien, l'erreur 6534 vient sur une zone secondaire. Donc tu n'as pas intégré ta zone à l'AD pour profiter de la réplication et de la sécurité de l'AD. Tu es resté sur le schéma conventionnel de réplication DNS.

    Au niveau du DNS qui héberge la zone DNS Principale, tu as bien intégré l'ensemble des serveurs DNS qui vont héberger cette zone dans l'onglet des serveurs de noms ? Surtout si ensuite tu autorise les transferts de zone vers uniquement ces serveurs là.

    mardi 30 avril 2019 09:41
  • Bonjour,

    Je confirme que toutes mes zones DNS sont bien intégrées à l'AD.

    Par contre j'ai trouvé un problème plus profond. En effet sur mes nouveaux serveurs AD je n'ai aucun partage SYSVOL et NETLOGON !! Je ne récupère donc pas le répertoire script ou alors Policies !

    mardi 30 avril 2019 10:17
  • Tes nouvelles machines ne sont donc pas bien intégrées dans l'AD. C'est donc normal que la réplication AD DNS ne fonctionne pas.

    Que donne les DCDIAG ?

    Essaye de mettre en DNS primaire sur tes nouveaux serveurs l'adresse IP d'un ancien DC pour commencer.

    mardi 30 avril 2019 11:02
  • Mes nouveaux DC ont bien comme DNS primaire un ancien serveur .

    Voici le résultat pour DCDIAG :

    Directory Server Diagnosis

    Performing initial setup:
       Trying to find home server...
       Home Server = SERV-EUMA-DC02
       * Identified AD Forest.
       Done gathering initial info.

    Doing initial required tests

       Testing server: Marcoussis\SERV-EUMA-DC02
          Starting test: Connectivity
             ......................... SERV-EUMA-DC02 passed test Connectivity

    Doing primary tests

       Testing server: Marcoussis\SERV-EUMA-DC02
          Starting test: Advertising
             ......................... SERV-EUMA-DC02 passed test Advertising
          Starting test: FrsEvent
             ......................... SERV-EUMA-DC02 passed test FrsEvent
          Starting test: DFSREvent
             There are warning or error events within the last 24 hours after the SYSVOL has been shared.  Failing SYSVOL
             replication problems may cause Group Policy problems.
             ......................... SERV-EUMA-DC02 passed test DFSREvent
          Starting test: SysVolCheck
             ......................... SERV-EUMA-DC02 passed test SysVolCheck
          Starting test: KccEvent
             ......................... SERV-EUMA-DC02 passed test KccEvent
          Starting test: KnowsOfRoleHolders
             ......................... SERV-EUMA-DC02 passed test KnowsOfRoleHolders
          Starting test: MachineAccount
             ......................... SERV-EUMA-DC02 passed test MachineAccount
          Starting test: NCSecDesc
             ......................... SERV-EUMA-DC02 passed test NCSecDesc
          Starting test: NetLogons
             ......................... SERV-EUMA-DC02 passed test NetLogons
          Starting test: ObjectsReplicated
             ......................... SERV-EUMA-DC02 passed test ObjectsReplicated
          Starting test: Replications
             ......................... SERV-EUMA-DC02 passed test Replications
          Starting test: RidManager
             ......................... SERV-EUMA-DC02 passed test RidManager
          Starting test: Services
             ......................... SERV-EUMA-DC02 passed test Services
          Starting test: SystemLog
             An error event occurred.  EventID: 0x00002720
                Time Generated: 04/30/2019   13:07:05
                Event String:
                The application-specific permission settings do not grant Local Activation permission for the COM Server app
    lication with CLSID
             ......................... SERV-EUMA-DC02 failed test SystemLog
          Starting test: VerifyReferences
             ......................... SERV-EUMA-DC02 passed test VerifyReferences


       Running partition tests on : ForestDnsZones
          Starting test: CheckSDRefDom
             ......................... ForestDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... ForestDnsZones passed test CrossRefValidation

       Running partition tests on : DomainDnsZones
          Starting test: CheckSDRefDom
             ......................... DomainDnsZones passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... DomainDnsZones passed test CrossRefValidation

       Running partition tests on : eu
          Starting test: CheckSDRefDom
             ......................... eu passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... eu passed test CrossRefValidation

       Running partition tests on : Schema
          Starting test: CheckSDRefDom
             ......................... Schema passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Schema passed test CrossRefValidation

       Running partition tests on : Configuration
          Starting test: CheckSDRefDom
             ......................... Configuration passed test CheckSDRefDom
          Starting test: CrossRefValidation
             ......................... Configuration passed test CrossRefValidation

       Running enterprise tests on : domainfr.local
          Starting test: LocatorCheck
             ......................... domainfr.local passed test LocatorCheck
          Starting test: Intersite
             ......................... domainfr.local passed test Intersite

    mardi 30 avril 2019 12:10
  • Bonjour pouvez-vous vérifier les journaux d’événements concernant l'active Directory?

    Pouvez-vous vérifier le thread ci-dessous?

    https://social.technet.microsoft.com/Forums/fr-FR/95480eb1-94b9-4efc-b70b-67a5c836969e/partage-sysvol-et-netlogon-manquant-lors-de-promotion-de-deuxime-controleur-de-domaine?forum=windowsserver8fr

    Merci d'avance.

    Cordialement.

    mardi 30 avril 2019 12:21
  • Mon problème est global à toute ma forêt. En effet il n'y a plus de synchro des répertoire Policies et Script entre les serveurs. :(

    Je pense suivre cette procédure : https://support.microsoft.com/en-us/help/2218556/how-to-force-an-authoritative-and-non-authoritative-synchronization-fo

    Dois je au préalable supprimer tout le contenu SYSVOL des serveurs qui ne sont pas autoritaire ?

    Cordialement,

    mardi 30 avril 2019 13:11
  • Il faut en amont bien vérifier les erreurs présentes dans le journaux d’événements pour s'assurer que l'ID correspond bien à la procédure que vous souhaitez utilisé.

    Cordialement.

    mardi 30 avril 2019 13:21
  • Il faut en amont bien vérifier les erreurs présentes dans le journaux d’événements pour s'assurer que l'ID correspond bien à la procédure que vous souhaitez utilisé.

    Cordialement.

    Désolé mais je ne vois pas de quoi vous parlez ? Dans la procédure il n'y a pas d'ID particulier.

    Désolé je suis un peu perdu avec ces problèmes

    mardi 30 avril 2019 13:26
  • Dans les journaux d’événements des serveurs vous devez trouver des erreurs de réplications, des erreurs sysvol et netlogon.

    En complément de votre lien, un petit lien explicatif de la restauration SYSVOL.

    https://www.dell.com/support/article/fr/fr/frbsdt1/sln156015/r%C3%A9initialisation-d-un-dossier-sysvol-r%C3%A9pliqu%C3%A9-avec-le-dfs-sur-un-contr%C3%B4leur-de-domaine-windows?lang=fr

    autre lien sur le forum:

    https://social.technet.microsoft.com/Forums/fr-FR/95f596f9-fffd-4b6a-9d69-d3cd454769ca/resolu-problme-replication-sysvol-dfs?forum=windowsserver2008fr

    Cordialement.

    mardi 30 avril 2019 13:34
  • Dans les journaux d’événements des serveurs vous devez trouver des erreurs de réplications, des erreurs sysvol et netlogon.

    Le soucis est que je n'ai pas forcément d'erreur dans les event.  Tous ce que je suis sur c'est :

    - Lors de l'ajout d'un nouveau DC le dossier SYSVOL n'est pas partagé et donc ne récupère pas le contenu et ça dans n'importe quelle domaine de ma forêt.

    - Je n'ai plus aucune synchro du répertoire SYSVOL entre mes anciens serveurs (cela fonctionnait il y a quelques semaines)

    mardi 30 avril 2019 13:46
  • Faites un repadmin /showrepl ou utiliser AD replication statuis tool pour avoir une vision plus global du problème.

    Attention dcdiag analyse par défaut que le DC sur lequel il est exécuté.

    Plus de détail :

    http://www.pbarth.fr/node/218

    Quel est la conf IP des nouveaux serveurs ? DNS primaire ? DNS Ipv6 ?

    Au vue de ce que tu indiques il devrait y avoir plus d'élément dans le DCdiag, sauf si le DCdiag vient d'un des DC qui n'a pas trop de problèmes.

    Dois je au préalable supprimer tout le contenu SYSVOL des serveurs qui ne sont pas autoritaire ?

    Non .

    Je ne vois pas ce que tu veux dire par serveurs autoritaire ! 

     

    mardi 30 avril 2019 13:56
  • merci Philippe tu m'as devancé.

    le lien pour AD replication status tool

    https://www.microsoft.com/en-us/download/details.aspx?id=30005

    Cordialement.

    mardi 30 avril 2019 13:59
  • La commande "repadmin /showrepl" ne ressort aucune erreur et ça sur tous les serveurs même les nouveaux. D'ailleurs l'outil "AD Replication Status Tool" ne ressort non plus aucune erreur.

    Pour ce qui concerne le serveur autoritaire je voulais parler de la façon de restaurer SYSVOL. Il en existe 2 autoritaire et non autoritaire.

    mardi 30 avril 2019 14:08
  • Combien de DC ancien ? combien de nouveau ?

    Conf ip des nouveaux ?

    J'ai vue régluièrement des erreurs lors de la première réplication AD, lors du redémarrage à cause du DNS IPV6 et (::1 = loopback) prioritaire sur IPV4.

    Si tu fais un nslookup mondomaine.local sur le nouveau quel réponse ?

    Si tu as un DC sysvol HS il faut faire une restauration non autoritaire sur ce DC en particulier. Attention il y a deux types de réplication possible (NTFRS ou DFS-R) en fonction du niveau fonctionnel de la forêt lors de la création ou si tu as exécuté une migration vers DFS-R

    Un peu de lecture :

    http://www.pbarth.fr/node/75

    http://www.pbarth.fr/node/68 => NTFRS avec burflags

    http://www.pbarth.fr/node/135 DFS-R

    mardi 30 avril 2019 14:27
  • J'ai 5 DC ancien et 1 nouveau. Et en effet j'ai l'IPV6 bien d'activé mais laissé en DHCP Et pour DNS comme vous le dites ::1

    Est ce que je devrais désactiver l'IPV6 ?

    Concernant la réplication je suis en DFS-R.

    mardi 30 avril 2019 14:33
  • Si tu fais un nslookup mondomaine.local sur le nouveau quel réponse ?


    PS C:\Windows\system32> nslookup eu.l-domaine.local
    Server:  serv-euma-dc01.eu.l-domaine.local
    Address:  192.168.0.170

    Name:    eu.l-domaine.local
    Addresses:  192.168.0.171
              192.168.0.170
              192.168.0.218
              192.168.67.100
              192.168.30.207
              192.168.40.201
    mardi 30 avril 2019 14:35
  • Voici un message d'erreur DFSR :

    The DFS Replication service failed to get folder information when walking the file system on a journal wrap or loss recovery due to repeated sharing violations encountered on a folder. The service cannot replicate the folder and files in that folder until the sharing violation is resolved. 
     
    Additional Information: 
    Folder: C:\Windows\SYSVOL\domain\Policies\{B6543FFB-2B3B-41C1-8335-BB20D3F2B921}\User\ 
    Replicated Folder Root: C:\Windows\SYSVOL\domain 
    File ID: {00000000-0000-0000-0000-000000000000}-v0 
    Replicated Folder Name: SYSVOL Share 
    Replicated Folder ID: 04BB26FF-3933-4325-86A5-C940AC35B07E 
    Replication Group Name: Domain System Volume 
    Replication Group ID: C2BB0E3F-046B-4200-B882-A044F4E0C6D3 
    Member ID: C7F9CDE0-18AB-4A88-8538-1BE08AFB1A9F

    mardi 30 avril 2019 15:09
  • J'ai 5 DC ancien et 1 nouveau. Et en effet j'ai l'IPV6 bien d'activé mais laissé en DHCP Et pour DNS comme vous le dites ::1

    Est ce que je devrais désactiver l'IPV6 ?

    Ce n'est pas recommandé de désactivé ipv6, par contre j'enlève souvent le ::1 au moment de la promotion. Lorsque tu ajoutes un DC au départ il n'a pas le rôle de serveur DNS, et interroge l'ancien en IPV4. Au moment de la promotion le rôle DNS est ajouté et il faut redémarrer. Au redémarrage il est serveur DNS mais il n'est pas prêt car la réplication initiale de l'AD (contenant les zones intégrés AD) n'est pas faites (voir message dans le journal), si tu as ::1 dans DNS ipv6 prioritaire par défaut, il va s'interroger lui même, mais il n'est pas prêt à répondre, et pour que la réplication DNS fonctionne il lui faut DNS et pour que DNS fonctionne il lui faut la réplication. C'est sans fin.

    Sysvol ne s'initialise pas et si tu fais un net share , tu n'as pas les partage netlogon et sysvol.

    Dans ce cas enlever "::1" sur DNS ipv6 redémarrer faire un repadmin /showrepl pour vérifier la réplication  de 'lannuaire + faire une restauration non autoritaire de sysvol sur ce serveur en particulier.

    Désolé pour la phrase j'ai été interrompu 4 fois pendant ma réponse ...

    mardi 30 avril 2019 15:29
  • Je n'avais pas vu le dernier message apparemment tu dois avoir une gpo HS sur un ancien dc voir tous. Essaye de la modifier depuis la console. Fait un dcdiag sur chacun pour identifier quel dc.... 
    mardi 30 avril 2019 16:09
  • Bonjour, pour répondre à la question de l'IPV6, je recommande de mettre en priorité L'IPV4 pour éviter de désactiver IPV6.

    https://blogs.technet.microsoft.com/windows_networking_fr/2011/09/26/ipv6-versus-ipv4-comment-prioriser-les-flux-ipv4-dans-windows/

    Effectivement comme le dit Philippe, laisser IPV6 par défaut empêchera les réplications DNS.

    Cordialement.

    mercredi 1 mai 2019 15:10
  • Merci pour tous vos réponses.

    J'ai effectué les modifications sur l'IPV6 sans succès. J'ai enlevé mon nouveau DC sous 2016 pour résoudre mon problème de synchro DFS-R. 

    Pour le moment je n'ai plus aucun synchro entre les répertoires SYSVOL même en forçant la synchro avec les procédures cité plus haut. 

    D'ou pourrait venir mon soucis de synchro SYSVOL ? je ne vois pas d'ou cela pourrait venir. Si je lance l'outil AD Replication Tool je n'ai aucune erreur sur aucun de mes serveurs !!

    jeudi 2 mai 2019 08:13
  • D'ou pourrait venir mon soucis de synchro SYSVOL ?

    Il faut que tu trouves la GPO qui a le numéro :{B6543FFB-2B3B-41C1-8335-BB20D3F2B921}, son contenu doit poser problème sur un ou plusieurs DCs. Tu peux éventuellement la supprimer et la refaire...

    Si je lance l'outil AD Replication Tool je n'ai aucune erreur sur aucun de mes serveurs !!

    Il y a deux type de réplication dans l'AD DS différent et indépendant, la réplication de l'annuaire (repadmin ou ad replication status tool) et la réplication de fichiers pour le contenu de sysvol (ce qui pose problème). Il est important de vérifier la réplication AD même si ce n'est pas directement le sujet, les infos des GPO étant stocké dans l'AD, alors que les paramètres sont dans sysvol.

    jeudi 2 mai 2019 12:28
  • En effet le problème venait de cette GP. Je l'ai supprimé puis j'ai relancer une synchro et la tout est revenu à la normale.

    Je vais maintenant remettre mon serveur 2016 dans le domaine pour voir si il récupère bien tout :)

    Merci encore

    jeudi 2 mai 2019 13:15