none
Délégation des boites avec Exchange et Outlook 2010 RRS feed

  • Discussion générale

  • Bonjour,

    Nous venons de migrer de Lotus vers Exchange 2010 (enfin !). La délégation sous lotus pouvait se faire sans intervention de l'utilisateur (suffisait de nous dire l'accès à donner pour qu'on le fasse). Sous exchange et outlook, j'ai pas encore réussi à le faire. Disons que je veux déléguer l'accès à X sur la boite Y (avec différents niveaux d'accès aux mails, calendrier, etc).

    Côté serveur, je peux donner un accès complet à la boite mais ce n'est pas ce que je veux. J'ai trouvé une astuce sur le web qui consiste à ouvrir un outlook avec un compte privilégié (dans le groupe organization management). J'ajoute ensuite le compte de Y (File, Add account, désolé c'est en anglais et j'ai pas d'outlook français) mais je ne mets pas son mot de passe (je le connais pas et hors de question de le demander). Le compte s'ajoute, je relance outlook. Je passe ce compte en compte par défaut puis je vais essayer de déléguer l'accès. Je vais donc dans File, Account Settings et là, Delegate Access est grisé. Je ne peux donc pas déléguer à la place de la personne.

    J'imagine qu'il me manque un droit mais lequel ? Comment faire pour déléguer l'accès à une boite sans l'intervention de la personne ?

     

    Merci :)

    • Type modifié Florin Ciuca vendredi 5 août 2011 13:53 attente de feedback
    samedi 30 juillet 2011 15:02

Toutes les réponses

  • Bonjour,

    Normalement le rôle Organisation Management suffit pour faire la délégation souhaitée,

    Vous pouvez éventuellement essayer en powershell avec la commande Add-MailboxFolderPermission (http://technet.microsoft.com/fr-fr/library/dd298062.aspx) qui permet de faire une gestion dossier par dossier, et qui devrait de plus vous retourner une erreur plus explicite en cas de problème.

     

    dimanche 31 juillet 2011 16:09
    Modérateur
  • J'ai pu ajouter les droits voulus via powershell sans erreur (avec le même utilisateur bien sûr). Malgré tout, je trouve ça bizarre que ce soit grisé dans outlook.

    J'ai été voir les logs rpc client access mais il n'y a pas d'infos intéressantes en l'état. J'ai voulu augmenter le niveau de logging mais je ne sais pas trop quelle log toucher pour espérer trouver la source du problème...

    dimanche 31 juillet 2011 20:18
  • Bonjour,

    Si le bouton est grisé, il se peut que la délégation par Outlook est désactivée par GPO. Essayer de jeter aussi un coup d'oeil sur la clé de registre suivante:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\

    Est-ce que la clé DisableEditPermission est à 0 ou à 1 ?

    Bonne chance


    Best Regards Don't forget to mark it as answer if it helps
    lundi 1 août 2011 13:30
  • La clé n'existait pas (dans 14.0 vu que je suis sous 2010). Je l'ai créée en dword avec une valeur 0 puis j'ai relancé outlook : toujours grisé.

    La seule gpo que j'ai mis concernant exchange, c'est pour contrôler HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover\ZeroConfigExchange pour éviter de faire next, next, finish pour la configuration d'un nouveau profil exchange.

     

    mardi 2 août 2011 12:38
  • Bonjour,

    Je pense que l'emplacement de la clé est plutot le suivant:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Folders

    Essayer d'effectuer cette manipulation, redemarrer votre ordinateur ! n'oublier pas de nous tenir au courant.

    Dans le cas ou ca n'a pas fonctionner, je vous informe qu'au niveau de Exchange 2010 et dans le cas vous allez attribuer le droit à utilisateur d'y acceder sur autre mailbox vous ne pouvez effecuter que du full permission. sinon, vous pouvez attribuer les droits de 'send as' et 'send on behalf of'. si vous voulez raffiné les permissions comme celle de lotus, je pense que personnement je ne connais pas une facon standard de la faire via Exchange 2010.

    Merci 


    Best Regards Don't forget to mark it as answer if it helps
    mardi 2 août 2011 14:06
  • Bonjour Michaël,

     

    Nous changeons le type de votre question à « Discussion générale » parce que vous n’êtes pas revenu avec les informations sollicitées. Si vous avez plus de temps pour réexaminer la question et fournir plus d'informations, n'hésitez pas à modifier le type du thread à « Question ». Si le problème est résolu, s’il vous plaît partagez la solution avec nous afin que la réponse puisse être trouvée et utilisée par d'autres membres de la communauté ayant des questions similaires. Merci !

     

    Cordialement,

     

    Florin


    Florin CIUCA, MSFT       Join TechNetFr on Viadeo   Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    vendredi 5 août 2011 13:53
  • Bonjour,

    Je n'ai pas pu tester ce que Maher m'a proposé avant ce matin. J'ai dû créer la clé HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Folders et donc un dword disableeditpermission avec une valeur 0. J'ai relancé outlook et ça n'a rien changé.

    J'ai également fait un autre test en ayant le mot de passe d'un compte sur lequel je veux faire la délégation. J'ai donc ajouté un compte en mettant l'adresse mail et le mot de passe : idem, je ne peux pas.

    En revanche, je peux donner des permissions depuis powershell sur inbox, calendar, contacts. Le problème, c'est que je n'ai pas trouvé comment appliquer les permissions de manière récursive sur tous les dossiers de la mailbox (ou comment activer l'héritage de permissions comme avec ntfs).

    Je n'ai donc toujours pas de vraie solution. Je vais essayer de creuser du côté d'ews pour voir si je peux développer un bout de programme qui fasse ce que je veux :)

    jeudi 18 août 2011 07:17