none
Exchange 2013 - How to change the backend SMTP port 2525 to something else ? RRS feed

  • Question

  • Hello,

    The default port for backend SMTP transport is 2525 (Default <Server> inbound connector).

    I tried to change the port to something else (4025) because port 2525 is in use by aTempo Time Navigator backup agent software..

    The port change on inbound connector is ok, but the frontend "proxy" SMTP transport still tries to connect to port 2525... and I can't find where to tell him the new port... (tried a reboot in case of an "autodetected thing" with no luck..)

    Can someone help me ?

    regards,

    Stéphane


    lundi 8 juillet 2013 08:20

Toutes les réponses

  • Bonjour Stéphane

    Plutôt que de changer le port utilisé par Exchange pouvez vous changer celui de votre application?

    Merci


    Hakim Taoussi

    lundi 8 juillet 2013 08:43
  • Bonjour Stéphane

    Plutôt que de changer le port utilisé par Exchange pouvez vous changer celui de votre application?

    Merci


    Hakim Taoussi

    Bonjour,

    Bien sur que non... sinon je n'aurais pas posé la question....

    Le port de Tina est configuré "par serveur de sauvegarde". changer le port revient à réinstaller le serveur. de backup... et la configuration des centaines d'agents de backup qui y sont rattachés...

    Cdt,

    lundi 8 juillet 2013 08:48
  • Bonjour, 

    Vous pouvez utiliser la langue française sur ce forum. Je ne retrouve plus la référence mais il me semble que l'on ne puisse pas changer les ports par défaut directement. Peut-etre que d'autres personnes ont eu cette problèmatique ou qu'il y a une clé de registre. Je vais me renseigner, c'est une question intéressante :)


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr

    lundi 8 juillet 2013 08:51
    Modérateur
  • Bonjour, 

    Vous pouvez utiliser la langue française sur ce forum. Je ne retrouve plus la référence mais il me semble que l'on ne puisse pas changer les ports par défaut directement. Peut-etre que d'autres personnes ont eu cette problèmatique ou qu'il y a une clé de registre. Je vais me renseigner, c'est une question intéressante :)


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr

    Bonjour,

    C'est probablement qqchose de ce genre oui.. clef de registre ou fichier.config à paramétrer (je n'ai pas trouvé de référence au port 2525 dans les 2 cas).

    Ce qui est bizarre, c'est qu'on puisse changer le port du connecteur par défaut 2525... c'est même dans l'interface EAC...mais que la partie "proxy" ne checke pas le port sur lequel il faut envoyer.. (je m'attendais à un processus de détection, via le "healthcheck", qui aurait pu déclencher une détection si le port 2525 ne répond pas... mais à priori.. non....)

    Cdt,


    lundi 8 juillet 2013 08:56
  • Merci de votre retour.

    Comme vous l'indiquiez cela devrait être possible car lorsque les rôles sont "splité" c'est le port 25 qui est utilisé pour ce connecteur et il ne devient 2525 qu'en multirole.

    Je vérifie sur mes plateformes et auprès de MS. Petite question êtes vous en CU1?

    Merci


    Hakim Taoussi

    lundi 8 juillet 2013 09:49
  • L'architecture est composée d'1 seul serveur Exchange 2013 CU1, sur Windows 2012.

    Il cohabite avec un serveur Exchange 2010 SP3/Windows 2008R2

    Je viens de supprimer Exchange 2003 et les dossiers publics.

    Le domaine est un domaine Windows 2012 avec 2 AD/GC/DNS. Foret 2012 / Domaine 2012.

    lundi 8 juillet 2013 11:04
  • Bonjour

    Apres de nombreux tests et interrogations à MS, je n'ai aucune réponse malheureusement positive.

    En effet dans les logs de connectivity, on voit bien l'activité de routage (check) s'effectué sur le 2525 et une fois changé, échec.

    La seule solution serait de spliter les roles :( hors il n'est pas possible de decommisionner un role seul sur Exchange 2013

    Avez vous peut etre trouver une autre solution et nous la faire partager? ;-)

    Merci


    Hakim Taoussi

    mercredi 17 juillet 2013 06:03
  • Aucune réponse non plus de mon côté, je vais continuer à creuser.

    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr

    mercredi 17 juillet 2013 06:53
    Modérateur
  •  Bonjour,

     mauvaises nouvelles donc... je suis un peu étonné que ça ne soit pas possible... (un oubli de MS ?).

     Pas mieux de mon coté. Je backupe avec WB en attendant.

     Merci pour vos recherches en tout cas.

    Cdt

    Stéphane Leleu


    mercredi 17 juillet 2013 07:22
  • Bonjour,

    J'ai exactement le même problème et je n'ai pas eu de réponse positive de la part de Microsoft.

    Il semble que le port 2525 soit codé en dur dans Exchange 2013.

    De toutes façons en ce qui concerne Time Navigator, il faut attendre la version 4.3 SP3 qui prendra en charge Exchange 2013.

    Avez-vous d'autres informations depuis ?

    Cordialement,

    Sébastien LEFEVRE


    mardi 8 octobre 2013 08:50
  • Bonjour,

    En recoupant les informations et les "on dit", il semblerait en effet que le port 2525 soit en dur dans la configuration (en tout cas, personne ne sait le modifier..)

    Du coup, pas mieux... en attente (comme d'habitude) d'une nouvelle version de TiNa à réinstaller, en modifiant le port...

    Cdt,

    mardi 8 octobre 2013 08:57
  • Merci pour votre réponse.
    mardi 8 octobre 2013 09:24
  • Oui en dur. Idem il faut éviter de trop changer la partie IIS

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 8 octobre 2013 12:27
    Modérateur