locked
Faire fonctionner le multicast avec WDS et MDT RRS feed

  • Question

  • Bonjour,

     

    Je n'arrive pas à faire marcher le multicast avec WDS et MDT 2010.

    Voici un petit résumé de mon infrastructure de déploiement :

    • DHCP Linux
    • WDS, MDT et PXE sur le même serveur sous 2008R2

    Tout marche nickel. J'ai fait un deploymentshare qui fonctionne au poil. 

    Donc actuellement, pour déployer Windows 7, je démarre mon client en pxe, je choisis l'image de démarrage correspondant à mon deploymentshare et hop :).

    Mais voilà, je voudrais faire du multicast. Alors j'ai coché la case Enable multicast et mis à jour le deploymentshare ainsi que l'image de démarrage dans WDS.

    Dans WDS / Transmission par multidiffusion s'est créée une entrée du nom de mon deploymentshare.

    Quand je tente d'installer un client, celui affiche très rapidement lors de l'action Install operating system, Attempting multicast transfert, puis passe à la suite et installe windows 7. Le client n'apparaît pas dans la console de WDS.

    Dans C:\Windows\tracing\WDSServer.log, je n'ai trouvé que ça :

    [2260] 15:24:07: [WDSMC][RPC][Ep:{6F13A317-3687-4B54-81A5-504DAA9062FA}] Request Received From:192.168.9.114 Len:576 Auth:Yes
    [1488] 15:24:08: [UDPPorts] Allocated dynamic port 49958.
    [1488] 15:24:08: Dynamic Port: 49958
    [1488] 15:24:08: [WDSMC][UDP][Ep=49958] Registered
    [1488] 15:24:08: UpdEndpoint::UdpEndpoint = 0000000001319260
    
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\madcaphandler.cpp:446] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\madcaphandler.cpp:947] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\multicasthandler.cpp:280] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\udpendpoint.cpp:139] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [WDSMC][UDP][Ep=192.168.0.22:49958] Creation Failed (rc=2)
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\udphandler.cpp:499] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [WDSMC][UDP][Ep=192.168.0.22:49958] Deleted.
    [1488] 15:24:08: UpdEndpoint::~UdpEndpoint = 0000000001319260
    
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\udphandler.cpp:302] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [WDSMC][UDP][Ep=0] Registration Failed (rc=2)
    [1488] 15:24:08: [WDSMC][UDP][Ep=0] Closed
    [1488] 15:24:08: [UDPPorts] Dynamic Port 49958 freed.
    [1488] 15:24:08: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\ifhandler.cpp:227] Expression: , Win32 Error=0x2
    [1488] 15:24:08: [WDSMC][RPC][Ep:{6F13A317-3687-4B54-81A5-504DAA9062FA}] Client:192.168.9.114 Request Cancelled (rc=0)
    


    Les "Rules" de mon deploymentshare

    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    
    [Default]
    OSInstall=Y
    SkipAppsOnUpgrade=YES
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipUserData=YES
    UserDataLocation=AUTO
    SkipLocaleSelection=YES
    SkipTimeZone=YES
    SkipApplications=NO
    SkipBitLocker=YES
    DoNotCreateExtraPartition=YES
    
    SkipTaskSequence=YES
    TaskSequenceID=INFO-WIN7X64-003
    SkipSummary=YES
    SkipBDDWelcome=NO
    SkipFinalSummary=YES
    
    UILanguage=fr-FR
    UserLocale=fr-FR
    KeyboardLocale=040c:0000040c
    
    TimeZone=105
    TimeZoneName=Romance Standard Time 
    
    JoinDomain=domain.fr
    DomainAdmin=DOMAIN\o-mdtjoin
    DomainAdminPassword=pass 
    MachineObjectOU=OU=Ordinateurs,DC=domain,DC=fr
    

    Quelqu'un aurait une idée du pourquoi ça marche pas :) ?

    Merci d'avance.

    mercredi 25 janvier 2012 15:45

Réponses

  • Bon et bien j'ai trouvé un peu par hasard une solution ;)

     

    Dans les propriétés de WDS, onglet Multidiffusion, j'avais sélectionné Obtenir l'adresse IP par DHCP. 

    J'ai sélectionné Utiliser des adresses dans la plage suivante... et hop ça marche.

    La première solution devait être si le serveur DHCP est sur la même machine, je suppose.

     

    Bref. Maintenant, on passe à Windows 7.

    • Marqué comme réponse sinjiku mercredi 25 janvier 2012 16:31
    mercredi 25 janvier 2012 16:31

Toutes les réponses

  • J'oublié de mentionner l'observateur d'évènement où deux messages d'erreur se trouvent :

     

    Nom du journal :Application
    
    Source :       WDSServer
    
    Date :         25/01/2012 15:08:17
    
    ID de l’événement :1539
    
    Catégorie de la tâche :WDSServer
    
    Niveau :       Erreur
    
    Mots clés :    Classique
    
    Utilisateur :  N/A
    
    Ordinateur :   mytus.iut.bx1
    
    Description :
    
    Aucun serveur MADCAP disponible sur l’interface 192.168.0.22 (serveur WDS)
    


     

     

     

     

    Nom du journal :Application
    
    Source :       WDSServer
    
    Date :         25/01/2012 15:08:17
    
    ID de l’événement :772
    
    Catégorie de la tâche :WDSServer
    
    Niveau :       Erreur
    
    Mots clés :    Classique
    
    Utilisateur :  N/A
    
    Ordinateur :   mytus.iut.bx1
    
    Description :
    
    Une erreur s’est produite lors de la création du point de terminaison UDP pour le fournisseur WDSMC sur l’interface 192.168.0.22:50636. Cette erreur peut se produire si l’interface réseau a été désactivée ou modifiée, ou si une autre application utilise déjà le port. Le fournisseur  ne pourra pas recevoir de demandes sur cette interface. 
    
     
    
     Informations sur l’erreur : 0x2
    
    
    
    
    
    


     

     

     

     


    • Modifié sinjiku mercredi 25 janvier 2012 16:04
    mercredi 25 janvier 2012 16:03
  • Bon et bien j'ai trouvé un peu par hasard une solution ;)

     

    Dans les propriétés de WDS, onglet Multidiffusion, j'avais sélectionné Obtenir l'adresse IP par DHCP. 

    J'ai sélectionné Utiliser des adresses dans la plage suivante... et hop ça marche.

    La première solution devait être si le serveur DHCP est sur la même machine, je suppose.

     

    Bref. Maintenant, on passe à Windows 7.

    • Marqué comme réponse sinjiku mercredi 25 janvier 2012 16:31
    mercredi 25 janvier 2012 16:31