none
Deux site en https sur un serveur Sharepoint 2013 RRS feed

  • Question

  • Bonjour,

    J'ai crée deux applications web, une pour mon site principal et l'autre pour les mysites. Je voudrais que pour ces deux sites les utilisateurs y accède en ssl.

    Le problème est que lorsque je configure les bindings sur mon serveur IIS sur les deux sites et avec deux certificats différents j'obtiens l'erreur: "Un ou plusieurs sites utilisent la même liaison HTTPS configurée avec un certificat différent. Êtes vous sur de vouloir utiliser cette liaison HTTPS et réaffecter les autres sites pour utiliser le nouveau certificat ?"

    De plus, si j'utilise le même certificat, un des deux sites ne démarre pas et l'erreur suivante s'affiche: "Impossible de démarrer ce site web, un autre site web utilise le même port".

    Comment résoudre le problème ?

    Merci d'avance,

    Bastien


    jeudi 17 avril 2014 09:53

Réponses

Toutes les réponses

  • La version d'IIS antérieur à 7.5 ne peut pas écouter sur le port 443 pour deux sites différents, donc un seul site IIS pourra être configuré sur le port 443 avec son certificat SSL associé.

    Si vous etes sous IIS 7.5 (sous W2012), je vous invite à suivre l'article suivant pour configurer vos deux sites :

    http://blogs.msdn.com/b/varunm/archive/2013/06/18/bind-multiple-sites-on-same-ip-address-and-port-in-ssl.aspx


    Hicham KADIRI | IT Consultant /Director. MCP - MCSA - MCTS - MCSE - MCITP - MCT

    jeudi 17 avril 2014 10:57
  • Merci de la réponse,

    J'ai finalement ajouté une deuxième adresse IP à la carte réseau et tout est rentré dans l'ordre.

    Bastien

    jeudi 17 avril 2014 14:58
  • Merci Minilef pour votre retour!


    Microsoft SharePoint MVP. Community Warrior. Managing Consultant. TechNet Addict. Gokan contributes on @WikiNinjas.

    vendredi 18 avril 2014 07:38