none
Problème Powershell Exchange 2013 WS2012 R2 RRS feed

  • Question

  • Bonjour à tous,

    Lors de l'installation d'Exchange 2013 sur mon DC 2012 R2 (avec tous les prérequis d'installer) 

    J'ai une erreur: L'application powershell n'existe pas dans le site web par défaut de C:\Windows\System32\Inetsrv\config\applicationhost.config 

    Assurez vous que l'application n'a pas été supprimé du site web par défaut. 

    J'ai chercher sur Internet sans pour autant trouver quelque chose de similaire.

    J'espère que vous pourrez m'aider d'avantage.

    Cordialement, 


    Vers l'infini et au delà

    mercredi 5 novembre 2014 10:34

Réponses

  • Bonjour,

    [Avis personnel]

    Si c'est un serveur de test, je pense que vous perdriez moins de temps en partant d'une installation propre que de solutionner la problématique actuelle.

    L'installation d'un Windows Server 2012 ne prend que quelques minutes ...

    Pour ce qui est de l'installation d'un Exchange 2013 dans les bonnes pratiques tout est là : http://technet.microsoft.com/fr-fr/library/bb691354%28v=exchg.150%29.aspx


    m.geyer

    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    jeudi 6 novembre 2014 14:21
  • Exchange n'aime pas etre colocalise avec d'autres roles, c'est particulierement vrai avec un DC, mais vu le nombre de roles presents, il y a tres peu de chance d'arriver a quoi que ce soit.

    Vous avez le role HyperV installem pourquoi ne pas avec installe Exchange sur une VM?


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Proposé comme réponse Teodora Sharkova vendredi 7 novembre 2014 15:12
    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:22
    • Non marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    jeudi 6 novembre 2014 14:24
    Modérateur
  • Y a t'il des particularités à l'installation de Exchange dans une VM?

    Si c'est uniquement pour un lab, il y a moins de contraintes, je vous suggère cependant de ne pas utiliser la mémoire dynamique ou l'hyperthreading.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 7 novembre 2014 20:03
    Modérateur

Toutes les réponses

  • Avez vous bien la version Exchange 2013 SP1 ou CU 5 ou 6?

    Sinon vous avez plus d'information dans le fichier c:\exchangesetuplog\ExchangeSetup.log


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 5 novembre 2014 20:34
    Modérateur
  • Merci pour votre réponse,

    Oui j'ai bien Exchange 2013 SP1

    Comme il y a eu des erreurs à la chaînes, j'ai trouver un tutoriel afin de pouvoir supprimer les éléments de Exchange afin de tenter une réinstallation.

    J'ai recommencé et l'installation c'est stoppée cette fois ci à la tâche "rôle de boite au lettre, service d'accès au client"  .

    Erreur lors de l’install de « Service d’accès au client »

     Mais j'ai à nouveau une erreur:

    Une erreur inattendue s'est produite et un vidage Watson est en cours de génération : L'erreur suivante est survenue lors de l'exécution de "$error.Clear();

              . "$RoleInstallPath\Scripts\ConfigureNetworkProtocolParameters.ps1";

              Enable-RpcOverTcpPortScaling;

              Enable-ExtendedTcpPortRange

            " : "L’exécution de la commande s’est arrêtée, car la variable de préférence « ErrorActionPreference » ou le paramètre courant a la valeur Stop : La clé de Registre n'existe pas à l'emplacement spécifié.".

    PS: C'est un serveur de test perso mais j'aimerais éviter une réinstallation de Windows Serveur 2012 R2

    (ISO provenant de Dreamspark et vérifié)


    Vers l'infini et au delà


    • Modifié Kévin LC jeudi 6 novembre 2014 13:53
    jeudi 6 novembre 2014 13:51
  • Est ce qu'il y a d'autres roles installes sur le serveur, comme par exemple ADDS?

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    jeudi 6 novembre 2014 14:07
    Modérateur
  • Oui, alors:

    - ADDS

    - DNS

    - DHCP

    - HyperV

    - RAS

    - IIS

    - WDS


    Vers l'infini et au delà

    jeudi 6 novembre 2014 14:15
  • Bonjour,

    [Avis personnel]

    Si c'est un serveur de test, je pense que vous perdriez moins de temps en partant d'une installation propre que de solutionner la problématique actuelle.

    L'installation d'un Windows Server 2012 ne prend que quelques minutes ...

    Pour ce qui est de l'installation d'un Exchange 2013 dans les bonnes pratiques tout est là : http://technet.microsoft.com/fr-fr/library/bb691354%28v=exchg.150%29.aspx


    m.geyer

    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    jeudi 6 novembre 2014 14:21
  • Exchange n'aime pas etre colocalise avec d'autres roles, c'est particulierement vrai avec un DC, mais vu le nombre de roles presents, il y a tres peu de chance d'arriver a quoi que ce soit.

    Vous avez le role HyperV installem pourquoi ne pas avec installe Exchange sur une VM?


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Proposé comme réponse Teodora Sharkova vendredi 7 novembre 2014 15:12
    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:22
    • Non marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    • Marqué comme réponse Kévin LC vendredi 7 novembre 2014 20:23
    jeudi 6 novembre 2014 14:24
    Modérateur
  • Merci pour vos réponses.

    Effectivement vu que c'est un serveur de Test (en faite seul le DHCP est en prod) mais il y a pas mal de travail sur d'autres éléments que j'aimerais éviter de perdre.

    Je vais tenter de passer par la VM, ce sera plus facile.

    Avez vous une méthode pour enlever proprement Exchange du serveur?

    Y a t'il des particularités à l'installation de Exchange dans une VM?


    Vers l'infini et au delà


    • Modifié Kévin LC jeudi 6 novembre 2014 15:41
    jeudi 6 novembre 2014 15:40
  • Y a t'il des particularités à l'installation de Exchange dans une VM?

    Si c'est uniquement pour un lab, il y a moins de contraintes, je vous suggère cependant de ne pas utiliser la mémoire dynamique ou l'hyperthreading.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 7 novembre 2014 20:03
    Modérateur
  • Non pas spécialement.

     Merci pour vos réponse et vos conseils, je l'ai fait dans une VM finalement ça tourne mais au minimum :/

    Mon serveur de test commence à manquer de puissance



    Vers l'infini et au delà

    vendredi 7 novembre 2014 20:26