none
Impossible de executer la commande Set-AutodiscoveryVirtualdirectory RRS feed

  • Question

  • Bonjour,

    Nous essayons de configurer exchange 2013 en mode multi-tenant. Mais nous rencontrons un problème avec la commande powershell

    Set-AurodiscoverVirtualdirectory -Identity 'autodiscover (default Web Site)' -ExternalUrl 'https://autodiscover.domaine.tld/autodiscover/autodiscover.xml

    le résultat est:

    Impossible de trouver un paramètre correspondant au nom "ExternalUrl"

    Quelqu’un pourrait nous aider?

    Merci



    • Modifié south_noc mardi 27 août 2013 11:55
    mardi 27 août 2013 11:34

Réponses

  • Bonjour,

    il doit y avoir un problème d'apostrophe, guillemet ou autre, car cela fonctionne bien !

    Voici la syntaxe fonctionnant bien avec les guillemets:

    [PS] C:\Windows\system32>set-AutodiscoverVirtualDirectory -identity "TDSRV17\Autodiscover (Default Web Site)" -ExternalUrl "https://exchange.faqexchange.info/autodiscover/autodiscover.xml"

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(78 MCPs). https://mvp.support.microsoft.com/profile=CE2B565B-B13D-4C24-B04D-F0D5766D14A1 http://base.faqexchange.info

    • Proposé comme réponse Florin Ciuca jeudi 29 août 2013 08:47
    • Marqué comme réponse Florin Ciuca vendredi 30 août 2013 09:54
    mercredi 28 août 2013 14:59
    Modérateur
  • Bonjour,

    Problème réglé.

    Sur Exchange 2013  la commande Set-autodiscoverVirtualDirectory ne reconnait plus les  options -ExternalUrl et -InternalULR, car  ce n'est pas nécessaire.

    A plus

    • Marqué comme réponse Florin Ciuca vendredi 6 septembre 2013 13:30
    vendredi 6 septembre 2013 08:55

Toutes les réponses

  • Bonjour,

    il doit y avoir un problème d'apostrophe, guillemet ou autre, car cela fonctionne bien !

    Voici la syntaxe fonctionnant bien avec les guillemets:

    [PS] C:\Windows\system32>set-AutodiscoverVirtualDirectory -identity "TDSRV17\Autodiscover (Default Web Site)" -ExternalUrl "https://exchange.faqexchange.info/autodiscover/autodiscover.xml"

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(78 MCPs). https://mvp.support.microsoft.com/profile=CE2B565B-B13D-4C24-B04D-F0D5766D14A1 http://base.faqexchange.info

    • Proposé comme réponse Florin Ciuca jeudi 29 août 2013 08:47
    • Marqué comme réponse Florin Ciuca vendredi 30 août 2013 09:54
    mercredi 28 août 2013 14:59
    Modérateur
  • Bonjour,

    Problème réglé.

    Sur Exchange 2013  la commande Set-autodiscoverVirtualDirectory ne reconnait plus les  options -ExternalUrl et -InternalULR, car  ce n'est pas nécessaire.

    A plus

    • Marqué comme réponse Florin Ciuca vendredi 6 septembre 2013 13:30
    vendredi 6 septembre 2013 08:55
  • Bonjour Thierry,

    Il semble que cette fonction n'existe plus en Exchange 2016

    Get-AutodiscoverVirtualDirectory -Server  exchange-v-02 | Set-AutodiscoverV
    irtualDirectory -ExternalUrl "https://blablabla.fr/Autodiscover/Autodiscover.xml"
    Impossible de trouver un paramètre correspondant au nom « ExternalUrl ».
        + CategoryInfo          : InvalidArgument : (:) [Set-AutodiscoverVirtualDirectory], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,Set-AutodiscoverVirtualDirectory
        + PSComputerName        : exchange-v-02

    jeudi 6 août 2020 08:50
  • Pour aller plus loin, voici comment faire.

    Exécuter Powershell (pas le shell exchange)

    ajouter Le PSSnapin E2010

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010

    Get-AutodiscoverVirtualDirectory -Server  exchange-v-01 | Set-AutodiscoverVirtualDiectory -ExternalUrl "https://exchange-v-01/Autodiscover/Autodiscover.xml"

    Working fin ;)

    ceci afin de régler ce type de problème 

    Autodiscover Event ID 1 après l'installation de Exchange Server 2019 CU3 ou Exchange Server 2016 CU14 / CU17

    jeudi 6 août 2020 08:59