none
Lenteur HyperV R2 Windows 2012 Standard

    Discussion générale

  • Bonjour,

    J'ai un souci sur mon serveur en windows Hyper V2 R2.

    Ma machine :

    Dell PowerEdge R730 2 x Xeon E5 2660 v3 Carte RAID H730P

    256 RAM 3x 500 SSD (Raid 5) + 5 x 960 SSD (raid 5)

    Serveur installé en Hyper-V R2 windows 2012 Standard

    3 vm (1 vm Routeur, 1 vm AD 2012 R2, 1 Vm RDS 2012 R2).

    Jusque là cela fonctionne bien pas de pb de lenteur  général ni de réseau.

    En revanche par moment (cela peut-être 1 fois par semaine ou 2 fois par semaine) le serveur RDS se met à ramer (pb débit internet , pb accès aux ressources enfin tout accès aux applications). J'éteins les serveurs vm puis routeur, désactivation des cartes réseaux : la lenteur est sur l'hôte hyper V. Sur l'hôte aucun pb visible (ressource CPU, ram ) rien aucune activité écriture /lecture disque pourtant il rame. Pagefile n'indique pas de recommandation supplémentaire (systéme )

    Un redémarrage du serveur suffit à remettre les performances du serveur.... 

    La seule particularité c'est que je remonte en disque physique le raid 5 (5 x 960 ssd) des données pour augmenter les performances lecture/écriture, sur le serveur RDS (donc sur ce disque lecteur D par de vhdx).

    J'ai l'impression une fuite de mémoire mais impossible de diagnostiquer cela. Venant d'où ? de l'hyper V ou du RDS ?

    Aucune erreur de disques durs rien de visible dans le bios.

    J'ai pensé à un problème systéme.

    Si qqun peut m'éclairer .

    Merci d'avance.

    jeudi 8 mars 2018 08:53

Toutes les réponses

  • Bonjour ETECH01,

    Quelle est la dernière mise à jour que vous avez effectué ? J'ai trouve un hotfix qui pourra vous aider :

    https://support.microsoft.com/en-us/help/3055615/a-windows-server-2012-r2-server-becomes-slow-and-unresponsive-if-updat

    Je vous remercie par avance pour votre retour.

    Cordialement,
    Nedeltcho


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "Tel quel" sans garantie d'aucune sorte, explicite ou implicite. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 9 mars 2018 06:23
    Modérateur
  • Bonjour

    Merci de ce retour j'étais effectivement tombé sur ce patch mais quand je tente de l'installer j'ai le message "Cette mise à jour ne s'applique pas à votre ordinateur".

    Le serveur est à jour. 

    Je pense un problème sur le serveur hôte ?

    Une autre piste ?


    samedi 10 mars 2018 17:13
  • bonjour,

    sur vos VMs, quelle est la configuration de vos processeurs virtuels ?

    et aussi la RAM de vos VMs, est-elle statique ou dynamique ?

    etes vous en performances élévées sur l'hote ? et sur vos VMs ? (cela augmente nettement les performances processeur de vos VMs)

    dimanche 11 mars 2018 07:27
  • Bonjour

    Bon voilà de nouveau lenteur de nouveau à partir de 19h30 alors que pas grand monde sur le serveur....

    vm routeur(linux) -> 1 virtuel / 2 Go Ram

    vm ad -> 6 processeurs virtuels / 8 go Ram

    vm RDS -> 25 processuers virtuels / 92 go ram (j'en avais moins c'est pareil) .

    Pas de mémoire dynamique. 

    Performances élevées ? Dans alimentation dans le bios oui.

    Pour rappel, dès que je redémarre tout est nickel pas de ralentissement serveur performant. 

    Merci

    mardi 13 mars 2018 19:59
  • Bonjour,

    Voila quelques idées :

    -Lancer les outils de diagnostique au niveau du POST/BIOS/UEFI (tests CPU / MEM / HDD etc..)

    -Lancer sous Windows un SFC /scanow et un CHKDSK.

    -Lancer les MAJ Windows.

    -Mettre à jour les derniers BIOS / PILOTES (carte mère / réseau / vidéo / son / carte RAID / firmware HDD etc..)

    -Désinstaller puis réinstaller le dernier framework.

    -Utilisation commande DISM (pour réparer le Windows).

    Attention
    -Il faut s'assurer que le serveur physique supporte bien la version du Windows serveur pour être sur de trouver les bon pilotes.
    -En cas de problème de démarrage, lancer un démarrage sans-échec réussi, conforte dans l'hypotese de problèmes avec les pilotes.

    Un MCSE un peu perdu...

    mercredi 28 mars 2018 21:14
  • Bonjour,

    vm RDS -> 25 processuers virtuels / 92 go ram (j'en avais moins c'est pareil) . ?????????????

    C'est totalement inutile. En fonction de la charge etc on size la vm correctement mais en principe 2 ou 4 processeur sont largement suffisants.

    92Go de ram, cela est nécessaire pour des application très lourdes également ou alors avec de nombreuses connexion utilisateurs mais dans ce cas là, c'est beaucoup mieux d'avoir plusieurs serveurs.

    De la même manière, 6 vcpu pour un AD c'est trop... 2 sont suffisant généralement.

    Au niveau du serveur physique en effet il faut tout mettre à jour au niveau bios, firmware et driver.

    Sinon des pistes supplémentaires à explorer :

    -Installation des mises à jour windows en cours quand le serveur rame

    -analyse antivirus

    -backup

    jeudi 29 mars 2018 06:49
  • > vm routeur(linux) -> 1 virtuel / 2 Go Ram

    C'est trop 1 Go de ram suffit largement.

    vm ad -> 6 processeurs virtuels / 8 go Ram

    2 proc et 4 go c'est déjà royal pour 20 a 50 utilisateurs

    vm RDS -> 25 processuers virtuels / 92 go ram (j'en avais moins c'est pareil) .

    Combien d'utilisateurs en simultanés ?

    Autrement il faut peut-être aller voir du coté des IO sur les systèmes de disque dur de l’hôte, c'est très souvent le goulet d’étranglement, attention aussi a ce que tous les disques raid soient a la même vitesse d'accès si vous avez des 10 000 tours/mn et des 15 000 tout fonctionnera en 10 000 tours/mn.

    Suivant le matériel que vous détenez les contructeurs peuvent vous offrir des outils qui peuvent vous orientez dans un audit matériel.

    Autrement accélérateur significatif intéressant disque SSD pour l’hôte.

    Cordialement.

    GGA.

    jeudi 29 mars 2018 09:57