locked
Problème avec groupes local de domaine RRS feed

  • Question

  • Bonjour,

    Je vous explique mon problème.
    Depuis quelques temps, (je ne pourrais dire quand).
    Il m'est impossible de voir tous les groupes locaux de domaine lorsque je veux créer un partage et ceux quelques soit le poste ou le serveur que j'ai dans mon domaine.

    Je ne parviens pas à voir d'où peut venir le problème.
    Sur les postes, je vois les SID avec un point ? (sans voir le nom des groupes).

    Je ne sais pas si je suis claire.
    Mais peut vous fournir d'autres informations.

    Merci

    jeudi 4 décembre 2008 08:54

Réponses

  •  wmsa A écrit:
    Je me suis mal exprimé.
    Ma zone principale est bien intégré a Active Directory.
    Le DC 2003 faisant aussi office de serveur DNS, dispose aussi de la même zone que le DC 2000.

    Les zones secondaires, appartiennent à des zones DNS de forêt différentes, qui elles aussi ont un nom DNS sans extension.
    J'ai simplement supprimer ces zones secondaires du DC 2003.
    Mais elles sont toujours disponibles sur l'autre DC 2000, sur lequel je n'ai pas de message d'erreur au niveau de l'eventlog DNS.

    Par contre ça ne résout pas mon problème avec les groupes locaux qui ne sont toujours pas visible.


    Pour rappel, un groupe de domaine local ne s'affiche que sur les DCs car il n'y a pas de base locale sur un DC, c'est fait pour avoir un équivalent.

    Sur n'importe quel autre poste du domaine un groupe de domaine local n'apparait pas car ces postes ont leurs propre base locale justement

    Si je me rappel bien le comportement est différent si le domaine est en mode mixte

    Pour rappel

    Un compte->se mets dans un groupe global->se met dans un groupe (de domaine sur un DC) local->qui est assigné à une ressource local

    jeudi 4 décembre 2008 15:25

Toutes les réponses

  • Peux tu nous donner plus de détails (des captures d'écrans aideraient)
    jeudi 4 décembre 2008 11:10
  • Bonjour,

     

    ce problème se produit généralement lorsque le DC ayant le rôle Emulateur PDC n'est pas joignable ou un problème de DNS ne te permet pas les enregistrements SRV pour le service LDAP et les catalogues globaux.

     

     

    Le problème se produit sur tous les postes ?

    >> Si oui, lances un netdiag /test sur un de tes DC.

     

    Tu as plusieurs DCs ?

     

    @bientôt

    jeudi 4 décembre 2008 12:09
  • Merci déjà pour cette réponse.
    J'ai un DC en 2000 et l'autre en 2003 R2.
    J'ai effectivement constaté des messages d'erreur au niveau de l'eventlog pour le DNS.

    Oui le problème ce produit sur tous les postes.
    LE message suivant apparait uniquement sur le 2003 R2

    Type de l'événement :    Erreur
    Source de l'événement :    DNS
    Catégorie de l'événement :    Aucun
    ID de l'événement :    4004
    Date :        04/12/2008
    Heure :        12:02:48
    Utilisateur :    N/A
    Ordinateur :    SRVDC
    Description :
    Le serveur DNS n'a pas pu terminer l'énumération du service d'annuaire de la  zone XXXXXXXX. Ce serveur DNS est configuré pour utiliser les informations à partir  de Active Directory pour cette zone et il ne peut pas charger la zone sans  celles-ci. Vérifiez que Active Directory fonctionne correctement et répétez  l'énumération de la zone. L'information de débogage d'erreur étendue (qui peut être vide) est "". Les données d'événement contiennent l'erreur.

    Pour plus d'informations, consultez le centre Aide et support à l'adresse http://go.microsoft.com/fwlink/events.asp.
    Données :
    0000: 2a 23 00 00               *#..   

    Je précise que le nom de domaine est sans extension.
    D'autre part il y à des relations d'approbation en 4 sites distant et j'ai recuper

    Quel information importante je dois regarder avec netdiag /test.
    jeudi 4 décembre 2008 12:42
  •  

    Quelle est la configuration de ton client DNS sur tes DC ?

     

    Peux-tu lire ceci et nous dire les tests que tu as pu effectué et tes conclusions : http://eventid.net/display.asp?eventid=4004&eventno=334&source=DNS&phase=1

     

    Avec netdiag /test tu dois vérifier s'il n'y a pas de message d'erreur.

     

    Je crois que tu n'as pas fini ta phrase concernant les sites distants Wink

     

     

    jeudi 4 décembre 2008 13:49
  • En faite pour finir la phrase c'est que j'ai mis des zones secondaires sur les deux contrôleurs de domaine.
    Du coup je venais justement des les supprimer de mon DC 2003. Pour le moment je n'ai plus de message d'erreurs dans les logs DNS.

    Je ne sais pas si cela est en rapport direct avec mon problème.
    Je vais voir les tests que vous proposez sur le lien plus haut.

    Avec Netdiag et DCdiag, tous les testent passed


    Netcard queries test . . . . . . . : Passed
        GetStats failed for 'Parallèle direct'. [ERROR_NOT_SUPPORTED]
        [WARNING] The net card 'Miniport réseau étendu WAN (PPTP)' may not be working because it has not received any packets.
        [WARNING] The net card 'Miniport WAN (PPPOE)' may not be working because it has not received any packets.
        [WARNING] The net card 'Miniport WAN (IP)' may not be working because it has not received any packets.
        GetStats failed for 'Miniport réseau étendu WAN (L2TP)'. [ERROR_NOT_SUPPORTED]

    Per interface results:

        Adapter : Connexion au réseau local 2
            Netcard queries test . . . : Passed
            AutoConfiguration results. . . . . . : Passed
            Default gateway test . . . : Passed
            NetBT name test. . . . . . : Passed
            [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names is missing.
            WINS service test. . . . . : Passed
    Global results:
    Domain membership test . . . . . . : Passed
    NetBT transports test. . . . . . . : Passed
        List of NetBt transports currently configured:
            NetBT_Tcpip_{59CEDA56-5134-43E6-B411-0BD536412140}
        1 NetBt transport currently configured.
    Autonet address test . . . . . . . : Passed
    IP loopback ping test. . . . . . . : Passed
    Default gateway test . . . . . . . : Passed
    NetBT name test. . . . . . . . . . : Passed
        [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.
    Winsock test . . . . . . . . . . . : Passed
    DNS test . . . . . . . . . . . . . : Passed
        PASS - All the DNS entries for DC are registered on DNS server 'XXX.XXX.XXX.XXX' and other DCs also have some of the names registered.
        PASS - All the DNS entries for DC are registered on DNS server '
    'XXX.XXX.XXX.XXX' and other DCs also have some of the names registered.

    Redir and Browser test . . . . . . : Passed
        List of NetBt transports currently bound to the Redir
            NetBT_Tcpip_{59CEDA56-5134-43E6-B411-0BD536412140}
        The redir is bound to 1 NetBt transport.

        List of NetBt transports currently bound to the browser
            NetBT_Tcpip_{59CEDA56-5134-43E6-B411-0BD536412140}
        The browser is bound to 1 NetBt transport.
    DC discovery test. . . . . . . . . : Passed
    DC list test . . . . . . . . . . . : Passed
    Trust relationship test. . . . . . : Passed
        Secure channel for domain 'XXXXXX' is to '\\srvdc2K.XXXXXXXXX'.
    Kerberos test. . . . . . . . . . . : Passed
    LDAP test. . . . . . . . . . . . . : Passed
    Bindings test. . . . . . . . . . . : Passed
    WAN configuration test . . . . . . : Skipped
        No active remote access connections.
    Modem diagnostics test . . . . . . : Passed
    IP Security test . . . . . . . . . : Skipped

        Note: run "netsh ipsec dynamic show /?" for more detailed information

    LA deuxième carte réseau est désactivé.
    Depuis l'apparition du problème je n'ai pas démarré le DC en Windows 2000.
    jeudi 4 décembre 2008 14:06
  •  

    s'il n'y a pas d'erreur dans ton dcdiag et netdiag c'est trés bien.

     

     

    Concernant le fait que tu sois en zone secondaire c'est un peu bizarre effectivement.

    Du coup tu es repassé en zone primaire (intégrée à l'AD) et le problème est resolu ?

     

    jeudi 4 décembre 2008 14:55
  • Je me suis mal exprimé.
    Ma zone principale est bien intégré a Active Directory.
    Le DC 2003 faisant aussi office de serveur DNS, dispose aussi de la même zone que le DC 2000.

    Les zones secondaires, appartiennent à des zones DNS de forêt différentes, qui elles aussi ont un nom DNS sans extension.
    J'ai simplement supprimer ces zones secondaires du DC 2003.
    Mais elles sont toujours disponibles sur l'autre DC 2000, sur lequel je n'ai pas de message d'erreur au niveau de l'eventlog DNS.

    Par contre ça ne résout pas mon problème avec les groupes locaux qui ne sont toujours pas visible.
    jeudi 4 décembre 2008 14:59
  •  

    Tu pourrais nous copier/coller le résultat du dcdiag de tes deux DC ?
    jeudi 4 décembre 2008 15:15
  •  wmsa A écrit:
    Je me suis mal exprimé.
    Ma zone principale est bien intégré a Active Directory.
    Le DC 2003 faisant aussi office de serveur DNS, dispose aussi de la même zone que le DC 2000.

    Les zones secondaires, appartiennent à des zones DNS de forêt différentes, qui elles aussi ont un nom DNS sans extension.
    J'ai simplement supprimer ces zones secondaires du DC 2003.
    Mais elles sont toujours disponibles sur l'autre DC 2000, sur lequel je n'ai pas de message d'erreur au niveau de l'eventlog DNS.

    Par contre ça ne résout pas mon problème avec les groupes locaux qui ne sont toujours pas visible.


    Pour rappel, un groupe de domaine local ne s'affiche que sur les DCs car il n'y a pas de base locale sur un DC, c'est fait pour avoir un équivalent.

    Sur n'importe quel autre poste du domaine un groupe de domaine local n'apparait pas car ces postes ont leurs propre base locale justement

    Si je me rappel bien le comportement est différent si le domaine est en mode mixte

    Pour rappel

    Un compte->se mets dans un groupe global->se met dans un groupe (de domaine sur un DC) local->qui est assigné à une ressource local

    jeudi 4 décembre 2008 15:25
  • Pas de problème

    DCDIAG du DC 2003

    Domain Controller Diagnosis
    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests
      
       Testing server: Premier-Site-par-defaut\SRVDC01
          Starting test: Connectivity
             ......................... SRVDC01 passed test Connectivity
    Doing primary tests
     
      Testing server: Premier-Site-par-defaut\SRVDC01
          Starting test: Replications
             ......................... SRVDC01 passed test Replications
          Starting test: NCSecDesc
             ......................... SRVDC01 passed test NCSecDesc
          Starting test: NetLogons
             ......................... SRVDC01 passed test NetLogons
          Starting test: Advertising
             ......................... SRVDC01 passed test Advertising
          Starting test: KnowsOfRoleHolders
             ......................... SRVDC01 passed test KnowsOfRoleHolders
          Starting test: RidManager
             ......................... SRVDC01 passed test RidManager
          Starting test: MachineAccount
             ......................... SRVDC01 passed test MachineAccount
          Starting test: Services
             ......................... SRVDC01 passed test Services
          Starting test: ObjectsReplicated
             ......................... SRVDC01 passed test ObjectsReplicated
          Starting test: frssysvol
             ......................... SRVDC01 passed test frssysvol
          Starting test: frsevent
             ......................... SRVDC01 passed test frsevent
          Starting test: kccevent
             ......................... SRVDC01 passed test kccevent
          Starting test: systemlog
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   15:21:48
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   15:21:48
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   15:21:48
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   15:21:49
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   15:21:49
                (Event String could not be retrieved)
             ......................... SRVDC01 failed test systemlog
          Starting test: VerifyReferences
             ......................... SRVDC01 passed test VerifyReferences
      
       Running partition tests on : Schema
          Starting test: CrossRefValidation
             ......................... Schema passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... Schema passed test CheckSDRefDom
      
       Running partition tests on : Configuration
          Starting test: CrossRefValidation
             ......................... Configuration passed test CrossRefValidation
          Starting test: CheckSDRefDom
             ......................... Configuration passed test CheckSDRefDom
      
       Running partition tests on :
    domaine XXXXXXX
          Starting test: CrossRefValidation

             ......................... domaine
    XXXXXXX passed test CrossRefValidation
          Starting test: CheckSDRefDom
             .........................
    domaine XXXXXXX passed test CheckSDRefDom
      
       Running enterprise tests on :
    domaine XXXXXXX
          Starting test: Intersite
             .........................
    domaine XXXXXXX passed test Intersite
          Starting test: FsmoCheck
             .........................
    domaine XXXXXXX passed test FsmoCheck

    Pour le DC en 2000

    Domain Controller Diagnosis

    Performing initial setup:
       Done gathering initial info.

    Doing initial required tests
      
       Testing server: Premier-Site-par-defaut\SRVDC00
          Starting test: Connectivity
             ......................... SRVDC00 passed test Connectivity

    Doing primary tests
      
       Testing server: Premier-Site-par-defaut\SRVDC00
          Starting test: Replications
             ......................... SRVDC00 passed test Replications
          Starting test: NCSecDesc
             ......................... SRVDC00 passed test NCSecDesc
          Starting test: NetLogons
             ......................... SRVDC00 passed test NetLogons
          Starting test: Advertising
             ......................... SRVDC00 passed test Advertising
          Starting test: KnowsOfRoleHolders
             ......................... SRVDC00 passed test KnowsOfRoleHolders
          Starting test: RidManager
             ......................... SRVDC00 passed test RidManager
          Starting test: MachineAccount
             ......................... SRVDC00 passed test MachineAccount
          Starting test: Services
             ......................... SRVDC00 passed test Services
          Starting test: ObjectsReplicated
             ......................... SRVDC00 passed test ObjectsReplicated
          Starting test: frssysvol
             ......................... SRVDC00 passed test frssysvol
          Starting test: kccevent
             ......................... SRVDC00 passed test kccevent
          Starting test: systemlog
             An Error Event occured.  EventID: 0x40011006
                Time Generated: 12/04/2008   15:29:51
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x40011006
                Time Generated: 12/04/2008   15:59:51
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   16:24:56
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 12/04/2008   16:24:56
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 12/04/2008   16:24:57
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000457
                Time Generated: 12/04/2008   16:24:58
                (Event String could not be retrieved)
             An Error Event occured.  EventID: 0x00000452
                Time Generated: 12/04/2008   16:24:58
                (Event String could not be retrieved)
             ......................... SRVDC00 failed test systemlog
      
       Running enterprise tests on : domaine XXXXXXX
          Starting test: Intersite
             ......................... domaine XXXXXXX passed test Intersite
          Starting test: FsmoCheck
             ......................... domaine XXXXXXX passed test FsmoCheck

    IL y a effectivement quelques erreur
    jeudi 4 décembre 2008 15:32
  • salut,

     

     wmsa A écrit:


    Je vous explique mon problème.
    Depuis quelques temps, (je ne pourrais dire quand).
    Il m'est impossible de voir tous les groupes locaux de domaine lorsque je veux créer un partage et ceux quelques soit le poste ou le serveur que j'ai dans mon domaine.

    Je ne parviens pas à voir d'où peut venir le problème.
    Sur les postes, je vois les SID avec un point ? (sans voir le nom des groupes).

    Je ne sais pas si je suis claire.
    Mais peut vous fournir d'autres informations.

    Merci

     

    Kazer a raison, faut être en mode natif  et non mixte !

     

    @+

    jeudi 4 décembre 2008 15:40
  • je crois pas que ce soit la bonne réponse.
    Je suis en mode Mixte, le mode natif permet l'imbrication de groupe et l'utilisation de groupe universel.

    Le faite d'avoir des serveurs de fichiers sur lesquels je dispose de partages, gérer par des groupes de domaine local créer sur AD, indique bien que cela fonctionne.

    A moins que je me trompe. Du coup pas sure que Kazer ai raison.
    Merci de votre suggestion.
    jeudi 4 décembre 2008 15:53
  • re,

     

     wmsa A écrit:
    je crois pas que ce soit la bonne réponse.
    Je suis en mode Mixte, le mode natif permet l'imbrication de groupe et l'utilisation de groupe universel.

    Le faite d'avoir des serveurs de fichiers sur lesquels je dispose de partages, gérer par des groupes de domaine local créer sur AD, indique bien que cela fonctionne.

    Et le faite de le tester en parallèle sur une domaine identique. Avec un seul DC prouve que cela fonctionne.
    Rien a voir avec le mode natif.

    A moins que je me trompe. Du coup pas sure que Kazer ai raison.
    Merci de votre suggestion.

     

    Tu as lu "Les groupes locaux de domaine ne peut pas être utilisées dans de domaine mixte-Mode" (

    http://support.microsoft.com/kb/296369) ?

     

    @+

    jeudi 4 décembre 2008 16:05
  • Merci pour l'info.
    Effectivement je ne l'avais pas lu.
    Du coup Merci à Kazer et à vous aussi.

    Ca fonctionné comme je l'ai dis plus haut. Mais c'est vrai que le controleur utilisé a ce moment pour les testent été l'unique DC en 2003.
    Du coup sa me rassure.




    jeudi 4 décembre 2008 20:23
  • Autant pour moi et bien vu Kazer !

     

    Du coup j'ai marqué uniquement ton post en réponse à ce topic.

     

    A bientôt

    vendredi 5 décembre 2008 09:17