locked
WDS ne démarre pas - Error=0x6ba RRS feed

  • Question

  • Bonjour

    J'ai tout juste installé le role WDS sur mon serveur W2k8R2 "PRODMDT" suite à la mise en place de MDT, sur ce même serveur, afin de déployer mon image LTI via PXE. J'ai un serveur DHCP et AD W2k3 sur le même sous réseau.

    Configuration par défaut

     

    Utilitaire de gestion des services de déploiement Windows [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. Tous droits réservés.
    
    
    INFORMATIONS D'INSTALLATION POUR LE SERVEUR 
    [-----------------------------------------------------------------------------]
    
    
    État du serveur :
      Version du système : 6.1
      Mode de fonctionnement WDS : Natif
    
    État de l'installation :
      Emplacement RemoteInstall : d:\WDS_Deploiement
      Partage RemoteInstall à jour : Oui
      Fichiers de démarrage installés :
       x86 - Oui
       x64 - Oui
       ia64 - Non
    
    
    [-----------------------------------------------------------------------------]
    
    
    INFORMATIONS DE CONFIGURATION POUR LE SERVEUR 
    [-----------------------------------------------------------------------------]
    
    
    Autorisation de serveur :
      État de l'autorisation : Autorisé
    
    Stratégie de réponse :
      Répondre aux clients : Oui
      Répondre uniquement aux clients connus : Non
      Délai de réponse : 0 secondes
    
    Stratégie d'utilisation Active Directory :
      Contrôleur de domaine préféré : 
      Catalogue global préféré : 
      Périphériques de préinstallation à l'aide de MAC : Non
      Stratégie de nommage des nouveaux ordinateurs : %61Username%#
      Ordre de recherche de domaine : Catalogue global uniquement
      Domaine de jointure des nouveaux ordinateurs : Oui
    
    Unité d'organisation Nouvel ordinateur :
      Type d'unité d'organisation : Personnalisé
      Unité d'organisation : OU=Stations_de_travail,OU=Organisation,DC=xxx,DC=fr
    
    Configuration DHCP :
      État du service DHCP : Non installé
      Option DHCP 60 configurée : <Non applicable>
    
    Stratégie de liaison PXE :
      Utiliser les ports DHCP : Oui
      Détection de serveurs non autorisés : Désactivé
      Port RPC : 5040
    
    Stratégie de liaison d'interface :
      Stratégie : Exclure les inscrits
      Interfaces inscrites :
    
    Stratégie de programme de démarrage :
      Stratégie d'invite PXE de client connu : OptOut
      Stratégie d'invite PXE de nouveau client : OptOut
      Autoriser N12 pour les nouveaux clients : <Non applicable>
      Découverte d'architecture : Activé
      Réinitialiser le programme de démarrage : Non
      Programmes de démarrage par défaut :
       x86 - boot\x86\pxeboot.com
       x64 - boot\x64\pxeboot.com
       ia64 - boot\ia64\bootmgfw.efi
      Programmes de démarrage N12 par défaut :
       x86 - boot\x86\pxeboot.n12
       x64 - boot\x64\pxeboot.n12
       ia64 - boot\ia64\bootmgfw.efi
    
    Liste des GUID bannis :
    
    Stratégie d'image de démarrage :
      Type d'image par défaut pour les clients x64 : Les deux
      Images de démarrage par défaut :
       x86 - 
       x64 - 
       ia64 - 
    
    Stratégie de client WDS :
      Stratégie d'enregistrement :
       Activée : Non
       Niveau d'enregistrement : Informations
    
      Stratégie autonome :
       Activée : Non
       Précédence de ligne de commande : Non
       Fichiers d'installation sans assistance WDS :
        x86 - 
        x64 - 
        ia64 - 
    
    Stratégie OSChooser :
      Nom de menu : 
    
    Stratégie d'actualisation automatique de serveur :
      Délai d'actualisation : 900 secondes
    
    Stratégie d'actualisation de BCD :
      Activée : Non
      Délai d'actualisation : 60 minutes
    
    Stratégie d'ajout automatique :
      Stratégie : Désactivé
      Intervalle d'interrogation : 10 secondes
      Nombre max. de tentatives : 2160 fois
      Message aux clients en attente : 
      Période de rétention :
       Périphériques approuvés : 30 jours
       Autres périphériques : 1 jours
      Valeurs par défaut pour x86 :
       Serveur de référence : 
       Chemin d'accès au programme de démarrage : 
       Chemin d'accès au fichier d'installation sans assistance client WDS : 
       Chemin d'accès à l'image de démarrage : 
       Utilisateur : Domain Admins
       Droits de jointure : Complet
       Domaine de jointure : Oui
      Valeurs par défaut pour x64 :
       Serveur de référence : 
       Chemin d'accès au programme de démarrage : 
       Chemin d'accès au fichier d'installation sans assistance client WDS : 
       Chemin d'accès à l'image de démarrage : 
       Utilisateur : Domain Admins
       Droits de jointure : Complet
       Domaine de jointure : Oui
      Valeurs par défaut pour ia64 :
       Serveur de référence : 
       Chemin d'accès au programme de démarrage : 
       Chemin d'accès au fichier d'installation sans assistance client WDS : 
       Chemin d'accès à l'image de démarrage : 
       Utilisateur : Domain Admins
       Droits de jointure : Complet
       Domaine de jointure : Oui
    
    Fournisseurs PXE WDS :
      Nom : BINLSVC
      Chemin d'accès : C:\Windows\system32\binlsvc.dll
      Ordre : 1
      Critique : Oui
    
    Stratégie du serveur WDS de transport :
      Source IPv4 : DHCP
       Adresse de début : <Non applicable>
       Adresse de fin : <Non applicable>
      Source IPv6 : Étendue
       Adresse de début : FF15::1
       Adresse de fin : FF15::FF
      Port de début : 64001
      Port de fin : 65000
      Profil réseau : <Non applicable>
      Stratégie de session de multidiffusion : 
       Stratégie de gestion des clients lents : Aucun
       Seuil de déconnexion automatique : 256 Kbits/s
       Nombre de flux multiflux : 2
       Comportement par défaut des clients lents : Oui
    
    
    [-----------------------------------------------------------------------------]
    
    
    INFORMATIONS SUR LES IMAGES POUR LE SERVEUR 
    [-----------------------------------------------------------------------------]
    
    
    IMAGES DE DÉMARRAGE
    ===============================================================================
    
    
    ------------------------------
    Images de démarrage pour x86
    ------------------------------
    Nombre d'images : 1
    
    ------------------------------
    Informations sur les images :
    ------------------------------
    
    
    MDT_LTI_x86
    
    Nom du fichier : LiteTouchPE_x86.wim
    Nom de l'image : MDT_LTI_x86
    Description : Image de déploiement créée par MDT
    Architecture : x86
    Type d'image : Démarrage
    Groupe d'images : <Non applicable>
    Taille : 914460057 octets
    Style de partition : Inconnu
    Type HAL : 
    Heure de création : samedi 20 novembre 2010 16:54:58
    Dernière modification : mercredi 10 août 2011 10:21:24
    Langue par défaut : Français (France)
    Autres langues :
    Fichiers dépendants :
      \\PRODMDT.xxx.fr\REMINST\Boot\x86\Images\LiteTouchPE_x86.wim
    Version du système d'exploitation : Microsoft® Windows® Operating System, 6.1.7601
    Niveau de Service Pack : 1
    Filtre utilisateur : <Non applicable>
    Fichier d'installation sans assistance présent : Non
    État : Activé
    *******************************************************************************
    
    
    ------------------------------
    Images de démarrage pour ia64
    ------------------------------
    Nombre d'images : 0
    
    ------------------------------
    Informations sur les images :
    ------------------------------
    
    
    Aucune image ne correspond aux critères spécifiés.
    
    
    ------------------------------
    Images de démarrage pour x64
    ------------------------------
    Nombre d'images : 0
    
    ------------------------------
    Informations sur les images :
    ------------------------------
    
    
    Aucune image ne correspond aux critères spécifiés.
    
    
    ===============================================================================
    
    --------
    Résumé :
    --------
    Nombre total de magasins d'images de démarrage : 3
    Nombre total d'images de démarrage : 1
    --------
    
    
    IMAGES D'INSTALLATION
    ===============================================================================
    
    
    Aucun groupe d'images ne correspond aux critères spécifiés.
    
    
    ===============================================================================
    
    --------
    Résumé :
    --------
    Nombre total de groupes d'images d'installation : 0
    Nombre total d'images d'installation : 0
    --------
    
    
    IMAGES NON NATIVES
    ===============================================================================
    
    
    ===============================================================================
    
    --------
    Résumé :
    --------
    Nombre total de groupes d'images non-WIM : 0
    Nombre total d'images non WIM : 0
    --------
    
    
    [-----------------------------------------------------------------------------]
    
    ------------------------------
    RÉSUMÉ GLOBAL SUR LES IMAGES :
    ------------------------------
    Nombre total de magasins d'images de démarrage : 3
    Nombre total d'images de démarrage : 1
    Nombre total de groupes d'images d'installation : 0
    Nombre total d'images d'installation : 0
    Nombre total de groupes d'images non WIM : 0
    Nombre total d'images non WIM : 0
    ----------------------
    
    La commande s'est terminée correctement.
    

     

    Malheureusement celui-ci ne démarre pas, j'ai l'erreur suivante dans les logs

     

    [3708] 11:08:04: ===>Starting logging of module [WDSServer]
    [3708] 11:08:04: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\madcaphandler.cpp:108] Expression: , Win32 Error=0x6ba
    [3708] 11:08:04: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\multicasthandler.cpp:76] Expression: , Win32 Error=0x6ba
    [3708] 11:08:04: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\ifhandler.cpp:71] Expression: , Win32 Error=0x6ba
    [3708] 11:08:04: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\wdsservice.cpp:159] Expression: , Win32 Error=0x6ba
    [3708] 11:08:04: [Udp] Listen Shutdown.
    [3708] 11:08:04: <===Ending logging of module [WDSServer]

     


    Avec les erreurs suivantes dans les jounreaux:

    Une erreur s’est produite lors de la tentative de démarrage du serveur des services de déploiement Windows.
     
     Informations sur l’erreur : 0x6BA

    et

    Le service Serveur des services de déploiement Windows s’est arrêté avec l’erreur service particulière Le serveur RPC n’est pas disponible..

    Si je modifie l'option suivante à

    dans le log, j'ai les erreurs suivantes :

     

    [3112] 12:16:06: ===>Starting logging of module [WDSServer]
    [3112] 12:16:06: [UDPPorts] Policy: 1, Dynamic Port Range: 64001-65000.
    [3112] 12:16:06: [RPC] Using Tcp Port 5040 for Rpc Calls.
    [3112] 12:16:06: [RPC] Client Impersonation Logging=Disabled
    [3112] 12:16:06: [RPC] Host Name: PRODMDT.xxx.fr
    [3112] 12:16:06: [RPC] NTLM/Kerberos Spn: ldap/PRODMDT.xxx.fr
    [3112] 12:16:06: [RPC] Initialized
    [944] 12:16:06: [RPC] Server Started.
    [3112] 12:16:06: [BINLSVC][RPC][Ep={5F4FB9F0-C0E3-41C1-AA00-9A7C690AC3A3}] Registered
    [3112] 12:16:06: [BINLSVC] Provider Initialized.
    [3112] 12:16:06: [WDSDDPS][RPC][Ep={FA0A27E1-C2BA-4B3B-94B2-025E82FFAA6D}] Registered
    [3112] 12:16:06: [WDSDDPS][RPC][Ep={011D24AC-CB3A-4739-A339-5D2E1B5306CE}] Registered
    [3112] 12:16:07: [WDSDDPS] Provider Initialized.
    [3112] 12:16:07: [640][WdsImgSrv] -> WdsProviderInitialize
    [3112] 12:16:07: [640][WdsImgSrv] GetDSSServer: Domain=
    [3112] 12:16:07: [640][WdsImgSrv] GetDSServer: Ldap Server=DC.xxx.fr
    [3112] 12:16:07: [640][WdsImgSrv] CLdap::Open: Server=DC.xxx.fr, Port=389, DN=
    
    [3112] 12:16:07: [640][WdsImgSrv] GetDSSServer: Domain=xxx.fr
    [3112] 12:16:07: [640][WdsImgSrv] GetDSServer: Ldap Server=DC.xxx.fr
    [3112] 12:16:07: [640][WdsImgSrv] CLdap::Open: Server=DC.xxx.fr, Port=389, DN=
    
    [3112] 12:16:07: [640][WdsImgSrv] -> pInitializeManagement
    [3112] 12:16:07: [718][WdsImgSrv] <- pInitializeManagement=0
    [3112] 12:16:07: [718][WdsImgSrv] -> pWdsImgSrvRefreshSettings
    [3112] 12:16:07: [890][WdsImgSrv] <- pWdsImgSrvRefreshSettings=0
    [3112] 12:16:07: [890][WdsImgSrv] Image Cache: Refreshing...
    [3112] 12:16:07: [906][WdsImgSrv] Image Cache: Total 0 Images Found.
    [3112] 12:16:07: [WdsImgSrv][RPC][Ep={D8DEEB5A-EFFD-43B2-99FC-1A8A5921C227}] Registered
    [3112] 12:16:07: [906][WdsImgSrv] <- WdsProviderInitialize=0
    [3112] 12:16:07: [WdsImgSrv] Provider Initialized.
    [3112] 12:16:07: [984][WDSMC] [d:\w7rtm\base\ntsetup\opktools\wds\wdslib\crypt\lib\cryptstore.cpp:111] Expression: , Win32 Error=0x8009000f
    [3112] 12:16:07: [984][WDSMC] [d:\w7rtm\base\ntsetup\opktools\wds\transport\server\mc\mcserver.cpp:195] Expression: , Win32 Error=0x8009000f
    [3112] 12:16:07: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\wdsprovider.cpp:144] Expression: , Win32 Error=0x8009000f
    [3112] 12:16:07: [WDSMC] Initialization Failed (rc=2148073487)
    [3112] 12:16:07: [984][WDSMC] [d:\w7rtm\base\ntsetup\opktools\wds\transport\server\mc\mcserver.cpp:398] Expression: , Win32 Error=0x57
    [3112] 12:16:07: [984][WDSMC] -> CContentProvidersHandler::Shutdown
    [3112] 12:16:07: [984][WDSMC] <- CContentProvidersHandler::Shutdown=0
    [3112] 12:16:07: [984][WDSMC] [d:\w7rtm\base\ntsetup\opktools\wds\transport\server\mc\mcserver.cpp:398] Expression: , Win32 Error=0x57
    [3112] 12:16:07: [984][WDSMC] -> CContentProvidersHandler::Shutdown
    [3112] 12:16:07: [984][WDSMC] <- CContentProvidersHandler::Shutdown=0
    [3112] 12:16:07: [984][WDSMC] -> CContentProvidersHandler::Shutdown
    [3112] 12:16:07: [984][WDSMC] <- CContentProvidersHandler::Shutdown=0
    [3112] 12:16:07: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\wdsprovhdl.cpp:172] Expression: , Win32 Error=0x8009000f
    [3112] 12:16:07: [WDSMC] Deleted.
    [3112] 12:16:07: [d:\w7rtm\base\ntsetup\opktools\wds\wdssrv\server\src\wdsservice.cpp:178] Expression: , Win32 Error=0x8009000f
    [3112] 12:16:07: [Udp] Listen Shutdown.
    [944] 12:16:07: [RPC] Server terminated (rc=0)
    [3112] 12:16:07: [RPC] Listen Stopped.
    [3112] 12:16:07: [BINLSVC] Shutting down
    [3112] 12:16:07: [BINLSVC][RPC][Ep={5F4FB9F0-C0E3-41C1-AA00-9A7C690AC3A3}] Closed
    [3112] 12:16:07: [BINLSVC] Deleted.
    [3112] 12:16:07: [WDSDDPS] Shutting down
    [3112] 12:16:07: [WDSDDPS][RPC][Ep={FA0A27E1-C2BA-4B3B-94B2-025E82FFAA6D}] Closed
    [3112] 12:16:07: [WDSDDPS][RPC][Ep={011D24AC-CB3A-4739-A339-5D2E1B5306CE}] Closed
    [3112] 12:16:07: [WDSDDPS] Deleted.
    [3112] 12:16:07: [WdsImgSrv] Shutting down
    [3112] 12:16:07: [1031][WdsImgSrv] -> WdsProviderShutdown
    [3112] 12:16:07: [WdsImgSrv][RPC][Ep={D8DEEB5A-EFFD-43B2-99FC-1A8A5921C227}] Closed
    [3112] 12:16:07: [1031][WdsImgSrv] <- WdsProviderShutdown=0
    [3112] 12:16:07: [WdsImgSrv] Deleted.
    [3112] 12:16:07: <===Ending logging of module [WDSServer]


     


    mercredi 10 août 2011 10:18

Réponses

  • Bonjour

     

    j'ai deja sorti le serveur du domaine, supprimer le compte AD et reintroduit : idem

    J'ai deja supprimer le role, redémarrer et réinstaller : idem, plante avec le même message d'erreur dès la fin de l'assistant de configuration du serveur .. je n'arrive pas a savoir qui il essaye de contacter pour avoir cette erreur RPC

     

     

     

     

    Comme j'ai dit au paravent il y un erreur système dont il faut restaurer votre machine 




    • Proposé comme réponse F.ABASSI mardi 16 août 2011 13:21
    • Marqué comme réponse GuiAg mardi 16 août 2011 13:22
    jeudi 11 août 2011 10:32

Toutes les réponses

  • Bonjour,

    Il parait que votre controleur de domaine n'autorise pas le remote rpc. Dans la configuration avancée du parfeu de votre controleur de domaine essaye d'autorise "Remote Service Management RPC" et tenez nous au courant suite à l'application de ce changement. ( tu peut désactiver le parfeu momentanément pour voir l'effet, si c'est OK tu pourra ainsi spécifier ce service et désactiver le parfeu)

    Merci


    Best Regards Don't forget to mark it as answer if it helps
    mercredi 10 août 2011 10:58
    Auteur de réponse
  • Bonjour,

     

    ->Essaye de démarrer tous d'abord le service RPC :> cmd -> services.msc -> Localisateur d'appels de prcédure distante (RPC) : Démarrer 

     

    -> Ensuite redmarrer le serveur WDS :    cmd -> wdsutil uninitialize-serveur 

                                                   puis   cmd -> wdsutil initialize-serveur /reminst: {RemoteInstallFolder}

     

    Bonne journée,

     

     


    http://fethiabassi.blogspot.com/ FETHI ABASSI } =========== [ DEPLOY Windows 7 with MDT 2010 update 1 & WDS ]

    Voter à cet article si vous trouvez utile:

    http://social.technet.microsoft.com/Forums/fr-FR/windowsserver2008fr/thread/1e685681-35be-4704-9cfa-251c93e555b5



    mercredi 10 août 2011 11:11
  • Bonjour,

    Merci du retours mais chez nous, le pare-feu Windows est Off sur nos serveurs locaux (on privilégie plus des pare-feu en frontal de notre infra) et la commande telnet DC 135 passe correctement

    mercredi 10 août 2011 12:32
  • Bonjour

     

    Merci du retours mais le résultat est le même

    C:\Windows\system32>wdsutil /Uninitialize-server
    
    Utilitaire de gestion des services de déploiement Windows [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. Tous droits réservés.
    
    La commande s'est terminée correctement.
    
    C:\Windows\system32>wdsutil /initialize-server /reminst:D:\WDS_Deploiement
    
    Utilitaire de gestion des services de déploiement Windows [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. Tous droits réservés.
    
    Une erreur s'est produite lors de la tentative d'exécution de la commande.
    Code d'erreur : 0x41D
    Description de l'erreur : Le service n'a pas répondu assez vite à la demande de lancement ou de contrôle.


    mercredi 10 août 2011 12:37
  • Bonjour

     

    Merci du retours mais le résultat est le même

    C:\Windows\system32>wdsutil /Uninitialize-server
    
    Utilitaire de gestion des services de déploiement Windows [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. Tous droits réservés.
    
    La commande s'est terminée correctement.
    
    C:\Windows\system32>wdsutil /initialize-server /reminst:D:\WDS_Deploiement
    
    Utilitaire de gestion des services de déploiement Windows [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. Tous droits réservés.
    
    Une erreur s'est produite lors de la tentative d'exécution de la commande.
    Code d'erreur : 0x41D
    Description de l'erreur : Le service n'a pas répondu assez vite à la demande de lancement ou de contrôle.


     

    Est ce que vous  demarrer le service RPC ???

    Essaye la commande suivante au lieu de (wdsutil /initialize-server /reminst:D:\WDS_Deploiement):

    WDSUTIL /verbose /Progress /Initialize-server /Server:WDS /Reminst:"WDS_Deploiement"


     





    mercredi 10 août 2011 12:54
  • Sur les2 serveurs DC + WDS, le service Remote Procedure Call (RPC) est démarré en AUTO

     

    C:\Windows\system32>WDSUTIL /verbose /Progress /Initialize-server /Reminst:"D:\WDS_Deploiement"
    
    Windows Deployment Services Management Utility [Version 6.1.7600.16385]
    Copyright (C) Microsoft Corporation. All rights reserved.
    
    Setting up server...
    
    -> Creating the installation tree for Windows Deployment Services
    
    ---> Creating the installation root for Windows Deployment Services at \\PRODMDT
    .XXX.fr\D$\WDS_Deploiement
    
    ---> Creating the share for Windows Deployment Services at \\PRODMDT.XXX.fr\REMINST
    
    -> Installing Windows Deployment Services files
    
    ---> Installing system files
    .
    
    ---> Installing boot files for x86
    ..........
    
    ---> Installing boot files for ia64
    ..
    
    ---> Installing boot files for x64
    ...........
    
    -> Updating the registry
    
    -> Configuring the TFTP provider
    
    -> Configuring the service control point for BINL
    
    Enabling services for Windows Deployment Services...
    
    Starting the services for Windows Deployment Services...
    
    
    An error occurred while trying to execute the command.
    Error Code: 0x41D
    Error Description: The service did not respond to the start or control request in a timely fashion.


     


    mercredi 10 août 2011 13:22
  • Bonjour, 

    j'espère qu'il faut restaurer votre systeme vers un point de restauration antérieurs,

     


    http://fethiabassi.blogspot.com/
    jeudi 11 août 2011 10:05
  • Bonjour

     

    j'ai deja sorti le serveur du domaine, supprimer le compte AD et reintroduit : idem

    J'ai deja supprimer le role, redémarrer et réinstaller : idem, plante avec le même message d'erreur dès la fin de l'assistant de configuration du serveur .. je n'arrive pas a savoir qui il essaye de contacter pour avoir cette erreur RPC

     

     

     

     

    jeudi 11 août 2011 10:09
  • Bonjour

     

    j'ai deja sorti le serveur du domaine, supprimer le compte AD et reintroduit : idem

    J'ai deja supprimer le role, redémarrer et réinstaller : idem, plante avec le même message d'erreur dès la fin de l'assistant de configuration du serveur .. je n'arrive pas a savoir qui il essaye de contacter pour avoir cette erreur RPC

     

     

     

     

    Comme j'ai dit au paravent il y un erreur système dont il faut restaurer votre machine 




    • Proposé comme réponse F.ABASSI mardi 16 août 2011 13:21
    • Marqué comme réponse GuiAg mardi 16 août 2011 13:22
    jeudi 11 août 2011 10:32
  • Effectivement, l'installation sur un autre serveur W2k8R2 ne poste pas de soucis, il s'agit bien un pb système
    mardi 16 août 2011 13:22