Why does my Workflow show as "Cancelled" when it runs automatically?


  • Hi,
    I have created a 2010 Workflow which runs on a SharePoint list in SharePoint Online.  I have used SharePoint Designer 2013 to create it.  Each record within the list consists of a .pdf document and some attributes.  Two of these attributes are called “Requester” and “Approver”.  When both have been populated by a user, the workflow should move (copy, then delete) the record to another list.

    When the Workflow runs automatically (i.e. when it senses that a record has been changed and that the two fields are populated) it tries to run but ends as “Cancelled”.

    I have created an additional attribute called “Kick” which is a Yes / No field.  I use this to mass update the records where the Workflow has been Cancelled.  I simply change the value from “No” to “Yes” for all the records.  The Workflow then detects that records have changed and, where the criteria is met, tries to run again.  The workflow then runs successfully for most of the records I have “kicked”, with a few that fail with an “Error occurred” status.  I can then manually cancel the workflow where the “Error occurred”, “kick” the records again and the Workflow runs successfully (for most of the records – rinse and repeat).
    The Workflow is set to “Start workflow automatically when an item is changed” with “Start workflow automatically when an item is created” remaining unset.  “Allow this workflow to be manually started” is set, but only because I must rerun the workflow so often.

    I’m baffled as to why I’m witnessing this behaviour.  If there was anything fundamentally wrong with the lists I am moving the records from or to, or the logic in the workflow, the workflow would never complete successfully.  Could it be to do with permissions?  What account does the workflow use to run?  (I created the Workflow under my own account and manage the lists under a service account.)

    Any help gratefully received.

    A problem well stated is a problem half-solved

    lundi 11 juin 2018 16:06

Toutes les réponses

  • Hi HughNeedsHelp, 

    Please offer a screenshot about your workflow steps to further troubleshoot the issue. 

    If you don't have permission to upload a picture, please upload the picture in onedrive and share the link with us.

    Best Regards, 

    Lisa Chen 

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 14 juin 2018 09:33
  • Thanks for the response.  (Sorry for the delay - I didn't see the alert).

    Please see screenshots.  There is an Access Denied errors, but I don't understand which account this relates to.  In my opinion, if the Workflow runs automatically, it should not run under the credentials of the person who uploaded and modified the content.  But if this is what is happening, how do I change it?

    A problem well stated is a problem half-solved

    mercredi 20 juin 2018 14:32
  • Hi,

    I've uploaded screenshots.  Are you able to diagnose my issue?

    Thanks in advance

    A problem well stated is a problem half-solved

    lundi 25 juin 2018 16:24