none
RDS - WAN / Ordinateur distant introuvable RRS feed

  • Question

  • Salut à toute la communauté.

    Je bloque sur un message depuis quelque heures et j'avoue que je commence à tourner en rond...
    J'ai un serveur membre 2012 R2 (RDS) qui propose des Remote APP via un portail Web. Tout fonctionne parfaitement en local mais à partir du WAN c'est une autre affaire. Depuis le WAN, j’accède sans problème au portail via l'adresse IP publique et arrive à m'authentifier avec un compte autorisé, je vois ensuite les différentes Rmote App proposées mais dès que je veux lancer une Remote APP j'ai le message suivant qui s'affiche:

    "Remote App déconnecté: Ordinateur distant introuvable. Pour plus d'information sur cette erreur contactez le support technique"

    Avez vous déjà été dans ce cas de figure?
    Merci pour vos lumières.

    Cordialement
    jeudi 30 octobre 2014 10:42

Toutes les réponses

  • Bonjour,

    cela ressemble à une erreur de configuration, soit du portail, soit du firewall...

    Vous trouverez plus d'informations sur:

    http://technet.microsoft.com/en-us/library/cc730739.aspx

    J'espère que cela va vous aider, car personnellement je n'ai pas encore mis en place une telle solution.

    Cordialement,

    Laurent Dumont

    jeudi 30 octobre 2014 12:37
  • Merci pour votre réactivité.

    J'ai suivi la procédure de vérification et je suis toujours au point de départ.

    Je pense que je dois avoir un problème de certificat ou de configuration (TS gateway/certificat) dans IIS mais là je suis un peux noyé...

    vendredi 31 octobre 2014 12:01
  • J'ai déjà eu des problèmes de ce type sur d'autres produits, et généralement le problème est dans un manque d'ouverture de certains flux du firewall...

    Une erreur de certificat laisserais normalement des messages explicites soit côté client soit côté serveur.

    Laurent

    vendredi 31 octobre 2014 15:41
  • Bonjour,

    Je vous recommande cet article lien.

    A+


    L’information n’a de valeur que si elle est partagée!! AK

    vendredi 31 octobre 2014 18:15
  • Merci pour votre réactivité.

    J'ai vérifié la configuration avec l'aide de l'article d'Ahmed KASMI mais c'est sans succès.

    Je précise que je n'ai pas de nom de domaine routable donc je me connecte via https://@IP publique/RDWeb.

    Faut-il absolument renseigner un nom de domaine routable dans le paramètre: IIS\Sites\Default Web Site\RDWeb\Pages\DefaultTSGateway\valeur

    J'ai bien sûr testé en mettant l'adresse IP publique mais toujours sans succès.

    Une dernière chose, pour l'instant le port 443 est rerouté vers le RDS mais faut-il obligatoirement rerouter le port 3389 sachant que je ne fait pas de bureau virtuelle?

    Merci pour votre aide ;)

    lundi 3 novembre 2014 10:20
  • Bonjour Dotnoob,

    L'ouverture du port 3389 ne changera pas grand chose, parce qu'on parle de requetes HTTPS donc de la communication sur le port 443, par contre, dès que la requete arrive en interne, il est encapsulé sur du RDP (3389) (niveau réseau local) et renvoyé vers le bon serveur Hote de session (RemoteApp Server hébergeant vos programmes RemoteApp).

    En ce qui concerne le paramètre niveau IIS : IIS\Sites\Default Web Site\RDWeb\Pages\DefaultTSGateway\valeur

    Il faut savoir que la veleur doit contenir l'IP ou hostname (plutôt FQDN) de la passerelle et non pas du serveur RDS ou RD WA à part si ceux ci font aussi office de passerelle RDS.

    Avez-vous déployé une passerelle RDS sur votre réseau ?

    Vos users RDS internes ou externes sont censés passer par cette passerelle RDS ou y'a til un accès direct à votre Portail WEB BàD qui redirige vers les RemoteApp ?

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    mardi 4 novembre 2014 18:23
  • Bonjour Dotnoob,

    L'ouverture du port 3389 ne changera pas grand chose, parce qu'on parle de requetes HTTPS donc de la communication sur le port 443, par contre, dès que la requete arrive en interne, il est encapsulé sur du RDP (3389) (niveau réseau local) et renvoyé vers le bon serveur Hote de session (RemoteApp Server hébergeant vos programmes RemoteApp).

    En ce qui concerne le paramètre niveau IIS : IIS\Sites\Default Web Site\RDWeb\Pages\DefaultTSGateway\valeur

    Il faut savoir que la veleur doit contenir l'IP ou hostname (plutôt FQDN) de la passerelle et non pas du serveur RDS ou RD WA à part si ceux ci font aussi office de passerelle RDS.

    Avez-vous déployé une passerelle RDS sur votre réseau ?

    Vos users RDS internes ou externes sont censés passer par cette passerelle RDS ou y'a til un accès direct à votre Portail WEB BàD qui redirige vers les RemoteApp ?

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    Merci pour votre réactivité Hicham.

    Concernant les paramètres pour IIS\Sites\Default Web Site\RDWeb\Pages\DefaultTSGateway\valeur, tous les services sont hébergés sur le même serveur donc d’après vous je dois renseigner le FQDN de ce même serveur dans le paramètre "valeur".

    Ce que je ne comprends pas c'est, comment faire pointer l'adresse IP publique vers le FQDN (LAN) du serveur?

    J'ai effectivement une passerelle RDS déployée mais comment vérifier si les users passent par la passerelle ou arrivent en direct sur le portail?

    Merci pour votre aide ;)

    mercredi 5 novembre 2014 09:06
  • Bonjour dotnoob,

    si tous les services sont installés sur le même serveur, il faudrait mettre plutôt l'adresse IP publique du serveur dans la valeur niveau IIS.

    côté client externes, rien à faire si connexion depuis portail web, si depuis client RDC (mstsc.exe), il faudrait rajouter l'IP publique : depuis mstsc.Exe > afficher les options > avancé > connexion depuis tout ordinateur > paramètres -> utiliser ces paramètres de serveur de passerelle service BàD > spécifier l'IP

    donc vous clients passeront par cette passerelle pour  atteindre le serveur RDS.

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    samedi 8 novembre 2014 15:59