none
workfolder changement de port

    Question

  • bonjour

    je test workfolder sur  2019 et je souhaite changer le port.

    J ai un probleme avec une command trouver sur un tuto:

    Netsh http add urlacl url=https://*:12345/ user=”NT Authority\LOCAL SERVICE”

    le user ne passe pas , alors quand utilisant le compte admin ca passe.

    je vous met le lien

    workfolder port conflict

    Je suis aussi interesser sur de la doc sur les compte nt authorite,leur fonctionnement et pourquoi je les vois pas dans ma console..

    merci

    jeudi 25 avril 2019 15:54

Toutes les réponses

  • Bonjour,

    si le système est installé en Français, il faut sans doute remplacer

    ”NT Authority\LOCAL SERVICE”

    par

    "AUTORITE NT\SERVICE LOCAL"

    A bientôt,


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    jeudi 25 avril 2019 20:44
  • Bonjour,

    Question hors sujet, pourquoi vouloir changer le port ? Le fait d'utiliser un port web 80/443 permet de faire fonctionner les workfolder quasiement partout notamment sur les connexions public de type hotel et espace public. Le fait de mettre un port "exotique" risque de bloquer l'utilisation à l'extérieure.

    vendredi 26 avril 2019 09:17
  • Bonjour,

    Question hors sujet, pourquoi vouloir changer le port ? Le fait d'utiliser un port web 80/443 permet de faire fonctionner les workfolder quasiement partout notamment sur les connexions public de type hotel et espace public. Le fait de mettre un port "exotique" risque de bloquer l'utilisation à l'extérieure.

    bonjour,

    pour eviter les attaque sur les port connu.

    c est pour ca qu il y a les router, le nat,etc..

    de plus si tu a deja un serveur qui sur le 443 tu fais comment...

    reverse proxy mais ca n empeche pas les attaque sur les port 0-1065.

    en plus j aime bien me prendre la tete.

    mais si tu as une autre solution je suis preneur


    • Modifié olivier Rb vendredi 26 avril 2019 18:21 modif
    vendredi 26 avril 2019 17:18
  • Bonjour,

    si le système est installé en Français, il faut sans doute remplacer

    ”NT Authority\LOCAL SERVICE”

    par

    "AUTORITE NT\SERVICE LOCAL"

    A bientôt,


    Thierry DEMAN-BARCELO. Offce Apps&Services MVP. MCSE:Messaging 2016,MCSE:Server Infrastructure 2012(85 MCPs). MCSA Office 365 http://base.faqexchange.info

    merci thierry,

    je suis c.. sur ce coup la j  ai pas penser

    big shame

    vendredi 26 avril 2019 17:19
  • bonjour

    Ma petit contribution pour eviter de cherche a tout va comment faire.

    Install-WindowsFeature FS-SyncShareService,Web-WHC
    
    $nom_votre_certificat=Read-Host "Nom du certificat"
    
    $port=Read-Host "port a utiliser"
    
    
    #sleep (30)
    #///////////////////////////////install le module NTFSSecurity si pas present////////////je n ai pas fait cette partie encore
    
    
    #Install-Module NTFSSecurity 
        
    #///////////////////////////////////////change le proprio de syncshare et les droits/////////////////////////
    
    Set-ntfsOwner C:\Windows\System32\SyncShareSvc.config -Account "test\administrateur"
    
    Add-NTFSAccess –Path "C:\Windows\System32\SyncShareSvc.config" –Account "test\administrateur" –AccessRights FullControl
    
    
    
    #//////////////////////////////modification du port  syncshare//////////////////////////////////////////////////////////////////////
    
    $content = Get-Content "C:\Windows\System32\SyncShareSvc.config" | foreach { $_ -replace "443","$port" }
    Set-Content -Path "C:\Windows\System32\SyncShareSvc.config" -Value $content
    
    
    
    
    #//////////////////////////////creation urlacl et https sslcert//////////////////////////
    
    Netsh http add urlacl url=https://*:$port/ user="AUTORITE NT\SERVICE LOCAL"
    
    #////////////////////////////////////en cmd/////////////////////
    
    #netsh http add sslcert ipport=0.0.0.0:446 certhash=15A7B995F726CBFD7BD4FCDCC58DA00619188026 appid={CE66697B-3AA0-49D1-BDBD-A25C8359FD5D} certstorename=MY
    
    #///////////////////////////lire le certhash////////////////////////////////////////
    
    
    $Thumbprint = Get-ChildItem -Path "Cert:\localmachine\My\" | ? subject -Match $nom_votre_certificat |select  Select-Object -ExpandProperty Thumbprint
    
    #//////////////////////////////En powershell le certhash//////////////////////////////////////////////
    
    $guid = [guid]::NewGuid()
    $Command = "http add sslcert ipport=0.0.0.0:$port certhash= $Thumbprint appid={$guid}"
    $Command | netsh
    
    #////////////////////////////////////////////////firewall/////////////////////////////////////////////////////
    
    New-NetFirewallRule –Name "workfolder" -DisplayName "workfolder(4)"  -Profile "Private,Domain" -Enabled True  -Protocol TCP -LocalPort $port -Action Allow 
    
    #///////////////////////////////////redemare le service SyncShareService////////
    get-service SyncShareSvc |Restart-Service
    

    voila

    il y encore 2 ou 3 chose a faire.

    a+

    mercredi 1 mai 2019 19:43
  • re,

    finalise avec installation module NTFS security

    install-WindowsFeature FS-SyncShareService,Web-WHC
    
    $nom_votre_certificat=Read-Host "Nom du certificat"
    
    $port=Read-Host "port a utiliser"
    
    
    #sleep (30)
    #//////////////////////////////Iinstall le module NTFSSecurity si pas present////////////je n ai pas fait cette partie encore
    if (Get-Module -ListAvailable  -Name NTFSSecurity) {
        Write-Output "Module exists"
        
    } else {
        Write-Output "Module does not exist"
        install-Module NTFSSecurity -Force
    }
    
    
        
    #///////////////////////////////////////Change le proprietaire de syncshare et les droits/////////////////////////
    
    Set-ntfsOwner C:\Windows\System32\SyncShareSvc.config -Account "test\administrateur"
    
    Add-NTFSAccess –Path "C:\Windows\System32\SyncShareSvc.config" –Account "test\administrateur" –AccessRights FullControl
    
    
    
    #//////////////////////////////Modification du port syncshare//////////////////////////////////////////////////////////////////////
    
    $content = Get-Content "C:\Windows\System32\SyncShareSvc.config" | foreach { $_ -replace "443","$port" }
    Set-Content -Path "C:\Windows\System32\SyncShareSvc.config" -Value $content
    
    
    
    
    #//////////////////////////////Creation urlacl et https sslcert//////////////////////////
    
    Netsh http add urlacl url=https://*:$port/ user="AUTORITE NT\SERVICE LOCAL"
    
    #////////////////////////////////////en cmd pour info/////////////////////
    
    #netsh http add sslcert ipport=0.0.0.0:446 certhash=15A7B995F726CBFD7BD4FCDCC58DA00619188026 appid={CE66697B-3AA0-49D1-BDBD-A25C8359FD5D} certstorename=MY
    
    #///////////////////////////Lire le certhash////////////////////////////////////////
    
    
    $Thumbprint = Get-ChildItem -Path "Cert:\localmachine\My\" | ? subject -Match $nom_votre_certificat |select  Select-Object -ExpandProperty Thumbprint
    
    #//////////////////////////////En powershell le certhash//////////////////////////////////////////////
    
    $guid = [guid]::NewGuid()
    $Command = "http add sslcert ipport=0.0.0.0:$port certhash= $Thumbprint appid={$guid}"
    $Command | netsh
    
    #////////////////////////////////////////////////Firewall/////////////////////////////////////////////////////
    
    New-NetFirewallRule –Name "workfolder" -DisplayName "workfolder(4)"  -Profile "Private,Domain" -Enabled True  -Protocol TCP -LocalPort $port -Action Allow 
    
    #///////////////////////////////////Redemarre le service SyncShareService////////
    get-service SyncShareSvc |Restart-Service

    jeudi 2 mai 2019 16:32
  • Merci beaucoup pour la question, j'avais le même problème pour changer le port de mon coté le port 443 est déjà utilisé sur le serveur.

    Bonne soirée

    Dans le script il faut bien modifier le test par le nom de domaine

    #///////////////////////////////////////Change le proprietaire de syncshare et les droits/////////////////////////
    
    Set-ntfsOwner C:\Windows\System32\SyncShareSvc.config -Account "test\administrateur"
    
    Add-NTFSAccess Path "C:\Windows\System32\SyncShareSvc.config" Account "test\administrateur" AccessRights FullControl

    il y a 6 heure(s) et 48 minute(s)