none
exchange2013 et reverse proxy RRS feed

  • Question

  • Bonjour,

    Voici le topo:

    J'ai un Exchange2013.

    Un serveur Debian qui fait office de revers proxy.

    J'ai installer un certifcar SSL sur les deux serveurs.

    OWA fonctionne sans soucis. Pas d'erreur de certificat ni rien.

    Tous les virtuals directories ont été changés/tésté.

    Pourtant,soit je ne peux pas connecter certains user disposant d'un ihphone, soit ils ne peuvent que recevoir des messages.

    Pourriez-vous m'aider ?

    Merci

    vendredi 28 février 2014 10:36

Réponses

  • Personnellement je n'ai rien modifier au niveau dns pour autodiscover. 

    Vous devriez mettre un enregistrement DNS sur Internet du type autodiscover.mondomain.com, où mondomaine.com est le domaine de messagerie de l'utilisateur (la partie après le @) et qui pointe vers votre serveur Exchange.

    Par contre il faut aussi que votre certificat publique porte ce même nom.

    Ensuite, comme indiqué, si vous pouviez faire le test en bypassant le proxy.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    vendredi 28 février 2014 13:18
    Modérateur

Toutes les réponses

  • Essayer en connexion directe sans le reverse proxy. Si cela ne fonctionne pas, il faut voir côté Exchange, sinon côté Reverse Proxy.

    Avez vous des messages d'erreurs dans le journal du serveur Exchange?


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 28 février 2014 12:40
    Modérateur
  • J'arrove jusqu'au serveur c'est certain.

    Je vois des messages d'erreur si actovsync est disable pour un utilisteur par exempl.

    Une chose bizarre : si je fais le test via https://testconnectivity.microsoft.com/

    ca fonctionne sans problème....

    Une idée.

    Merci,

    vendredi 28 février 2014 12:53
  • Vous pouvez essayer pour un compte posant problème avec une autre marque de téléphone (ou l'application Courrier de Windows 8).

    Le problème avec ActiveSync est que chaque constructeur l'implémente un petit peu à sa sauce, si le problème n'est pas général (ie : touche android, ios et windows), il est compliqué d'apporter une solution. Les conseils généraux sont de mettre à jour la version de l'OS et vérifier si d'autres utilisateurs avec la même marque ont ce type de problème.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 28 février 2014 13:07
    Modérateur
  • J'ai essayé avec un iphone,un ipda,un samsung et un nokia (windows phone)Ça ne marche pour aucun des trois...

    Juste une chose je vois que tout le monde faire des "split dns" pour autodiscover.

    Personnellement je n'ai rien modifier au niveau dns pour autodiscover. Est-ce normale.

    De plus le test ne devrait pas fonctionner si le problème venait de la...

    Merci,

    vendredi 28 février 2014 13:10
  • Pouvez-vous ouvrir l'un des comptes posant problème via l'outil ADSIEdit.msc et vérifier si l'attribut AdminCount a une valeur?

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 28 février 2014 13:12
    Modérateur
  • AdminCount -->not set
    vendredi 28 février 2014 13:16
  • Personnellement je n'ai rien modifier au niveau dns pour autodiscover. 

    Vous devriez mettre un enregistrement DNS sur Internet du type autodiscover.mondomain.com, où mondomaine.com est le domaine de messagerie de l'utilisateur (la partie après le @) et qui pointe vers votre serveur Exchange.

    Par contre il faut aussi que votre certificat publique porte ce même nom.

    Ensuite, comme indiqué, si vous pouviez faire le test en bypassant le proxy.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    vendredi 28 février 2014 13:18
    Modérateur
  • je vais mettre cela en place.Mon certificat est en wildcard donc pas de soucis.

    Par contre cela n’explique pas pourquoi cela ne fonctionne pas en manuel...

    vendredi 28 février 2014 13:20