none
Windows 7 machines not seeing updates until you press Check for updates

    Question

  • I am already used to Windows 10 having often problems with contacting WSUS (or even regular WU), but for a few months i'm seeing weird issue with Windows 7 Pro machines, which were working flawlessly for many years. 10% out of 150 machines are currently showing 6 updates as needed. All show status as Downloaded. But if you go to Windows Update on such machine, it shows that no updates are needed and that it recently had a check. WSUS also shows that check, but still shows 6 needed updates. If i press Check for updates on such machine, it pulls the updates and installs them. I have also tried to run wuauclt /detectnow and /reportnow dozen of times on such machine with no effect. But if i restart WU service after running these commands, it sometimes actually detects the updates. Haven't checked the logs yet. But it is really weird it only works on manual check via GUI. WSUS is on Windows Server 2012 R2. Currently i'm trying to wipe SoftwareDistribution folder on affected machines to see if it will help in the future.
    jeudi 17 mai 2018 18:57

Toutes les réponses

  • To add to the problem. While trying to find a solution i have rebooted my server with WSUS yesterday. And today it doesn't update status of any machine, although they are checking in in the morning. I have noticed this a few times after i have updated this server and rebooted, when it gets stuck and doesn't update status changes. Usually additional reboot of a server fixes that. Maybe there is some problem with my WSUS installation. Although it is pretty fresh, installed it at the end of 2016 to prepare for Windows 10. Nothing else is running on this server.
    vendredi 18 mai 2018 06:03
  • Rebooting the IIS fixed the issue with no status updating in WSUS. I guess IIS is running into some issues. Maybe memory related. I have tweaked this server to support Windows 10 updates. Per this article (which i am the author of) http://www.wroot.lt/wp/technology/wsus-woes-with-windows-10-en/

    Maybe this setting has such effect

    In the Application Pools window press on the WsusPool, then go to Advances Settings > and in the Recycling section change Private Memory Limit (KB) to 0 (means unlimited size).

    The server has 6 GB of RAM and a few Xeon cores. Have checked a few days stats and it never drops below 20% of memory. It is weird that it seems that server's reboot causes this problem and IIS restart is needed then.

    vendredi 18 mai 2018 06:14
  • I would like to see detailed information of GPO applied to your Windows 7 machines to better handle your problems. Could you send me the screenshoot
    vendredi 18 mai 2018 06:59
  • Screenshot of what do you need exactly? I can provide you my GPO for WSUS screeshots.


    vendredi 18 mai 2018 09:54
  • On the server with WSUS i have found this in Application event log: The Reporting Web Service is not working . But it only showed up a few times yesterday after i have rebooted this Windows server.
    vendredi 18 mai 2018 09:55
  • Hi,

    is there manual approval or automatic approval in WSUS?

    Update needed showing in wsus are these updates approved?

    in my case :-

    vendredi 18 mai 2018 10:03
  • Manual approval. All updates are already approved (which were not showing up in the client after an automatic search and which has already been installed on ~80% of other machines).
    vendredi 18 mai 2018 11:53