none
Acces à Exchange via smartphone en 3G RRS feed

  • Discussion générale

  • Bonjour,

    Je vous expose mon problème (j'ai déjà fait pas mal de recherches là-dessus, sans trouver de solution)

    J'ai un serveur 2003 SBS, et des smartphones (iPhone et Android avec connexion 3G), et je voudrais que les utilisateurs des smartphones aient accès à leurs plannings en temps réel.

    Tous les test que j'ai faits jusque-là n'ont pas été concluants.

    Voici les informations relatives à mon matériel :


    Serveur :
    Windows server 2003 SBS SP2
    Exchange version 6.5 (Build 7638.2: Service Pack 2)
    Comptes d'utilisateurs actifs et fonctionnels (sur les postes clients fixes, via Outlook)
    Serveur Imap activé

    Connexion internet avec adresse IP fixe

    Routeur :
    port redirigé vers mon serveur :
    TCP 143 (IMAP)

    Quels sont les prérequis pour que cela fonctionne?

    Suis-je obligé de passer par une connexion SSL? A priori, non : mon adresse email perso est hébergée sur un autre serveur 2003 (que je ne gère pas), et je peux sans problème synchroniser mes emails et calendrier sur mon Android, en passant par une connexion Imap sans SSL.

    Merci d'avance pour votre aide

    Arnaud

     


    mardi 22 novembre 2011 16:23

Toutes les réponses

  • Bonsoir
     
    A priori, ça passe presque tout seul sur winphone 7, androîd et iphone,
    sur le vieux windows mobile 6.2 et 6.5 c'est parfois délicat avec le
    certificat. Après, si ton SBS a été installé comme il faut (donc avec
    les assistants) y a rien à faire :-) tout juste router le 443 vers ton
    SBS et jouer l'assistant internet et messagerie, dans la config du
    parefeu, y a une case à cocher "outlook via internet".
     
    La synchro se fait via https (donc avec un certificat), ça se passe sur
    le port 443. Tu parles de connexion IMAP (certes sur le port 143), ça
    n'a rien à voir avec la synchro exchange, d'ailleurs sur ton androïd,
    quand tu crées un compte il y a POP, IMAP et synchro exchange (cqfd).
     
    Après sur le téléphone, ajoute un compte "exchange" et accepte le
    certificat proposé, ce certificat doit correspondre à l'adresse
    utilisée pour joindre le serveur.
     
    hth
    @+lolo
     
    mardi 22 novembre 2011 17:21
  • Bonjour Laurent.C,

    Merci pour ta réponse rapide, et pour l'attention que tu portes à mon problème.

    - j'ai redirigé le port 443 vers mon serveur
    - j'ai relancé l'assistant internet et messagerie et créé mon certificat, le pare-feu est OK


    J'ai essayé de paramétrer mon smartphone android:

    - compte email Imap --> OK, mais le calendrier est considéré comme un dossier, et donc ne s'affiche pas comme un agenda

    - compte email exchange --> Impossible de me connecter au serveur avec ou  sans SSL ("Impossible d'établir une connexion avec le serveur")

    - paramètres/comptes et synchro/type de compte : entreprise --> Impossible de me connecter au serveur avec ou  sans SSL ("Impossible d'établir une connexion avec le serveur")

    Quand je saisis l'adresse https://monIPfixe/exchange dans le navigateur du smartphone, j'ai bien accès à mon compte (email, calendrier, ...), donc mon certificat et la redirection fonctionnent. A priori, mon serveur et mon routeur sont bien paramétrés


    Paramètres de mon smartphone sous andoid (2.3.3) :

    Ajouter un compte --> Entreprise
    Adresse email : test@monserveur.local ( + mot de passe)

    Domaine\Nom d'utilisateur : mon domaine\test ( + mot de passe)
    Serveur : mon adresse IP fixe
    SSL coché

    Je ne comprends pas où est l'erreur ....


    Mon compte email perso qui est aussi hébergé sur un serveur 2003 est paramétré en compte  entreprise, avec comme adresse de serveur: imap.serveurmail.fr, et cela fonctionne très bien (synchro de tous les dossiers exchange, et affichage du calendrier comme un agenda)

    J'ai oublié de préciser une chose dans mon précédent message : les comptes email paramétrés sur mon serveur sont sous la forme compte@monserveur.local (mais cela ne doit pas poser de problème, je suppose)

    Arnaud

    mercredi 23 novembre 2011 09:14
  • Bonjour
     
    Je pense que tu te rates au niveau du certificat.
     
    Dans l'assistant internet et messagerie, au rayon certificat, tu mets
    quoi ?
    A priori tu dois mettre un truc du genre MonHote.MonDomainePublic.fr
     
    Pour faire ça, dans la gestion de ta zone DNS (chez celui qui gère ton
    nom de domaine), tu crée un "hôte A" qui pointe vers l'IP fixe de ta
    box internet qui est devant le SBS. Une fois fait, sur une station
    connectée à l'internet, un ping MonHote.MonDomaine.fr dois renvoyer
    l'IP publique de ta box (tant que ça ne passe pas, intile d'aller plus
    loin).
    Après, sur ton androïd, ajoute un compte exchange et donne pour nom de
    serveur MonHote.MonDomainePublic.fr, ton adresse mail est du type
    MonNom@MonDomainePublic.fr, ton login utilisateur (éventuellement
    MonDomaineLocal\MonUser) et le mot de passe qui va bien ... accepte le
    certificat ... et hop !
     
    Ton compte perso en IMAP ne synchronise pas les contacts et les tâches
    outlook je crois, je suis surpris que le calendrier passe ... te
    focalise pas sur IMAP ce n'est pas ce que tu cherches à faire.
     
    Je ne comprends pas ton "J'ai oublié de préciser une chose dans mon
    précédent message : les comptes email paramétrés sur mon serveur sont
    sous la forme compte@monserveur.local (mais cela ne doit pas poser de
    problème, je suppose)"
    Comment ont été créé les utilisateurs sur ton SBS 2003 ? Avec les
    assistants ? Si ça n'a pas été fait comme recommandé par MS ... c'est
    normal que ça marche pas tout seul tel que prévu par MS.
     
    hth
    @+lolo
     
    mercredi 23 novembre 2011 11:57
  • Bonjour,

    J'ai peut-être mal décrit mon infrastructure :

    J'ai un domaine public www.mondomaine.fr, et une dizaine d'adresses email du type nom@mondomaine.fr (avec serveurs pop3, imap et webmail horde). Tout ceci est géré par un prestataire hors de nos locaux.

    J'ai un serveur SBS local (monserveur), un domaine (mondomaine), et une vingtaine de comptes exchange (du type nom@mondomaine.local), le tout paramétré avec les assistants Microsoft.

    Les adresses email nom@mondomaine.fr sont redirigées vers les boites exchange nom@mondomaine.local, via un connecteur pop3. (par exemple, j.dupont@mondomaine.fr est redirigé vers jean@mondomaine.local)

    Ce que mes utilisateurs veulent avoir sur les smartphones, ce sont les calendriers des boites exchange locales (les emails ne serviront pas, mais je pense qu'ils seront synchronisés quand même).

    J'ai déjà fait créer à mon prestataire un hôte du type hote.mondomaine.fr, qui redirige vers l'adresse IP fixe de mon modem. Le ping fonctionne (j'ai redirigé le port 80 vers mon serveur de vidéosurveillance, ça marche très bien).

    C'est bien cette adresse que je renseigne comme serveur sous android, et que j'ai mise quand j'ai paramétré mon certificat SSL.

    Arnaud

    P.S: Je t'assure que mon adresse perso est bien paramétrée en Imap sur mon smartphone, et que le calendrier est bien synchronisé (les contacts aussi, mais pas les tâches) ... c'est pour cela que je voulais paramétrer mes autres comptes en Imap, puisque je sais que cela fonctionne.

     

    mercredi 23 novembre 2011 12:55
  • Salut
     
    > ... POP3 ... Tout ceci est géré par un prestataire hors de nos locaux
     
    Quand arrêtes tu de bricoler ? Tu serais moins ennuyé !
    Il serait beaucoup mieux (mais pas obligatoire) de passer sur une
    config MX et jeter POP !!! Dans ta zone DNS pointe le champ MX sur
    MonHote.MonDomaine.fr, route le 25 vers ton SBS et un petit coup
    d'assistant internet et messagerie, pouf c'est fini.
     
    > J'ai un serveur SBS local (monserveur), un domaine (mondomaine), et
    > une vingtaine de comptes exchange (du type nom@mondomaine.local),
    > le tout paramétré avec les assistants Microsoft.
     
    Euf non, tu as des utilisateurs SBS qui ont une boite mail et cette
    boite mail doit avoir pour adresses email nom@mondomaine.local ET
    j.dupont@mondomaine.fr (par défaut).
     
    Avec le 443 routé et la coche outlook via internet dans l'assistant
    parefeu ça doit le faire ...
     
    Ton bureau à distance fonctionne t'il ?
    Route le 4125 vers ton sbs (en plus du 443) et depuis l'extérieur dans
    un IE, si tu as le certificat tu dois pouvoir utiliser pleinnement les
    Une fois fait, sur la page du remote, il y a un topo pour faire de
    l'outlook en rpc sur http ... si celà fonctionne ta synchro téléphone
    doit le faire aussi.
     
    PS : si tu veut absolument faire de l'IMAP (j'imagine que tu as compris
    que je trouve nul), il faut démarrer le service IMAP, router le 143 et
    ça devrait le faire.
     
    @+lolo
     
    mercredi 23 novembre 2011 13:57
  • Re-bonjour,

    >... "Quand arrêtes tu de bricoler ? Tu serais moins ennuyé !"

    Pour information, je suis juste un petit informaticien dans une PME, avec un BTS IG en poche, et aucune formation sur W2003. Donc mon travail peut paraître du bricolage à tes yeux, mais tant que ça marche, ça me va ... (il y a beaucoup de notions que je n'ai pas, je vais bientôt faire une formation poussée sur 2003 SBS, et peut-être que j'arrêterai de bricoler !!)

    >... "Il serait beaucoup mieux (mais pas obligatoire) de passer sur une config MX et jeter POP !!!"

    Que m'apporterait le fait de passer sur une configuration MX et pas POP? Les emails arrivant sur les boites nom@mondomaine.fr arriveraient directement sur mon serveur, sans passer par mon prestataire?

    Et comment faire pour que les boites mails aient pour adresses email nom@mondomaine.local ETj.dupont@mondomaine.fr (par défaut)?

     

    Pour revenir à mon problème principal :

    Oui, le bureau à distance fonctionne, et j'ai bien accès à  https://MonHote.MonDomaine.fr/remote et https://MonHote.MonDomaine.fr/exchange, mais je n'ai pas réussi à faire du RPC sur HTTP ...

    Si ça marchait en Imap, cela me suffirait, mais vraisemblablement, il y a un problème quelque part ... Le port 143 est bien redirigé, mais je n'arrive pas à m'authentifier au serveur ...

    La nuit porte conseil, je m'y remets demain ...

    Merci encore pour ton aide et ton temps ...

    Arnaud

    mercredi 23 novembre 2011 16:26
  • Bonjour
     
    Avec ma remarque sur le bricolage POP, j'étais bien loin de vouloir
    d'agresser sur la qualité de ton travail ... désolé si tu l'as pris
    comme ça, ce n'était pas l'objectif.
     
    Une config POP doit être réservée à un nombre très restreint d'adresse
    mail de ton LAN,  par exemple pour une vielle adresse historique
    @wanadoo.fr. Oui, avec une config MX ton serveur recevra directement
    les mails, ça ira plus vite et le connecteur POP ne se bloquera pas et
    ne te perdra plus de mail.
     
    > Et comment faire pour que les boites mails aient pour adresses email
    > nom@mondomaine.local ETj.dupont@mondomaine.fr (par défaut)?
     
    Si ton SBS a été installé avec les assistants et si tes utilisateurs
    ont été créé avec l'assistant SBS ad'hoc, alors ils ont cette
    configuration.
     
    Pour l'IMAP, as tu démarré le "serveur IMAP" ? En interne, sur une
    station du LAN est ce qu'un
    telnet sbs 143
    te répond ?
     
    Si non, le service n'est peut être pas démarré ou le parefeu mal
    configuré.
     
    Désolé de ne pouvoir t'aider plus ...
    @+lolo
     
    jeudi 24 novembre 2011 08:43
  • Bonjour Laurent,

    Je n'ai absolument pas mal pris ta remarque sur le bricolage, je voulais juste t'expliquer pourquoi je bricole! (et je me dis qu'il est vraiment temps d'avoir une vraie formation sur SBS 2003 !!)

    J'ai installé le SBS et créé les utilisateurs avec les assistants, je ne me souviens pas avoir vu quelque chose à propos des 2 adresses email (domaine local et fr) ...j'ai du mal regarder.

     

    Je n'arrive toujours pas à me connecter à exchange via mon android ... Il y a un truc qui cloche, et je ne vois pas ce que c'est ...

     

    Pour l'Imap, il y a quelque chose que je ne comprends pas :

    - quand je fais un telnet en local vers mon serveur, j'ai la réponse suivante :

    "* BYE Cannot establish SSL with IMAP server 192.168.1.2:993, SSL_connect error 38" (j'ai fait un telnet sur le port 143, et j'ai un problème sur le port 993 ...??)

    - quand je fais un telnet de chez moi vers mon serveur (IP fixe ou monhote.mondomaine.fr), j'ai la réponse suivante:

    "* OK Le serveur IMAPrev1 Microsoft Exchange Server 2003 version 6.5.7638.1 (monserveur.mondomaine.local) est prêt"

    Donc à priori, mon IMAP est bien accessible à partir d'internet ... ce qui est bien le cas : j'arrive à configurer un compte email en Imap sur mon android (ou sur un ordinateur, d'ailleurs), mais comme expliqué dans un précédent message, le calendrier est considéré comme un dossier, et donc ne s'affiche pas comme un agenda, ce que je ne veux pas.

    Mais quand j'essaie de configurer un compte entreprise sous android, j'ai toujours ce message : "Impossible d'établir une connexion avec le serveur" (j'ai tout essayé : SSL ou pas, IP fixe, monhote.mondomaine.fr, imap.monhote.mondomaine.fr, j'ai même fait rediriger l'Imap de mon domaine .fr vers mon IP fixe, ...)

    Théoriquement, cela devrait marcher, mais je dois louper quelque chose quelque part ...

    Arnaud
    jeudi 24 novembre 2011 15:52
  • Salut
     
    > (et je me dis qu'il est vraiment temps d'avoir une vraie formation
    > sur SBS 2003 !!)
     
    J'me dis que tu vas pt'ête avoir du mal à trouver ... conseil : faire
    attention. J'me dit aussi qu'on en est à SBS 2011 :o) te trompe pas de
    train, SBS 2003 (surtout premium) était une très belle machine mais il
    commence à ce faire vieux ...
     
    Oui, IMAP en SSL c'est sur le 993 TCP. Sur SBS 2003, de base c'est sans
    SSL.
     
    > ... calendrier est considéré comme un dossier, et donc ne s'affiche
    > pas comme un agenda, ce que je ne veux pas
     
    Oui, je vois que tu te rapproches de mon avis ... IMAP c'est nul ;-)
     
    Il faut que tu passes par ActiveSync.
    L'adresse du serveur est monhote.mondomaine.fr, le certificat SBS doit
    aller avec cette adresse et router le port 443.
     
    Difficile de t'aider plus semble t'il :-( désolé, mais il y a un moment
    ou il faut voir la machine.
     
    Eventuellement, rejoue l'assistant de connexion, 1 fois tu décoches
    tout dans le parefeu, redémarre et la 2nd en recochant toutes les
    options nécessaires.
     
    Autre truc, ta machine est elle sous-dimmenssionée (processeur +
    mémoire) ? Sur SBS 2003 il faut 4 Go de mémoire pour que ça tourne,
    d'ailleurs je crois que ça fait parti des critères de nulité de l'IMAP,
    c'est très consommateur de ressources.
     
    @+lolo
     
    jeudi 24 novembre 2011 17:13
  • Bonjour Laurent,

    Sachant que je vais garder mon serveur encore quelques années (à part ce problème avec les smartphones, ça marche bien), je vais faire une formation sur SBS 2003 pour combler mes lacunes. D'ici 2 ou 3 ans, avant de changer de serveur, je ferai une formation sur le nouveau système d'exploitation que j'aurai (2011 ou plus).

    Je ne pense pas que mon serveur soit sous-dimensionné (processeur :2 x Opteron 2.4 GHz, 4Go de RAM par processeur).

     

    A propos de mon problème principal, je commence à perdre espoir : tout à l'air bien paramétré côté serveur, mais ça ne marche toujours pas ... Je vais tout reprendre à zéro, on verra bien.

    Si ça ne marche toujours pas, c'est que le problème doit venir de l'installation du serveur à l'origine. Dans ce cas, j'essaierai d'installer un serveur temporaire pour faire des test ...

    Quels sont les points que je ne dois absolument pas rater lors de l'installation d'un SBS 2003?

    Merci beaucoup encore pour ton aide et ton soutien!

    Arnaud

    vendredi 25 novembre 2011 14:48
  • Bonjour,

    J'ai revu toute ma configuration, je ne vois pas ce que j'ai raté ...

    Je continue à chercher sur tous les sites et forums Microsoft, et j'ai trouvé quelques pistes :

    - Je n'ai pas de serveur ISA de paramétré. Est-ce que cela change quelque chose?

    - Est-ce que cela peut avoir un rapport avec un paramétrage en serveur frontal ou principal (je n'ai qu'un seul serveur)

    - Le pare-feu Windows est désactivé: si je l'active, Outlook n'arrive plus à se connecter au serveur sur les postes clients ... oui, c'est bizarre, c'est comme ça depuis l'installation du serveur (et même après réinstallation). Mais bon, le pare-feu est désactivé, tout devrait donc passer ...

     

    - J'ai trouvé un outil très utile :Best Practices Analyzer Tool pour faire un diagnostic assez complet d'un serveur exchange, mais il n'y a pas de problème majeur

    - J'ai trouvé un outil web très utile aussi :Outil Analyseur de connectivité à distance Exchange

    problème trouvé : Exchange Activesync a renvoyé une réponse HTTP 500

    J'ai donc suivi certaines procédures pour résoudre ce problème, et je me suis rendu compte que dans le Gestionnaire des services Internet (IIS), le dossier "Sites Web par défaut\Exchange" est vide ... et ça n'a pas l'air normal ... Comment résoudre cela ?

    Je continue mes recherches, mais si un point mentionné ci-dessus vous paraît pertinent, je suis preneur ...

    A bientôt

    Arnaud

     

     

     

    lundi 12 décembre 2011 10:53
  • Bonjour,

    Après beaucoup de tests, de paramétrage, je commençais à désespérer ...

    J'ai donc fini par faire une formation poussée sur Windows 2003 SBS avec un professionnel, pour combler mes (nombreuses) lacunes ...

    Nous avons donc fini par trouver mon erreur :

    dans le registre (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters), la chaîne "ExchangeVDir" n'était pas paramétrée comme il faut : il manquait le "/" devant la valeur de la chaîne ...

    Après avoir modifié cela, la synchronisation des Androïdphones et des Iphones s'est déroulée sans problème ...

    J'en ai profité pour revoir entièrement le paramétrage de mon serveur et de mon exchange (ajout d'alias, mais pas de configuration en MX), tout marche beaucoup mieux !

    Merci encore à Laurent.C pour ton aide.

    P.S: Comment dois-je faire pour signaler que mon problème a été traité (et résolu) ?

    jeudi 1 mars 2012 09:34