locked
Erreur de protocle de licence - bureau à distance vers RDS 2008 RRS feed

  • Question

  • Bonjour,

    Cela fait quelques mois que j'ai installé un serveur RDS sur un Windows serveur 2008 R2.

    Tous mes nouveaux clients Windows 7 Pro 32bit se connectaient correctement au serveur jusqu'à aujourd'hui..
    J'ai toujours le même message d'erreur :

    "L'ordinateur distant a déconnecté la session en raison d'une erreur dans le protocole de licence."
    "Essayez de relancer la connexion à l'ordinateur distant ou contactez votre administrateur"

    En retournant sur le serveur RDS dans la «  configuration d’hôte de session bureau à distance », j'ai remarqué que le serveur de licence des services bureau à distance n’était pas Spécifié (je devais donc être dans la période de grâce lors de l’installation du serveur), j’ai donc spécifié mon serveur de licence qui était bien activé auprès de Microsoft. J’ai redémarré le serveur (au cas où) et refait mes tests : toujours pareil !

    J’ai donc réinstallé le service de licence en pensant que ça venait de là mais ça bloque toujours !
    J’ai revérifié toute la conf, je ne vois aucun souci et de toute facon ça fonctionnait très bien avant…
    Il y a des solutions sur le net ( suppression d'une clé dans la bdr )mais ce n'est que pour Windows Xp, la clé n'existe pas sur Windows 7...

    Je ne comprends pas ce qui se passe…
    Quelqu'un aurait une idée ?

    jeudi 16 septembre 2010 14:36

Réponses

  • ca y'est j'ai trouvé une solution ! :)

    Il faut se connecter sur le poste client avec le compte administrateur puis lancer le client bureau à distance et se connecter entant qu'admin. Après de retour sur le compte utilisateur la connection à distance refonctionne par magie ! plus de message d'erreur.

    bizarre mais ca fonctionne..

     

    • Marqué comme réponse Spe$lurp mercredi 29 septembre 2010 07:59
    mercredi 29 septembre 2010 07:58

Toutes les réponses

  • Bonsoir,

    A essayé :

    Suppression de la valeur REG_BINARY Certificat dans le Registre 

    HKlM\System\CurrentControlSet\Services\TermService\Parameters

    Après avoir supprimé cette valeur, redémarres le serveur (La valeur est automatiquement recrée).


    Eric Perromat - MVP Terminal Server
    jeudi 16 septembre 2010 19:07
  • Je viens de regarder dans la bdr cette clé mais elle reste introuvable..

    Dans HKlM\System\CurrentControlSet\Services\TermService\Parameters j'ai :

    ServiceDLL REG_EXPAND_SZ qui point vers une Dll : termsrv.dll

    et

    ServiceDllUnloadOnStop REG_DWORD valeur 0x000001

    rien d'autre, est-ce normal ?? le problème viendrait de là ??

    Merci pour l'intéré que vous portez à mon problème.

    vendredi 17 septembre 2010 06:51
  • as tu des evenements dans le journal systeme et le journal application ?

     


    Eric Perromat - MVP Terminal Server
    lundi 20 septembre 2010 13:50
  • Quand je recréé l'erreur avec un client Win7, le serveur ne créé aucun événement relatif à cette erreur..

    lundi 20 septembre 2010 14:01
  • as tu essayé sur le Win7 de supprimer les clés qui se trouvent sous la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing ?

    cela supprime la licence du poste ...

     


    Eric Perromat - MVP Terminal Server
    mardi 21 septembre 2010 06:02
  • Oui et c'est là aussi mon problème parce que cette clé n'existe pas !

    C'est pour ca que je ne sais plus quoi faire...

    mardi 21 septembre 2010 06:39
  • Ni la clé de certificat du serveur, ni la clé du poste client n'existe ????
    Eric Perromat - MVP Terminal Server
    mardi 21 septembre 2010 07:53
  • ba oui.. le chemin est peut être différent sur Windows 7 ?
    mardi 21 septembre 2010 09:27
  • Non c'est pareil à ma connaissance ...

    Par contre réinitialise complètement ton serveur de licence ...

    Désinstalles le service, puis supprime le répertoire lserver dans lequel la base de donnée des licences était ...

    Puis réinstalles ton service et réactive ton serveur et tes licences TS.

    Quel type de licence as tu ? si c'est user c'est normal que tu n'aies rien sur le poste client.


    Eric Perromat - MVP Terminal Server
    mardi 21 septembre 2010 11:25
  • J'ai activé une licence user donc normal pour les clients..

    Le serveur RDS est aussi le serveur de licence, j'ai déjà reparamétrer les roles pour tester, ca n'avait rien changé.

    Je vais recommencer et essayer d'aller plus en profondeur, on verra bien.

    mardi 21 septembre 2010 15:00
  • ca y'est j'ai trouvé une solution ! :)

    Il faut se connecter sur le poste client avec le compte administrateur puis lancer le client bureau à distance et se connecter entant qu'admin. Après de retour sur le compte utilisateur la connection à distance refonctionne par magie ! plus de message d'erreur.

    bizarre mais ca fonctionne..

     

    • Marqué comme réponse Spe$lurp mercredi 29 septembre 2010 07:59
    mercredi 29 septembre 2010 07:58