none
[Résolu] Windows 7 et SSRS - impossibilité de se connecter en tant qu'administrateur au serveur de rapport SSRS RRS feed

  • Question

  • Bonjour,

    Après une installation sur environnement windows Seven Familiale Premium 64bits sur PC Asus G51J. Je n'arrive pas à me connecter sous les deux URL de reporting services:

    http://<nom_host>/ReportServer_SQLSERVERR2 erreur : Les autorisations accordées à l'utilisateur '<NOM_HOST>\Christophe' sont insuffisantes pour effectuer cette opération. (rsAccessDenied) Obtenir de l'aide en ligne

    De même pour :

    http://<nom_host>/ReportServer_SQLSERVERR2 :

    L'utilisateur « NOM_HOST\Christophe » ne dispose pas des autorisations requises. Vérifiez que les autorisations suffisantes ont été accordées et qu'aucune restriction liée au contrôle de compte d'utilisateur (UAC) Windows ne pose problème.

    J'ai bien tenté de mettre IE ou Firefox en mode <<administateur>> mais cela ne change rien. On me demande toujours de saisir le login et le mot de passe et une fois connecté je retombe sur la page d'erreur.

    Est ce que quelqu'un est tombé sur le même problème.

    Je vous remercie d'avance.

    Christophe



    dimanche 18 septembre 2011 21:05

Réponses

  • Bonjour,

    D'après les documentations de déploiement de SQL Server, il y a des étapes supplémentaires à effectuer dans le cas du déploiement de SQLRS sur Windows Vista / 7 + UAC. Source: http://msdn.microsoft.com/fr-fr/library/bb630430.aspx

    Pour configurer l'administration locale d'un serveur de rapports sur Windows Vista et Windows Server 2008

     

    1. Ouvrez une fenêtre du navigateur avec les autorisations Exécuter en tant qu'administrateur. Dans le menu Démarrer, cliquez sur Tous les programmes, cliquez avec le bouton droit sur Internet Explorer et sélectionnez Exécuter en tant qu'administrateur.

    2. Cliquez sur Autoriser pour continuer.

    3. Dans l'adresse URL, entrez l'URL du Gestionnaire de rapports. Pour obtenir des instructions, consultez Gestionnaire de rapports dans la documentation en ligne de SQL Server.

    4. Cliquez sur Outils.

    5. Cliquez sur Options Internet.

    6. Cliquez sur Sécurité.

    7. Cliquez sur Sites de confiance.

    8. Cliquez sur Sites.

    9. Ajoutez http://<nom_serveur>.

    10. Désactivez la case à cocher Nécessite la certification du serveur (https:) pour tous les sites dans cette zone si vous n'utilisez pas HTTPS pour le site par défaut.

    11. Cliquez sur Ajouter.

    12. Cliquez sur OK.

    13. Dans le Gestionnaire de rapports, sur la page d'accueil, cliquez sur Paramètres du dossier.

    14. Dans la page Paramètres du dossier, cliquez sur Sécurité.

    15. Cliquez sur Nouvelle attribution de rôle.

    16. Spécifiez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

    17. Sélectionnez Gestionnaire de contenu.

    18. Cliquez sur OK.

    19. Cliquez sur Paramètres du site dans l'angle supérieur de la page d'accueil.

    20. Cliquez sur Sécurité.

    21. Cliquez sur Nouvelle attribution de rôle.

    22. Spécifiez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

    23. Sélectionnez Administrateur système.

    24. Cliquez sur OK.

    25. Fermez le Gestionnaire de rapports.

    26. Ouvrez à nouveau le Gestionnaire de rapports dans Internet Explorer, sans utiliser Exécuter en tant qu'administrateur.

     

     


    Nicolas Cambot - Blog Nelite
    • Marqué comme réponse Christophe P mardi 20 septembre 2011 21:45
    mardi 20 septembre 2011 09:23
  • Bonjour,

    J'avais déjà réalisé la mise en place du site sécurisé, cependant il manque une étape après le point 12 qui est de baisser au minimum la sécurité du site.

    Maintenant cela fonctionne.

    Merci pour ce retour.

    Christophe

    • Marqué comme réponse Christophe P mardi 20 septembre 2011 21:45
    mardi 20 septembre 2011 21:41

Toutes les réponses

  • Bonjour,

    D'après les documentations de déploiement de SQL Server, il y a des étapes supplémentaires à effectuer dans le cas du déploiement de SQLRS sur Windows Vista / 7 + UAC. Source: http://msdn.microsoft.com/fr-fr/library/bb630430.aspx

    Pour configurer l'administration locale d'un serveur de rapports sur Windows Vista et Windows Server 2008

     

    1. Ouvrez une fenêtre du navigateur avec les autorisations Exécuter en tant qu'administrateur. Dans le menu Démarrer, cliquez sur Tous les programmes, cliquez avec le bouton droit sur Internet Explorer et sélectionnez Exécuter en tant qu'administrateur.

    2. Cliquez sur Autoriser pour continuer.

    3. Dans l'adresse URL, entrez l'URL du Gestionnaire de rapports. Pour obtenir des instructions, consultez Gestionnaire de rapports dans la documentation en ligne de SQL Server.

    4. Cliquez sur Outils.

    5. Cliquez sur Options Internet.

    6. Cliquez sur Sécurité.

    7. Cliquez sur Sites de confiance.

    8. Cliquez sur Sites.

    9. Ajoutez http://<nom_serveur>.

    10. Désactivez la case à cocher Nécessite la certification du serveur (https:) pour tous les sites dans cette zone si vous n'utilisez pas HTTPS pour le site par défaut.

    11. Cliquez sur Ajouter.

    12. Cliquez sur OK.

    13. Dans le Gestionnaire de rapports, sur la page d'accueil, cliquez sur Paramètres du dossier.

    14. Dans la page Paramètres du dossier, cliquez sur Sécurité.

    15. Cliquez sur Nouvelle attribution de rôle.

    16. Spécifiez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

    17. Sélectionnez Gestionnaire de contenu.

    18. Cliquez sur OK.

    19. Cliquez sur Paramètres du site dans l'angle supérieur de la page d'accueil.

    20. Cliquez sur Sécurité.

    21. Cliquez sur Nouvelle attribution de rôle.

    22. Spécifiez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

    23. Sélectionnez Administrateur système.

    24. Cliquez sur OK.

    25. Fermez le Gestionnaire de rapports.

    26. Ouvrez à nouveau le Gestionnaire de rapports dans Internet Explorer, sans utiliser Exécuter en tant qu'administrateur.

     

     


    Nicolas Cambot - Blog Nelite
    • Marqué comme réponse Christophe P mardi 20 septembre 2011 21:45
    mardi 20 septembre 2011 09:23
  • Bonjour,

    J'avais déjà réalisé la mise en place du site sécurisé, cependant il manque une étape après le point 12 qui est de baisser au minimum la sécurité du site.

    Maintenant cela fonctionne.

    Merci pour ce retour.

    Christophe

    • Marqué comme réponse Christophe P mardi 20 septembre 2011 21:45
    mardi 20 septembre 2011 21:41