none
Exchange 2010 Rollup4 : Outlook Anywhere avec Outlook 2003 RRS feed

  • Question

  • Bonjour,

    Je viens de migrer un serveur Exchange 2003 SP2 vers un nouveau serveur Exchange 2010 Rollup4 sur Windows 2008 R2.

    J'ai bien généré un certificat SAN avec une PKI entreprise interne. Tout fonctionne OWA, Outlook 2003 et 2010 en MAPI, ActiveSync sur les mobiles HTC.

    Pour Outlook Anywhere :

    Un PC sous Windows 7 et Outlook 2010 fonctionne sans problème avec Outlook Anywhere

    Par contre, les PC sous Windows XP avec Outlook 2003 ne fonctionne pas. Il demande une authentification en permanence.

    NB : la mise à jour vers Outlook 2010 ne change rien.

    J'ai essayé une authentification "basic" et "NTLM", sans résultats.

    Le test de connexion sur l'URL externe https://nom_hote.domaine.com/rpc fonctionne bien.

    Est-ce que c'est un problème Windows XP, un nouveau réglage sur Exchange 2010 ?

    Bref, toutes les idées m'intéresse!

    merci à tous

    FP

    vendredi 9 juillet 2010 17:22

Réponses

  • Bonjour,

    Deux points à vérifier :

    - Windows XP doit être en SP2 au minimum

    - La configuration du provider EXPR

    Pour le provider :

    Outlook on Windows XP or earlier operating systems    The Windows RPC over HTTP component used for Outlook Anywhere requires that the SAN or common name of the certificate must match the Certificate Principal Name configured for Outlook Anywhere. Outlook 2007 and later versions use Autodiscover to obtain this Certificate Principal Name. To configure this value on your Exchange 2010 Client Access server, use the Set-OutlookProvide r command with the -CertPrincipalName parameter. Set this parameter to the external host name that Outlook clients use to connect to Outlook Anywhere .



    http://laubel.wordpress.com/
    samedi 10 juillet 2010 07:53
  • Merci frédéric,

    Tu étais sur la bonne piste. J'ai quand même eu un coup de main de Microsoft qui y a passé 2 heures

    on a saisi :

    Set-OutlookProvider   -Identity EXPR  -CertPrincipalName   none

    Set-OutlookProvider   -Identity EXPR  -CertPrincipalName  msstd:nom_serveur_interne.nom_de_domaine_internet.com (valeur de la commande HELO de mon connecteur d'envoi)

    L'autre erreur est que sur les clients Outlook dans les paramètres Proxy Exchange on méttait https://webmail.nom_de_domaine_internet.com et msstd:webmail.nom_de_domaine_internet.com (solution qui fonctionnait avec Exchange 2003 SP2).

    Maintenant il faut mettre msstd:nom_serveur_interne.nom_domaine_interne_AD

    Merci de ton aide

    FP

     

     

    mardi 13 juillet 2010 04:46

Toutes les réponses

  • Bonjour,

    Deux points à vérifier :

    - Windows XP doit être en SP2 au minimum

    - La configuration du provider EXPR

    Pour le provider :

    Outlook on Windows XP or earlier operating systems    The Windows RPC over HTTP component used for Outlook Anywhere requires that the SAN or common name of the certificate must match the Certificate Principal Name configured for Outlook Anywhere. Outlook 2007 and later versions use Autodiscover to obtain this Certificate Principal Name. To configure this value on your Exchange 2010 Client Access server, use the Set-OutlookProvide r command with the -CertPrincipalName parameter. Set this parameter to the external host name that Outlook clients use to connect to Outlook Anywhere .



    http://laubel.wordpress.com/
    samedi 10 juillet 2010 07:53
  • Merci frédéric,

    Tu étais sur la bonne piste. J'ai quand même eu un coup de main de Microsoft qui y a passé 2 heures

    on a saisi :

    Set-OutlookProvider   -Identity EXPR  -CertPrincipalName   none

    Set-OutlookProvider   -Identity EXPR  -CertPrincipalName  msstd:nom_serveur_interne.nom_de_domaine_internet.com (valeur de la commande HELO de mon connecteur d'envoi)

    L'autre erreur est que sur les clients Outlook dans les paramètres Proxy Exchange on méttait https://webmail.nom_de_domaine_internet.com et msstd:webmail.nom_de_domaine_internet.com (solution qui fonctionnait avec Exchange 2003 SP2).

    Maintenant il faut mettre msstd:nom_serveur_interne.nom_domaine_interne_AD

    Merci de ton aide

    FP

     

     

    mardi 13 juillet 2010 04:46