locked
WDS ne démarre pas erreur 513 et 257 RRS feed

  • Question

  • Bonjour,

    Voici mon problème :

    J'ai installé le rôle WDS sur un Windows serveur 2008 R2. L'installation semble s'être déroulée correctement.

    Cependant je remarque dans le "gestionnaire de serveur/services de déploiement Windows/serveurs" mon serveur n'apparait pas.

    De plus je remarque que le service système "serveur des services de déploiement Windows" ne veut pas démarrer et me renvoi les erreurs suivantes :

    513 : Une erreur s’est produite lors de la tentative d’initialisation du fournisseur WDSDDPS à partir de C:\Windows\system32\wdsddps.dll. Le serveur des services de déploiement Windows sera arrêté. 
     Informations sur l’erreur : 0x906

    257 : Une erreur s’est produite lors de la tentative de démarrage du serveur des services de déploiement Windows. 
     Informations sur l’erreur : 0x906

    J'ai essayé de suivre les autres postes auparavant concernant ce problème mais étant un peu débutant je ne comprends pas certaines aides conseillées.

    D'avance merci pour vos conseils.


    thepec

    mardi 14 août 2012 08:12

Réponses

  • problème résolu, tout venait de mon nom serveur trop long (16 caractères!!!!!!!!!!!!!!!!!!)

    Voilà je suis bien gavé d'avoir galéré pour ça mais c'est réparé :)


    thepec

    jeudi 16 août 2012 08:31

Toutes les réponses

  • Bonjour,

    Merci de mettre comme compte d'administrateur de domaine pour executer le service WDS.

    Autrement dit, au niveau de service, faites un clic droit sur votre service puis propriété puis dans l'onglet "connexion"

    Mettre votre compte administrateur de domaine dans la deuxieme option au lieu de compte systeme local.

    Testez et n'oubliez pas de nous tenir au courant!

    A+


    Best Regards Don't forget to mark it as answer if it helps

    mardi 14 août 2012 10:08
    Auteur de réponse
  • Bonjour et déjà merci.

    J'ai essayé ce que vous m'avez conseillé et voilà le message :

    Windows n'a pas pu démarrer le service Serveur des services de déploiement Windows sur Ordinateur local.

    Erreur 1297 : Un privilège exigé par le service pour fonctionner correctement n'existe pas dans la configuration du compte de service. Vous pouvez utiliser le composant logiciel enfichable Services (services.msc) de la console de gestion Microsoft pour afficher la configuration du service et la configuration du compte.

    Merci d'avance


    thepec

    mardi 14 août 2012 11:31
  • Bonjour,

    Avez vous specifier un controleur de domaine et un catalogue global pour votre serveur WDS?

    Cordialement;


    Best Regards Don't forget to mark it as answer if it helps

    • Proposé comme réponse FKubbiak vendredi 13 septembre 2013 15:09
    • Non proposé comme réponse FKubbiak vendredi 13 septembre 2013 15:09
    mardi 14 août 2012 13:15
    Auteur de réponse
  • Merci de me poser cette question. En effet j'ai vu qu'il fallait spécifier ces deux éléments mais je n'ai pas réussi à trouver par où accéder à ces propriétés. Donc par où y accédons nous?

    thepec

    mardi 14 août 2012 14:42
  • nouvelle précision :

    j'ai vu qu'on pouvait spécifier directement ces deux éléments (controleur de domaine et un catalogue global) directement par la base de registre à cette endroit : HKLM\System\CurrentControlSet\Services\Providers\WDSPXE\Providers\BINLSVC en modifiant ces deux clés

    - Nom : DefaultServer type REG_SZ

    - Nom : DefaultGCServer type REG_SZ

    Cependant ces deux clés n'existent pas dans ma base de registre. Dois-je les créer?

    L'absence de ces clés et le fait que dans le "gestionnaire de serveur/services de déploiement Windows/serveurs" mon serveur n'apparait pas ne veut il pas dire que l'installation c'est mal déroulé ou bien qu'il me manque des options lors de al création du rôle?

    Cordialement;


    thepec

    mardi 14 août 2012 21:02
  • Bonsoir,

    Les erreurs 513/275 peuvent apparaitre si:

    1# L'objet ordinateur du serveur WDS a été déplacé vers une autre unite d'organisation. Du coup, il faut réinitialiser le service WDS avec la commande wdsutil/Initialize-Server /reminst:{RemoteInstallFolder}

    {RemoteInstallFolder} : le chemin du dossier remoteinstall.

    2# Le catalogue global a été changé. Dans ce cas il faut le re-spécifier (nom FQDN) dans les paramètres avancées du WDS (à partir de la console WDS, clique droit sur le nom du serveur/propriétés/avancées). 


    Bechir Gharbi | My blog: @myITforum.com | Twitter: @Bechir_Gharbi | Linkedin: Bechir Gharbi | Time zone: GMT + 1


    mardi 14 août 2012 22:26
  • Bonjour,

    Pour la première solution, j'ai fais une recherche sur l'ensemble de mon ordinateur et le dossier "remoteinstall" est introuvable.

    Pour la deuxième solution, dans la console WDS le nom de mon serveur n'apparait pas et donc je ne peux pas aller dans les propriétés avancées.

    Merci pour le temps consacré à m'aider dans tous les cas.

    Je pense que mon rôle WDS n'est pas complet ou bien que l'installation ne s'est pas finalisée correctement. Cependant en le réinstallant c'est pareil.


    thepec

    mercredi 15 août 2012 07:39
  • Vous disiez "...sur l'ensemble de mon ordinateur"!!! J'assume que vous voulais dire le serveur WDS, n'est ce pas? Sinon vous ne voyez pas le serveur WDS dans la console, est-ce que vous travaillez directement sur le serveur WDS ou bien depuis la console (RSAT) sur votre ordinateur?

    Bechir Gharbi | My blog: @myITforum.com | Twitter: @Bechir_Gharbi | Linkedin: Bechir Gharbi | Time zone: GMT + 1

    mercredi 15 août 2012 16:39
  • Oui autant pour moi je me suis mal expliqué.

    Quand je vais dans le gestionnaire de serveur et que je développe le nœud (+) "services de déploiement Windows" et que je développe ensuite le nœud "serveurs", j'ai le message suivant : "aucun élément à afficher dans cet aperçu" alors que normalement ici je devrais voir marqué le nom de mon serveur.

    Ensuite vous me parliez du dossier "remoteinstall". J'ai lancé une recherche sur l'ensemble du disque dur de mon serveur et je ne l'ai pas trouvé.

    C'est pourquoi je pense que tout ne s'est pas bien déroulé ou bien que je n'ai pas tout bien compris.

    Cordialement


    thepec

    mercredi 15 août 2012 17:34
  • Bonsoir,

    Le message est tout à fait normal car vous devez configurer le serveur WDS après l'installation du rôle. De plus, le dossier "remoteinstall" ne se crée pas automatiquement lors de l'installation du role WDS, mais plutôt lors de la configuration de WDS. Voici un lien qui peut vous aider http://netwanlan.wordpress.com/2012/05/04/wds-installation-and-configuration-guide/


    Bechir Gharbi | My blog: @myITforum.com | Twitter: @Bechir_Gharbi | Linkedin: Bechir Gharbi | Time zone: GMT + 1

    mercredi 15 août 2012 22:01
  • oui je suis tout à fait d'accord avec vous cependant dans mon cas le lien en clic droit pour configurer le serveur n'était même pas accessible.

    J'ai cependant réussi à régler ce problème en ajoutant le serveur directement par son adresse ip.

    Le seul problème qui me reste est que le service "serveur des services de déploiement windows" ne veut pas démarrer à cause d'un problème de privilège et ceci alors que dans les propriétés de ce service j'ai paramétré le compte administrateur. (erreur 1297) un privilège exigé par le service pour fonctionner correctement n'existe pas dans la configuration du compte du service).


    thepec

    jeudi 16 août 2012 07:55
  • problème résolu, tout venait de mon nom serveur trop long (16 caractères!!!!!!!!!!!!!!!!!!)

    Voilà je suis bien gavé d'avoir galéré pour ça mais c'est réparé :)


    thepec

    jeudi 16 août 2012 08:31
  • Bonjour,

    Nous sommes heureux d’entendra ça. Merci aussi de marquer les réponses qui vous trouvez utiles.

    Cordialement,

    Dan


    Dan BAJENARU, MSFT    Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    jeudi 16 août 2012 08:45