locked
Comment démarrer un programme depuis le serveur NAS sans avertissement de sécurité? RRS feed

  • Question

  • Bonjour

    J'ai installé le logiciel gratuit "camion des mots" sur un NAS accessible depuis n'importe quel PC de l'école. Depuis chacun d'eux, j'ai créé un raccourci sur le bureau afin que les élèves (CP au CM2) puissent démarrer le logiciel facilement. Cependant au double-clic apparaît une fenêtre "avertissement de sécurité" qui me demande de confirmer l'exécution du programme. Y a-t-il un moyen de faire en sorte que cet avertissement soit squizzé?

    J'ai aussi tenté de créer un lecteur réseau Z: qui se reconnecte au démarrage à Z:\CamionDesMots.exe. Mais c'est identique...

    J'ai essayé aussi d'ajouter Z:\CamionDesMots.exe à la liste des programmes autorisés par le pare-feu.... sans succés : toujours la fenêtre "avertissement de sécurité".

     

    Je me demande donc : Y a-t-il un moyen de faire en sorte que cet avertissement soit squizzé?

     

    merci de votre aide.


    Cordialement
    Pascal
    http://www.scalpa.info
    mardi 13 décembre 2011 19:29

Réponses

  • Bonjour,

    Copie ceci dans notepad et sauvegarde en fichier d'extension .reg

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
    "SaveZoneInformation"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "LowRiskFileTypes"=".exe;.reg;.vbs"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Attachments]
    "SaveZoneInformation"=-

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "LowRiskFileTypes"=-

    Tu peux rajouter d'autre extensions si tu le souhaites.


    Revue du Geek | Déployer Windows 7 avec MDT 2010
    mardi 13 décembre 2011 21:29
  • Modifier le registre en changeant les avertissements pour tous les fichiers exécutables me paraît trop risqué. C'est ce que fait :
    "LowRiskFileTypes"=".exe;.reg;.vbs"
    

    La solution que je t'ai proposé est correcte. Si tu ne veux pas autoriser cela de façon globale parce que tu trouves trop risqué alors tu n'auras pas de choix que d'accepter l'avertissement à chaque fois.

    Revue du Geek | Déployer Windows 7 avec MDT 2010
    • Marqué comme réponse scalpa jeudi 15 décembre 2011 18:38
    jeudi 15 décembre 2011 18:25

Toutes les réponses

  • Bonjour,

    Le fichier ne serait-il pas en état bloqué ?

    Pour débloquer votre exécutable, faire un clic droit / propriétés sur ce dernier. Il devrait y avoir un bouton "Débloquer".


    Julien Darakdjian [Nelite] - http://www.nelite.com/community/b/jdarakdjian/default.aspx
    mardi 13 décembre 2011 20:14
    Auteur de réponse
  • Non, je ne pense pas. Si je clique sur le bouton exécuter cela fonctionne. Je souhaite juste pouvoir démarrer le programme sans cette fentre de sécurité comme quand l'éxécutable se trouve sur le disque du pc c:
    Cordialement
    Pascal
    http://www.scalpa.info
    mardi 13 décembre 2011 20:31
  • Bonjour,

    Copie ceci dans notepad et sauvegarde en fichier d'extension .reg

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments]
    "SaveZoneInformation"=dword:00000001

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "LowRiskFileTypes"=".exe;.reg;.vbs"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Attachments]
    "SaveZoneInformation"=-

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Associations]
    "LowRiskFileTypes"=-

    Tu peux rajouter d'autre extensions si tu le souhaites.


    Revue du Geek | Déployer Windows 7 avec MDT 2010
    mardi 13 décembre 2011 21:29
  • L'état "bloquer" n'empêche pas forcément l'exécution mais fait apparaître une fenêtre de sécurité.

    Pour compléter le paramétrage proposé par Yanncik, vous pouvez également effectuer ce paramétrage par LGPO (Stratégie locale), dans User Configuration\Administrative Templates\Windows Components\Attachment. Le résultat sera le même, c'est juste la méthode de mise en place qui est différente.

    Un petit lien vers le technet sur le sujet.


    Julien Darakdjian [Nelite] - http://www.nelite.com/community/b/jdarakdjian/default.aspx
    mardi 13 décembre 2011 22:27
    Auteur de réponse
  • Il n'y a pas de bouton "bloquer"dans les propriétés après clic-droit!

    Modifier le registre en changeant les avertissements pour tous les fichiers exécutables me paraît trop risqué. C'est ce que fait :

    "LowRiskFileTypes"=".exe;.reg;.vbs"
    


    je pense?

    Je souhaite appliquer une règle de confiance au cas par cas.

    merci

     


    Cordialement
    Pascal
    http://www.scalpa.info
    mercredi 14 décembre 2011 10:31
  • Bonsoir Scalpa ,

     

    La solution la plus simple est de désactiver l UAC  de votre PC

    Cliquer sur démarrer " ....dans la fonction recherche ,inscrire "contrôle " puis sélectionner la ligne "modifier les paramètres de contrôle du compte d utilisateur "

     

     Vous pouvez également spécifier l adresse ou l IP  de votre serveur NAS dans outils .... options internet ......onglet Sécurité ....... Intranet local ........Sites ....... Avancés

    Cordialement



    • Proposé comme réponse arch21Editor jeudi 15 décembre 2011 18:22
    • Modifié arch21Editor jeudi 15 décembre 2011 18:32
    • Non proposé comme réponse arch21Editor jeudi 15 décembre 2011 18:42
    jeudi 15 décembre 2011 18:21
    Auteur de réponse
  • La solution la plus simple est de désactiver l UAC  de votre PC

    http://www.forum-seven.com/le-controle-des-comptes-utilisateurs-uac-sous-windows-seven-431


    Ca n'a pas de rapport avec l'UAC. Meme avec l'UAC désactivé tu auras le message d'avertissement.

    Revue du Geek | Déployer Windows 7 avec MDT 2010
    jeudi 15 décembre 2011 18:23
  • Modifier le registre en changeant les avertissements pour tous les fichiers exécutables me paraît trop risqué. C'est ce que fait :
    "LowRiskFileTypes"=".exe;.reg;.vbs"
    

    La solution que je t'ai proposé est correcte. Si tu ne veux pas autoriser cela de façon globale parce que tu trouves trop risqué alors tu n'auras pas de choix que d'accepter l'avertissement à chaque fois.

    Revue du Geek | Déployer Windows 7 avec MDT 2010
    • Marqué comme réponse scalpa jeudi 15 décembre 2011 18:38
    jeudi 15 décembre 2011 18:25
  • La solution la plus simple est de désactiver l UAC  de votre PC

    http://www.forum-seven.com/le-controle-des-comptes-utilisateurs-uac-sous-windows-seven-431


    Ca n'a pas de rapport avec l'UAC. Meme avec l'UAC désactivé tu auras le message d'avertissement.

    Revue du Geek | Déployer Windows 7 avec MDT 2010

    Bonsoir Yannick ,

     

    Merci pour le retour d information explicite

     

    Cordialement

    jeudi 15 décembre 2011 18:44
    Auteur de réponse
  • Dommage que cela ne puisse se gérer au cas par cas...

    Merci de votre aide et joyeux Noël à tous.


    Cordialement
    Pascal
    http://www.scalpa.info
    jeudi 15 décembre 2011 19:18