none
exchange dag failover RRS feed

  • שאלה

  • שלום

    יש לי שני שרתי excahnge 2010 sp2 ru4  עם dag ו-  aapliance nlb כאשר אני מבצע restart  לאחד השרתים המתשמשים מתבקשים להזין שם משתמש וסיסמא?

    האם הנ"ל תקין והאם ניתן למנוע זאת? אני רוצה שהפעולה תהיה שקופה למשתמש.

    תודה

    יום רביעי 07 נובמבר 2012 10:21

תשובות

  • הי,

    אתה יכול לבצע בדיקה שאין הבדלים בין שרתי ה-CAS/Mailbox, החל מהגדרות גישה (websevice וכו) ועד עדכוני SP.

    או לחלופין להוסיף שרת ל-CASArray ול-DAG ולבדוק האם הבעיה חוזרת על עצמה.

    האם בדקת את השרתים אם הכלים הבאים: Test-OutlookWebServices, Test-ReplicationHealth.

    סיבות נוספות שיכולות להיות הם: הגדרת Mapi over kerberos ואולי גם הגדרה של ה-CASArray מחדש.

    אלי.


    The New UC User Group website, www.mucugi.com

    • הוצע כתשובה על-ידי Yaniv TotiashviliModerator יום רביעי 14 נובמבר 2012 12:21
    • סומן כתשובה על-ידי Eran Sharvit יום שני 19 נובמבר 2012 23:57
    יום ראשון 11 נובמבר 2012 17:31
  • יפה, מלבד זאת, אני מציע לך לחשבון על דרך לעבור ל- Exchange 2013 במידה וה- PF הוא חלק משמעותי בחייך ובחיי החברה שלך, כי ב- EX2013 עשו שיפורים רבים והיום ה- PF הוא Mailbox נוסף ב- DB שאתה יכול לרפלק ב- DAG, וזה יכול לחסוך לך המון (אבל המון, כן?) כאבי ראש.

    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    • הוצע כתשובה על-ידי Yaniv TotiashviliModerator יום רביעי 14 נובמבר 2012 12:22
    • סומן כתשובה על-ידי Eran Sharvit יום שני 19 נובמבר 2012 23:56
    יום שלישי 13 נובמבר 2012 21:00
    מנחה דיון

כל התגובות

  • שלום,

    חסרים קצת פרטים. האם שרתי ה-DAG משמשים גם כ-CAS. האם מוגדר CASArray בין השרתים?

    בעקרון ישנם כמה דברים שגורמים לבעיה:

    כאשר אתה מגדיר DNS ואין ttl נמוך.

    כאשר ה-SCP פונה לשרת ולא להגדרה של CASArray.

    אני מציע שתבודק את שני ההגדרות הנ"ל ותעדכן.

    כן אפשר למנוע, תוודא שהגדרת ה-SCP נכנונה כי היא זו שאחראית על ה-Autodiscover מול התחנות.

    הפקודה היא Set-ClientAccessServer –AutodiscoverServiceInternalUri

    אלי.


    The New UC User Group website, www.mucugi.com



    • נערך על-ידי Eli_ShlomoMVP יום רביעי 07 נובמבר 2012 16:47
    יום רביעי 07 נובמבר 2012 16:45
  • אלי שלום,

    השרתים אכן משמשים כ- cas, ביצעתי בדיקה לפי ההמלצה שלך ולדעתי מקור הבעיה שלי הוא שה- AutodiscoverServiceInternalUri מכוון לכל שרת בנפרד ולא לרשומת ה- dnsשל ה- cas array.

    אני אבצע את השינוי אך טרם לשינוי אדאג לסדר את ה- certificate כך שהמשתשים לא יקבלו הודעות בעיה של certificate ולאחר מכן אעדכן האם עבד תקין או לא.

    יום חמישי 08 נובמבר 2012 07:18
  • אלי שלום,

    ביצעתי את השינויים אבל עדיין בעת אתחול שרת אחד מבין השניים המשתמש מתבקש להזין שם משתמש וסיסמא.

    בשני השרתים מוגדרים כל ה- role -ים, ה- AutodiscoverServiceInternalUri מכוון ל- dns entry של ה- casarray וב- big ip יש הגדרה של virual server לפי template של exchange מובנה שבא עם המכונה, כמו כן ה- ttl  הורד ל- 5 דקות.

    אשמח אם יש לך עוד רעיון.

    תודה רבה

    יום חמישי 08 נובמבר 2012 15:39
  • שלום,

    האם סיימת את הגדרת ה-CASArray מול ה-DB.

    הפקודה היא Set-MailboxDatabase -Identity “DatabaseName” –RPCClientAccessServer

    בנוסף לכך ישנם עוד כמה הגדרות שאפשר לבדוק, אבל תסיים את ה-CAS כי לרוב הבעיה מגיעה משם.

    אלי.


    The New UC User Group website, www.mucugi.com

    יום חמישי 08 נובמבר 2012 18:00
  • שלום,

    ההגדרה של ה- cas array בוצעה ממזמן, זה לא נרה לי הכיוון.

    התופעה ממש מוזרה כביכול ה- token של ה- cliebt מול ה- cas הולך "לאיבוד" , אני פונה עם ה- scp ישירות ל-  cas array ה- db מוגדרים מול ה- cas array ועדיין יש את הבקשה לשם משתמש וסיסמא.

    יום חמישי 08 נובמבר 2012 19:34
  • שלום,

    האם ביצעת Mapi over Kerberos על שרתי הדואר?

    כאשר אתה עושה failover וישנה סיסמא, אתה יכול לבדוק באמצעות Email Test COnfiguration לאן התיבה מנסה לפנות?

    לפי דעתי ישנה הגדרה של AutoDiscover שמפנה עדיין את התיבות לשרת ספציפי.

    אלי.


    The New UC User Group website, www.mucugi.com


    • נערך על-ידי Eli_ShlomoMVP יום חמישי 08 נובמבר 2012 20:14
    יום חמישי 08 נובמבר 2012 20:05
  • לא ביצעתי mapi over kerberos, אני מניח שאתה מתכוון להגדרה של asa?

    אם כן אשמח לקבל המלצה כיצד לבצע.

    בהתייחס ל- auto discover  אני אבדוק האם פיספסתי משהו

    יום חמישי 08 נובמבר 2012 20:31
  • לדעתי תוודא היטב את הגדרות ה-Autodiscover לפני שאתה ממשיך לאופציה השניה.

    להגדרת Mapi Over Kerberos או ASA תגדיר לפי המאמר הבא, http://blogs.technet.com/b/exchange/archive/2011/04/15/recommendation-enabling-kerberos-authentication-for-mapi-clients.aspx

    אלי.


    The New UC User Group website, www.mucugi.com

    יום חמישי 08 נובמבר 2012 20:38
  • שלום,

    לפי מה שאני רואה ה- autodiscover  נראה תקין האם יש לך סט פקודות או הפניה מה לבדוק, אולי אני מפספס משהו?

    יום חמישי 08 נובמבר 2012 21:02
  • שלום רב,

    ישנו צורך לבצע שינויים נרחבים בתשתית אצלכם, דבר העלול לגרום להשבתה.

    תוכל להשתמש בפקודות הבאות על מנת לבנות את ה VIRTUAL DIR של ה CAS ARRAY בצורה נכונה.

    עם זאת, אם אין לכם הכרות טובה עם המערכת אני ממליץ בחום שתיעזרו ביועץ תשתיות.

    בהצלחה

    Get-AutodiscoverVirtualDirectory -Server INTERNALSERVERNAME | Set-AutodiscoverVirtualDirectory –InternalUrl “https://INTERNALSERVERNAME/Autodiscover/Autodiscover.xml”
     
    Get-ClientAccessServer -Server INTERNALSERVERNAME | Set-ClientAccessServer –AutodiscoverServiceInternalUri “https://INTERNALSERVERNAME/Autodiscover/Autodiscover.xml”
     
    Get-WebservicesVirtualDirectory -Server INTERNALSERVERNAME | Set-WebservicesVirtualDirectory –InternalUrl “https://INTERNALSERVERNAME/Ews/Exchange.asmx”
     
    Get-OabVirtualDirectory -Server INTERNALSERVERNAME | Set-OabVirtualDirectory –InternalUrl “https://INTERNALSERVERNAME/Oab”
     
    Get-OwaVirtualDirectory -Server INTERNALSERVERNAME | Set-OwaVirtualDirectory –InternalUrl “https://INTERNALSERVERNAME/Owa”
     
    Get-EcpVirtualDirectory -Server INTERNALSERVERNAME | Set-EcpVirtualDirectory –InternalUrl “https://INTERNALSERVERNAME/Ecp”
     
    Get-ActiveSyncVirtualDirectory -Server INTERNALSERVERNAME | Set-ActiveSyncVirtualDirectory -InternalUrl “https://INTERNALSERVERNAME/Microsoft-Server-ActiveSync”

     

    Get-AutodiscoverVirtualDirectory -Server INTERNALSERVERNAME | Set-AutodiscoverVirtualDirectory –ExternalUrl “https://mail.externaldomainname.com.com/Autodiscover/Autodiscover.xml”
     
    Get-webservicesVirtualDirectory -Server INTERNALSERVERNAME | Set-webservicesVirtualDirectory –ExternalUrl “https://mail.externaldomainname.com.com/Ews/Exchange.asmx”
     
    Get-OabVirtualDirectory -Server INTERNALSERVERNAME | Set-OabVirtualDirectory –ExternalUrl “https://mail.externaldomainname.com.com/Oab”
     
    Get-OwaVirtualDirectory -Server INTERNALSERVERNAME | Set-OwaVirtualDirectory –ExternalUrl “https://mail.externaldomainname.com.com/Owa”
     
    Get-EcpVirtualDirectory -Server INTERNALSERVERNAME | Set-EcpVirtualDirectory –ExternalUrl “https://mail.externaldomainname.com.com/Ecp”
     
    Get-ActiveSyncVirtualDirectory -Server INTERNALSERVERNAME | Set-ActiveSyncVirtualDirectory -ExternalUrl “https://mail.externaldomainname.com.com/Microsoft-Server-ActiveSync”

     

    Get-AutodiscoverVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl
     
    Get-webservicesVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl
     
    Get-OabVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl
     
    Get-OwaVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl
     
    Get-EcpVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl
     
    Get-ActiveSyncVirtualDirectory -Server INTERNALSERVERNAME | ft Identity,InternalURL,ExternalUrl


    Set-AutodiscoverVirtualDirectory -Identity 'autodiscover (default Web site)' -internalUrl ($null)

     


    Set-OwaVirtualDirectory -Identity "owa (Default Web Site)" -BasicAuthentication <$true|$false>

     


    Best Regards, Yuval Sinay, Y.S.Net CTO http://www.ysnet.co.il , Blog: http://blogs.microsoft.co.il/blogs/yuval14

    יום חמישי 08 נובמבר 2012 22:20
  • יובל שלום,

    לפי מה שאני מבין מהפקודות צריך "לכוון" את הכל ל- dns host של ה- cas array name?

    מה שמוזר לי הוא מדוע בעת יצירת cas array לא נתקלתי בכל הדרישות הללו?

    תודה מראש

    יום שישי 09 נובמבר 2012 06:07
  • שלום רב,

    בפעם הבאה שאתם מתקינים מוצר, אני מציע שתעברו על התיעוד לפני כן, ותבצעו התקנה במעבדה.

    בכל מקרה, הפקודות הנ"ל הן הכוונה, וצריך להכיר את הנושא יותר לעומק על מנת לוודא שהמערכת תעבוד לאחר

    מכן באופן תקין. כמובן שרצוי לערב את התמיכה של יצרן ה LB, על מנת לוודא שפיתרון ה LB תומך בתצורה הנ"ל, וכי

    ההגדרות הינן נכונות.

    בהצלחה


    Best Regards, Yuval Sinay, Y.S.Net CTO http://www.ysnet.co.il , Blog: http://blogs.microsoft.co.il/blogs/yuval14


    • נערך על-ידי Yuval Sinay יום שישי 09 נובמבר 2012 09:53
    יום שישי 09 נובמבר 2012 09:53
  • יובל שלום,

    מהבדיקה שלי כל הפקודות שרשמת כבר תקינות ועדיין אני חווה בעיה בעת ביצוע failover.

    אני אנסה לבחון הלאה ובמידה ואמצא משהו אעדכן

    שבת 10 נובמבר 2012 14:21
  • אם כך המצב, תוודא שה-Outlook Anywhere מוגדר לעבוד עם NTLM.

    גם בצד השרת וגם בתחנות ולאחר מכן תוודא שה-failover עובד.

    אלי.


    The New UC User Group website, www.mucugi.com

    יום ראשון 11 נובמבר 2012 05:15
  • אלי שלום,

    ה-outlook anywhere מושבת הן מצד השרת והן מצד ה- client.

    מה שדי מוזר הוא שכאשר אני מבצע restart לשרת אחד מבין השניים (ורק לו) יש לי בעיה ב- failover כאשר אני מבצע לשרת השני אין לי בעיה זה תמיד אותו שרת שגורם לתופעה.

    יום ראשון 11 נובמבר 2012 07:42
  • הי,

    אתה יכול לבצע בדיקה שאין הבדלים בין שרתי ה-CAS/Mailbox, החל מהגדרות גישה (websevice וכו) ועד עדכוני SP.

    או לחלופין להוסיף שרת ל-CASArray ול-DAG ולבדוק האם הבעיה חוזרת על עצמה.

    האם בדקת את השרתים אם הכלים הבאים: Test-OutlookWebServices, Test-ReplicationHealth.

    סיבות נוספות שיכולות להיות הם: הגדרת Mapi over kerberos ואולי גם הגדרה של ה-CASArray מחדש.

    אלי.


    The New UC User Group website, www.mucugi.com

    • הוצע כתשובה על-ידי Yaniv TotiashviliModerator יום רביעי 14 נובמבר 2012 12:21
    • סומן כתשובה על-ידי Eran Sharvit יום שני 19 נובמבר 2012 23:57
    יום ראשון 11 נובמבר 2012 17:31
  • דרגו שלום רב,

    המצב שלך לא תקין. אתה צריך לוודא שיש לך CAS Array ברמת Exchange 2010 שתוחם את עצמו ל- AD Site שלך, לאחר מכן, תיצור VIP ב- L7 LB שלך (אני לא יודע איזה Appliance יש לך, אני מטמיע רק של F5 ולכן אתייחס ל- F5) ותקשר אותו ל- CAS Array שלך. תצביע לשתי הכתובות ותגדיר Sticky session כך שבמקרה של ניתוק (כמו שציינת), יתבצע Redirect אוטומטית לשרת השני של תעבורת ה- HTTPS\RPC.

    מידע נוסף אודות הגדרת L7 LB F5 עבור Exchange 2010 תמצא כאן: http://www.f5.com/pdf/deployment-guides/f5-exchange-2010-dg.pdf


    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    יום ראשון 11 נובמבר 2012 20:48
    מנחה דיון
  • נתנאל שלום,

    1. יש לי cas array
    2. יש לי site  אחד ולכן אין בעיה מהצד הזה
    3. אני עובד עם f5 וכל ההגדרות בוצעו  כבר מזה זמן ובמקרה גם לפי הקובץ שהעלת פה, עבדתי עם ה- template המובנה שיש ב- f5.
    4. ה- presistence מודר ל- source address

    יום שני 12 נובמבר 2012 10:13
  • אתה עובד עם SSL Offloading?

    בנוסף, הייתי מציע לך לצור קשר עם F5 או ספק השירות שלך ולראות שכל ההגדרות תקינות. כמו כן, הייתי מציע לך לבדוק ב- Event Viewer בשרתים אם יש בעיות לגבי Connectivity ל- CAS.


    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    יום שני 12 נובמבר 2012 21:20
    מנחה דיון
  • נתנאל שלום,

    אני לא מבצע ssl offloading ואין משהו חריג ב- event viewer, לדעתי כל הבעיה מקורה ב- pf היות והוא לא חלק מה- dag (כי הוא לא יכול להיות שם - לפי מיקרוסופט) והיות וה- client  מתחבר אליו ישירות ולא דרך ה- cas אזי אתחול שרת יגרור הצגת popup של שם משתמש וסיסמא.

    יום שלישי 13 נובמבר 2012 09:24
  • במקרה שכזה עלייך להרים אז PF נוסף ולבצע Replication ביניהם

    ובעת Disaster לשנות ידנית את ה- PF ב- DB

    ניתן כמובן לעשות את זה בסקריפט דרך EMS


    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    יום שלישי 13 נובמבר 2012 13:07
    מנחה דיון
  • שלום,

    כבר ביצעתי רפליקציה בעת ההקמה , אך עדיין זה לא ימנע את ה- popup  של ה- username וה- password.

    יום שלישי 13 נובמבר 2012 13:08
  • פתרון לא ממש מציאותי עבורך (או שכן, אני לא מכיר אותך) שעובד אצל כמה לקוחות שלי - להקים שרת שיחזיק רק את ה- PF וישב ב- SITE מרוחק (לטובת בעיות של Site Resilience וכו') ולהצביע אליו, ולשרת הזה אתה תבצע תחזוקה רק במקרי קיצון וכו' לפי לו"ז מסודר שלא יפגע במשתמשים.

    יש לי המון לקוחות שעושים את זה, כאשר השרת הזה יושב באתר ה- DRP\BCP שלהם.


    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    יום שלישי 13 נובמבר 2012 13:50
    מנחה דיון
  • אני כרגע סיימתי לכתוב מייל עם הפתרון הזה כהצעה למנוע את התופעה המדוברת :) ואני רואה שחשבנו על אותו דבר

    יום שלישי 13 נובמבר 2012 14:01
  • יפה, מלבד זאת, אני מציע לך לחשבון על דרך לעבור ל- Exchange 2013 במידה וה- PF הוא חלק משמעותי בחייך ובחיי החברה שלך, כי ב- EX2013 עשו שיפורים רבים והיום ה- PF הוא Mailbox נוסף ב- DB שאתה יכול לרפלק ב- DAG, וזה יכול לחסוך לך המון (אבל המון, כן?) כאבי ראש.

    Netanel Ben-Shushan, MCSA/E, MCTS, MCITP, Windows Expert-IT Pro MVP. IT Consultant & Trainer | Website (Hebrew): http://www.ben-shushan.net | IT Services: http://www.ben-shushan.net/services | Weblog (Hebrew): http://blogs.microsoft.co.il/blogs/netanelb | E-mail: msilforums@ben-shushan.net

    • הוצע כתשובה על-ידי Yaniv TotiashviliModerator יום רביעי 14 נובמבר 2012 12:22
    • סומן כתשובה על-ידי Eran Sharvit יום שני 19 נובמבר 2012 23:56
    יום שלישי 13 נובמבר 2012 21:00
    מנחה דיון
  • אכן חשבתי על מעבר אבל אני מניח שזה יהיה לפחות עוד חצי שנה - שנה, אני אחכה קצת שהמערכת תוטמע בארגונים ויהיו רג'קטים.

    אני שוקל להעלים את ה- PF על - ידי הצעת חלופות שונות,

    נראה מה יהיה,

    המון תודה לכל החברים בפורום.

    יום רביעי 14 נובמבר 2012 07:36
  • באותה תופעה שנתקלת חוויתי אותה היום באותה צורה, ה-HLB היה מסוג F5, לאחר אינספור בדיקות גילינו שהבעיה מגיעה מה-F5.

    בתמיכה של F5 עדכנו שיש באג, מסתבר שזה הלקוח הראשון שפונה אליהם עם בעיה מסוג זה, הפתרון לתקלה הוא עדכון ה-F5.

    אלי.


    The New UC User Group website, www.mucugi.com

    יום רביעי 14 נובמבר 2012 15:11
  • המון המון תודה
    יום ראשון 18 נובמבר 2012 08:46
  • האם תוכל לרשום לי מה הגירסא שהיתה ולאיזו גרסה שדרגת את ה- f5?

    יום ראשון 18 נובמבר 2012 08:59