none
Windows Server 2016 HyperV - SuSe SLES12 SP2 Guest machine's network adapter settings not aligned with windows host RRS feed

  • שאלה

  • My Windows server 2016 HyperV SuSe Guest SLES12 SP2 machine's network adapter settings are not aligned with the physical network adapter settings in windows server 2016 host, i.e.  in hyperv SuSe SLES12  guest machine is showing "Unknown" Duplex and Auto-negotiation=off, but in windows server 2016 host, the physical adapter is showing Full duplex mode and auto negotiation is ON.   Is there a way to make these two network settings parameters in SuSe HyperV guest machine align with windows Host  network adapter settings ?

    [HyperV SuSe SLES12 SP2 Guest machine network adapter settings]

    > sudo /sbin/ethtool eth0

    Settings for eth0:

            Supported ports: [ ]

            Supported link modes:   Not reported

            Supported pause frame use: No

            Supports auto-negotiation: No

            Advertised link modes:  Not reported

            Advertised pause frame use: No

            Advertised auto-negotiation: No

            Speed: 100Mb/s

            Duplex: Unknown! (255)

            Port: Other

            PHYAD: 0

            Transceiver: internal

            Auto-negotiation: off

            Link detected: yes

    יום שלישי 25 יוני 2019 13:01

כל התגובות

  • I'm not sure on this, however the duplex and auto-negotiation options are not supported/changeable on a Hyper-V VM.

    However, these options would relate to the kernel version (version of netvsc module), and SP2 kernel is very(?) old.

    I would highly recommend to try this with a newer kernel, or maybe SP4 on a different VM, and compare then.

    יום רביעי 26 יוני 2019 07:24