none
Task Scheduler - The specified account name is not valid RRS feed

  • שאלה

  • I have created a new scheduled task in task scheduler on a domain-joined 2019 server. I have setup the task to run as a local user account. I was successfully able to create the task.

    However, when I attempt to add a new trigger to the task and hit OK, after entering the password for the local user I get the following error message:

    "An error has occurred for task Backup OS. Error message: The specified account name is not valid."

    I have administrative privileges on the server.

    יום רביעי 01 מאי 2019 19:45

כל התגובות

  • Hi,

    Thank you for posting in Microsoft TechNet Forum.

    Based on your description, please refer to the following methods to troubleshoot:

    1. Try to go to the Task Scheduler in the Start menu or Control Panel, right-click on it and select "Run as Administrator".

    2. Try to run a command prompt "as administrator" and use the Schtasks command-line utility to make changes:

    https://docs.microsoft.com/en-us/previous-versions/technet-magazine/ff356867(v=msdn.10)

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    יום חמישי 02 מאי 2019 02:24
    מנחה דיון
  • Hi,
    How things are going there on this issue?
    Please let me know if you would like further assistance.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    יום ראשון 05 מאי 2019 12:14
    מנחה דיון
  • Hi,

    Is there anything else I can do to help you on this issue?

    Please feel free to contact me if you have any questions.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    יום שלישי 07 מאי 2019 01:23
    מנחה דיון
  • I am having the same issue. I dont encounter this in Server 2008 R2.
    • הוצע כתשובה על-ידי KarlKoder87 שבת 27 יולי 2019 18:26
    • הצעה כתשובה בוטלה על-ידי KarlKoder87 שבת 27 יולי 2019 18:26
    יום שני 27 מאי 2019 12:45
  • Found the issue on local account. User account name must be --> SERVERNAME\USERNAME
    • נערך על-ידי Hector Bryan יום שני 27 מאי 2019 12:55
    • הוצע כתשובה על-ידי KarlKoder87 שבת 27 יולי 2019 18:26
    יום שני 27 מאי 2019 12:55
  • I got the same after update to Win10 1803

    I remember Windows XP/2003 was plagued by the same crap. Nothing changed in 18 years.

    Like always, instead of solving problems, MS spams the Internet with canned answers, best of which is uninstall Windows.

    • נערך על-ידי Hale_ru שבת 10 אוגוסט 2019 13:24
    שבת 10 אוגוסט 2019 13:20
  • I get this on Windows 10 pro too.

    Running as admistrator does not help.

    It not sensible that you are promted for an account name in a drop-down (ie yours), you select it, and are told it not valid  - without any explanation!

    We do need more involved responses to these questons otherwise people to just give up!


    • נערך על-ידי jason 8 יום ראשון 11 אוגוסט 2019 10:59
    יום ראשון 11 אוגוסט 2019 10:59
  • had the same issue! driving me nuts!

    You're the man, thank you!!!

    יום שני 12 אוגוסט 2019 11:36
  • Right on Hector. Fixed the issue!
    יום חמישי 22 אוגוסט 2019 18:23
  • For me, I got the error when checking "do this with the user logged or not", if I checked the "do this when the user is logged" I didn't get the prompt (that gave the error)

    (w10 home)

    יום שישי 23 אוגוסט 2019 11:04
  • I also faced this issue. I supplied correct Administrator password. But didnt accept it. 

    Thanks Pls help to resolve this. 

    יום חמישי 29 אוגוסט 2019 15:09
  • I also started having this problem recently on multiple Windows 10 laptops.  I can't edit tasks that I created and have  edited in the past.  I get the same error message when I try to make changes.  I can still run the task as previously defined.  I believe this started happening after an update. C'mon, Microsoft!!!
    שבת 31 אוגוסט 2019 14:31
  • On Win 10Pro:

    I Tried to delete the task using Schtasks and it failed saying "access denied"

    I tried using the Administrator, domain/Administrator, and running task scheduler as an administrator. 

    It seems that the task scheduler module is not communicating with the user account records.

    My other Win 10 Pro machines work fine.

    • הוצע כתשובה על-ידי Jayden MacRae יום שלישי 03 ספטמבר 2019 20:26
    • הצעה כתשובה בוטלה על-ידי Jayden MacRae יום שלישי 03 ספטמבר 2019 20:26
    שבת 31 אוגוסט 2019 19:18
  • I solved this by:

    1. Editing the user account for the task to run as SYSTEM

    2. Save task

    3. Edit task

    4. Edit the user account for the task to run as the user you want

    5. Save task


    יום שלישי 03 ספטמבר 2019 20:28
  • I did this on my own computer and realized that you can't use the drop down menu, you have to type the path instead. For example, my drop down option was "joshm" but that didn't work. Instead I had to type in "DESKTOP-N76IO0E\joshm" and that worked.

    I hope this helps anyone that sees this. Instead of using the drop down menu, type in

    '<desktop name>\<username>'

    and see if that works.

    After how many threads microsoft support locked after not answering people's questions, you would think they would have fixed such a simple issue

    יום שני 09 ספטמבר 2019 03:28
  • Thank you!! Got this was driving me crazy. I had a .bat file pinging a server to repeat a command but I THOUGHT this would be much easier to do.

    This did it. Thanks again.

    יום חמישי 19 ספטמבר 2019 02:42
  • For me, using SERVERNAME\USERNAME was not enough. The user didn't have enough access rights on the task. You can fix that by using ICACLS from a admin command prompt. Strangely enough, tasks seems to be stored in two folders: C:\Windows\Tasks and C:\Windows\System32\Tasks. I changed both:

    ICACLS C:\Windows\Tasks /grant <Your Windows User Name>:f
    ICACLS C:\Windows\Tasks\*.* /grant <Your Windows User Name>:f
    ICACLS C:\Windows\System32\Tasks /grant <Your Windows User Name>:f
    ICACLS C:\Windows\System32\Tasks\*.* /grant <Your Windows User Name>:f



    יום שישי 27 ספטמבר 2019 12:21
  • I have been searching for a solution for a scheduled task that was not working the way I intended. I could no longer edit it, disable it, or delete it. I kept getting an error, "Error message: The specified account name is not valid."
    I attempted to do these ICACLS things and they did not solve the issue. In the end, I went to %WINDIR%\System32\Tasks and deleted the task in question. Then, upon reopening Task Scheduler, I remade the task with the new settings.

    In the end, I think I solved my issue through brute force. I still do not know why Task Scheduler claimed that I didn't have permission to edit my own task.


    יום חמישי 10 אוקטובר 2019 14:00
  • Try this fix. Go to a command prompt, and type in "whoami"

    Whatever shows up is the name that Task Scheduler is looking for.

    For instance mine says:  desktop-abcdef\myusernam

    use that as the username, and use the password that you use to log on to windows. 

    I don't recognize the letters that come after "desktop", and the rest of my username seems to be a truncated part of my actual username.  But it works and allows me to save the changes.

    יום שלישי 22 אוקטובר 2019 16:10
  • I had this issue. I was using a Microsoft account. I had migrated to a MS a/c form a local account. I noticed that my user directory was still in the name of the local account so I tried the local account with the Microsoft account password and it worked! So DraJim is correct, use the local account (usually top of the list) and the password you used to login to windows (even though it's not for that account). Bizarre, but it works.

    יום רביעי 06 נובמבר 2019 16:38