none
מס' בעיות לאחר הגירה ל HYPER-V RRS feed

  • שאלה

  • שלום לכולם, מס' בעיות שחוזרות על עצמן תמיד אחרי המרה של דיסק VMDK ל VHD :

    1.

    יש לי בעיה שתמיד חוזרת על עצמה לאחר המרת שרתי win server 2003r2  מ- VMDK  ל-VHD

    זה קורה אך ורק עם שרתי 2003 (2008 תקין).

    לאחר ההמרה ויצירת מכונה וירטואלית ב HYPER-V   אני מתקין את ה hyper-v integration services

    ולאחר הפעלה מחודשת של המכונה יש כמה בעיות שחוזרות על עצמן תמיד:


    1.       ב Login לשרת תמיד תופיע ההודעה הבאה:

    2.       הבעיה הכי קשה והזויה-

    כשמבצעים Shoutdown לשרת (לא משנה אם דרך RDP  או מה Hyper-v Console )

    השרת בעצם לא מצליח לבצע כיבוי מוחלט ועולה מחדש, הוא עושה restart במקום כיבוי מוחלט.

    זאת בעיה שחוזרת בכ 10 שרתים.

     

    תהליך ההמרה שלי הוא המרה של דיסק VMDK   ל VHD  בעזרת הכלי של מיקרוסופט :

    microsoft virtual machine converter (דרך שורת הפקודה עם הכלי MVDC)

    3. הבעיה הבאה מתרחשת תמיד בלי שום קשר למערכת ההפעלה של הדיסק שמומר מ VMDK  ל-VHD:

    לאחר הפעלת ה VHD  בHYPER-V והגדרת כתובת לכרטיס הרשת, בסיום ההגדרה תמיד מקבלים את ההודעה הבאה:

    אני בטוח שהשגיאה הזאת גורמת לאיזה דופליקציה ברשת של הכרטיס. האם ההודעה הזאת מעידה על משהו לא תקין?

    בשרת ESX הסרתי את הכרטיס רשת של המכונה שהומרה.

    גם בדקתי אם במכונה שהומרה ל VHD נשארו שאריות מבחינת כרטיסי רשת קודמים או התקני חומרה קודמים והכל היה נקי.

    עבדתי לפי :

    * פתחו את ה- command prompt והקישו:
    set devmgr_show_nonpresent_devices=1
    הפקודה הזאת אומרת למנהל ההתקנים להציג גם את ההתקנים הישנים.

    פקודה שנייה:
    devmgmt.msc
    הפקודה הזאת פותחת את ה- device manager

    לאחר מכן נווטו בסרגל העליון ל-  View   ואז- Show Hidden Devices.
    תופיע לפניכם רשימת כל ההתקנים של המערכת.

    יש צורך לבחור התקן התקן ולמחוק את ההתקנים הישנים שמיוצגים ברקע אפור

    אשמח לקבל תשובות לשאלות כי אין כל אזכור ברשת לגבי השגיאות הללו.

    תודה

    יום רביעי 20 נובמבר 2013 10:10

תשובות

  • הי,

    1. וודא שהסרת את ה-vmware agent מהשרת ושה-userinit לא השתנה ב-Winlogon ב-Regedit.

    2. וודא שהמכונה הוירטואלית אינה חלק מ-Cluster ואין vmware agent מותקן עליה.

    3. הבעיה נובעת מהסיבה שלא הורדת את כתובות הרשת ב-VMDK ולכן אתה מקבל את ההודעה הנ"ל.

    ישנם המון מדריכים ברשת אני ממליץ שתסיר את כל הגדרות הרשת במכונה הוירטואלית ולאחר מכן תאתחל את השרת ורק אז תגדיר שוב את כתובת IP.

    תוכל להיעזר במאמר הבא, http://support.microsoft.com/kb/269155

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    • סומן כתשובה על-ידי Eran Sharvit יום ראשון 01 דצמבר 2013 16:54
    יום חמישי 21 נובמבר 2013 14:43
    מנחה דיון
  • הי,

    אני שמח בשני המקרים הראשונים הכל עובד.

    לגבי הבעיה השלישית בצע את ההגדרות הבאות:

    עדכון Windows Update של השרת

    הסרת Inegration Service

    הסרת כ.רשת

    התקנת Integration Services

    הגדרת כ.רשת

    אתחול השרת ולאחר מכן כיבוי.

    לאחר מכן תעדכן מה הסטטוס,

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    • סומן כתשובה על-ידי Eran Sharvit יום ראשון 01 דצמבר 2013 16:54
    יום שני 25 נובמבר 2013 17:57
    מנחה דיון

כל התגובות

  • בקרוב מומחי הקהילה ינסו לעזור לך.

    תודה.


    מיקרוסופט מציעה שירות זה ללא תשלום, למטרת סיוע למשתמשים והעשרת הידע הקשור בטכנולוגיות ובמוצרים של מיקרוסופט. תוכן זה מתפרסם כפי שהוא והוא אינו מעיד על כל אחריות מצד מיקרוסופט.

    יום חמישי 21 נובמבר 2013 09:49
  • שלום לך,

    לא צינתה מה תפקיד השרת?

    האם מעודכן בשרת SP?

    האם יש לך הודעות של שגייה בevent ID

    חוץ מזה אני גם הייתה ממליץ לך להסיר את הAV ולבדוק שוב

    אני הייתה ממליץ לך לבצעה sfc /SCANNOWאבל לפני הכול יש לבצעה גבוי למערכת

    לגבי השגייה שאתה מכבל בכרטס רשת

    Click Start, click Run, type cmd.exe, and then press ENTER.
    Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
    Type Start DEVMGMT.MSC, and then press ENTER.
    Click View, and then click Show Hidden Devices.
    Expand the Network Adapters tree.
    Right-click the dimmed network adapter, and then click Uninstall.

    בהצלחה ושבת שלום


    אם תגובתי פתרה את בעייתך - לחץ על "סמן כתשובה" ליד סימן ה V הירוק. Yaniv Totshvili http://www.yshvili.com http://itportal.co.il blog: http://blogs.microsoft.co.il/blogs/yanivlea

    יום חמישי 21 נובמבר 2013 11:41
  • הי,

    1. וודא שהסרת את ה-vmware agent מהשרת ושה-userinit לא השתנה ב-Winlogon ב-Regedit.

    2. וודא שהמכונה הוירטואלית אינה חלק מ-Cluster ואין vmware agent מותקן עליה.

    3. הבעיה נובעת מהסיבה שלא הורדת את כתובות הרשת ב-VMDK ולכן אתה מקבל את ההודעה הנ"ל.

    ישנם המון מדריכים ברשת אני ממליץ שתסיר את כל הגדרות הרשת במכונה הוירטואלית ולאחר מכן תאתחל את השרת ורק אז תגדיר שוב את כתובת IP.

    תוכל להיעזר במאמר הבא, http://support.microsoft.com/kb/269155

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    • סומן כתשובה על-ידי Eran Sharvit יום ראשון 01 דצמבר 2013 16:54
    יום חמישי 21 נובמבר 2013 14:43
    מנחה דיון
  • הי,

    1. וודא שהסרת את ה-vmware agent מהשרת ושה-userinit לא השתנה ב-Winlogon ב-Regedit.

    2. וודא שהמכונה הוירטואלית אינה חלק מ-Cluster ואין vmware agent מותקן עליה.

    3. הבעיה נובעת מהסיבה שלא הורדת את כתובות הרשת ב-VMDK ולכן אתה מקבל את ההודעה הנ"ל.

    ישנם המון מדריכים ברשת אני ממליץ שתסיר את כל הגדרות הרשת במכונה הוירטואלית ולאחר מכן תאתחל את השרת ורק אז תגדיר שוב את כתובת IP.

    תוכל להיעזר במאמר הבא, http://support.microsoft.com/kb/269155

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    תודה אלי, 

    עזרת לי ב 2 שאלות אך הבעיה הקריטית הייתה ונשארה:

    כשמבצעים Shoutdown לשרת (לא משנה אם דרך RDP  או מה Hyper-v Console )

    השרת בעצם לא מצליח לבצע כיבוי מוחלט ועולה מחדש, הוא עושה restart במקום כיבוי מוחלט.

    זאת בעיה שחוזרת בכ 10 שרתים.

    -  ווידאתי כבר את ההצעה הזאת שלך:

    1. וודא שהסרת את ה-vmware agent מהשרת ושה-userinit לא השתנה ב-Winlogon ב-Regedit.


    יום ראשון 24 נובמבר 2013 09:32
  • הי,

    אני שמח בשני המקרים הראשונים הכל עובד.

    לגבי הבעיה השלישית בצע את ההגדרות הבאות:

    עדכון Windows Update של השרת

    הסרת Inegration Service

    הסרת כ.רשת

    התקנת Integration Services

    הגדרת כ.רשת

    אתחול השרת ולאחר מכן כיבוי.

    לאחר מכן תעדכן מה הסטטוס,

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    • סומן כתשובה על-ידי Eran Sharvit יום ראשון 01 דצמבר 2013 16:54
    יום שני 25 נובמבר 2013 17:57
    מנחה דיון
  • הי,

    אני שמח בשני המקרים הראשונים הכל עובד.

    לגבי הבעיה השלישית בצע את ההגדרות הבאות:

    עדכון Windows Update של השרת

    הסרת Inegration Service

    הסרת כ.רשת

    התקנת Integration Services

    הגדרת כ.רשת

    אתחול השרת ולאחר מכן כיבוי.

    לאחר מכן תעדכן מה הסטטוס,

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    אהלן,

    לצערי כל הפעולות לא עוזרות והמכונה לא יכולה לבצע כיבוי. 

    מה שכן שמתי לב, כשמבצעים כיבוי למכונה אז לשנייה רואים שבדרך לכיבוי יש blue screen שהצלחתי לראות שכתוב משהו בנוגע ל :

    winlogon.exe 

    אין לי ספק שאי אפשר לכבות את השרתים בגלל ההודעת שגיאה שעולה כשעושים login לשרת :

    winlogon.exe encountered a problem and needed to close

    ניסיתי לטפל בהודעת השגיאה הזאת ע"י החלפת הקובץ שאחראי, ניסיתי לתקן את ההתקנה של כל המערכת, ניסיתי את הכליSFC .

    וכלום לא עוזר.   אשמח לעזרה

    יום שני 02 דצמבר 2013 08:40
  • הי,

    כמו שזה נראה רכיב ה-HAL אינו תקין ולכן אתה חווה תקלות.

    בצע את הבדיקות/הגדרות הבאות:

    בצע SFC על השרת

    בצע עדכון SP2 בשרת

    צור Dump באמצעות המאמר הבא http://support.microsoft.com/?id=972110

    עדכן לאחר מכן.

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    יום שני 02 דצמבר 2013 16:19
    מנחה דיון
  • הי,

    האם הסתדרת, אנא עדכן.

    אלי.


    Email:eshlomo9@hotmail.com;Twitter:https://twitter.com/EliShlomo1

    יום חמישי 05 דצמבר 2013 19:06
    מנחה דיון