none
Many mapped drives suddenly show disconnected RRS feed

  • שאלה

  • This just started this past monday on one of my larger clients. On random PCs for random users, some mapped drives show as disconnected. This is actually a big deal since one of the drives (the most common one to show disconnected) is the drive needed to be mapped for MS Dynamics. I've ran through many articles troubleshooting and this is not a client issue since it's so wide spread. Domain health is fine with a clean dcdiag report. I've recreated the GPO, adjusted to replace instead of update, delete with the setting to only apply once, and nothing has worked.

    What works temporarily is to use PSEXEC to delete the mapped drive (if you try in standard CMD it will fail) and add it again. This will work until rebooting, where the issue reverts straight back. 

    I have noticed that this tended to happen to systems this weekend where a shortcut to the network drive was on the desktop - in every case where the error occurred this was true, although not every system with a desktop shortcut to a network drive was affected.

    I also think this can't be a problem with the server sharing the files, since it is two servers with separate shares, and this has never happened before and suddenly occurred on a fairly widespread scale. 

    I've tried changing the reg value of HKLM\System\CurrentControlSet\Control\SessionManager\ProtectionMode from 1 to 0 but it changed nothing. There are two domain controllers and everything else is running smoothly. Replication is working, DNS has no errors. On both servers I ensured they had updates applied and I ran disk checks and all came back clean.


    Another oddity, I noticed when I change the GPO to delete for items that show disconnected, and then gpupdate /force, they don't change, but if a system is healthy and shows the drives normally, they pick up the GPO delete command and vanish properly. 

    This is a 2008 r2 forest with a 2008 r2 PDC and a 2012 R2 additional DC. 

    I'm pretty stumped on this and have never seen this happen on the many servers I have managed over the years. Initially I thought this was a windows 10 update issue since there were many windows 10 updates on 7/14/19, but one of the affected machines is a 2012r2 terminal server that had not been updated. Will appreciate any help.



    • נערך על-ידי Sean Braughton יום חמישי 18 יולי 2019 04:48
    יום חמישי 18 יולי 2019 04:08

כל התגובות

  • We had the exact same issue, although, the disconnected drives were still reachable, our solution was to uninstall the Itarian agent on affected PCs (we use Itarian).
    • הוצע כתשובה על-ידי Vincenzo De Lini יום שישי 19 יולי 2019 08:12
    יום חמישי 18 יולי 2019 13:29
  • The Itarian rmm or the security?
    • נערך על-ידי Davcomp יום חמישי 18 יולי 2019 15:11
    יום חמישי 18 יולי 2019 15:10
  • It's Itarian Endpoint protection, but I'm not sure this caused it since the terminal server didn't have it installed and it seems to be affected the worst. 
    יום חמישי 18 יולי 2019 15:46
  • Sean, 

    Actually I have found it is the remote communication that is causing it on my end.  Ugh

    יום חמישי 18 יולי 2019 17:41
  • Hi,

    Here is my understanding for your situation, please let know if i had any misunderstanding.

    You set map drive gpo for computers or users ,and now for some users/computers the map drive are disconnected.

    I would like to know that do you set up any dfsn links for your shared folder,?

    And can you access the shared folder  by the \\servername\shared folder from the computer affected?

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    יום שישי 19 יולי 2019 06:55
  • We as well have the same issues of disconnecting drivemappings, but it seems that it only applies to the homefolder of some users.
     
    In the the user policy in Group Policy Managemnt we set the map drive on update and reconnect.  \\server\share$\%username% and label it as %username%
     
    Unfortunately the Home Folders are still randomly getting disconnected.
     
     What have tried to fix the issue as follows: on each homefolder we have replaced all child object permissions entries with inheritable permission entries from this object. (Pushed the rights again on the folder)
     

    Also we have pushed a regkey in the computerpolicy with LinkedEnabledConnections with the value of 0.

    Unfortunatly we don't use itarian.

     
     

    But the problem still occurs. Does anyone have a solution?

    Best regards,

    Davy



    יום שישי 19 יולי 2019 11:09
  • We've seen the same behaviour (also using Itarian for RMM).

    As a temporary workaround we have disabled the "RMMService" service. You need to reboot for this "fix" to work

    יום שישי 19 יולי 2019 12:58