none
שדרוג SSIS packages מ-2008 ל-2014 RRS feed

  • שאלה

  • היי,

    אני משדרגת את סביבת הBI (SSRS/SSIS) בחברה ל2014.

    זה די מרגש, אבל אני משתגעת מהשדרוג. שום דבר לא הולך חלק.

    אנחנו משתמשים ב-Package Configuration כך שהמעבר של package בין DEV ל-PROD הוא חלק ונוח, אבל עצם השימוש ב-Package Configuration הוא זה שגורם לי למרבית הבעיות.

    בכל פעם שאני פותחת את ה-Designer, אני מקבלת את ההודעה Synchronize Connection Strings, שמעידה על אי תיאום בין ה-Package Configuration לבין ה-Connection Data Source.

    חוץ מזה, הPackage עובדת בצורה תקינה.

    אני יודעת שהSSIS Package Upgrade Wizard לא מעדכן connection strings בעצמו, ועידכנתי את כל המקומות הרלוונטים (או לפחות חשבתי כך)..
    קראתי את המסמך החביב שMS פירסמו, אבל לא היה שם משהו מיוחד

     Tips for a Smooth SSIS Upgrade to SQL Server 2012 https://msdn.microsoft.com/en-us/library/hh667275.aspx

    אני לא מצליחה להיפטר מזה.

    מישהו נתקל בזה בעת השידרוג ?

    יום שלישי 02 יוני 2015 08:06

כל התגובות

  • ערב טוב רוני

    השאלה שלך כללית מאוד :-)

    ברור שאנשים נתקלו בבעיות, בעיקר במערבר ל 2012 (הכוונה לקפיצה מ 2008R2 ולפני ל 2012 או יותר). מכיוון שב 2012 יש כמה שינויים מהותיים (החל מסביבת ההרצה שהיא כבר דוט-נט 4+ ואינה תומכת אחורה בגרסאות דוט-נט 2-3.5 בצורה מלאה).

    אם יש לך בעיה ספציפית ותוכלי לספק לנו כלים לשחזר אותה, אז אולי אנשים יוכלו לעזור יותר, מרק להגיד שהם נתקלו בבעיות :-)

    * אנא צרפי הודעות שגיאה מדוייקות שאת מקבלת. זה יעזור לחפש פתרונות ולהזכר במקרים בהם נתקלנו אולי באופן אישי.


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]

    • הוצע כתשובה על-ידי pituachMVP, Editor יום שלישי 09 יוני 2015 18:39
    יום שלישי 02 יוני 2015 14:52
    מנחה דיון