none
Windows 10 with SSD boots too fast for GP RRS feed

  • שאלה

  • Is there a way to force a Windows 10 computer to slow down the boot process so that Group Policy gets a chance to run?

    I setup a program to install on all networked computers and it installed fine on all of the Windows 7 computers but doesn't install on the Windows 10 computers. 

    I've modified these settings in the local group policy:

    Computer Configuration - Administrative Templates - System - Logon

         Always wait for the network at computer startup and logon - Enabled

    Computer Configuration - Administrative Templates - System - Group Policy

         Configure Logon Script Delay - Disabled

    Those settings slowed it down enough to allow the drives to map properly and show the users home directory, but it's not slow enough to install a program.

    The Event Log has two entries:

         Warning - Application Management Group Policy - 108 - None

              Failed to apply changes to software installation settings. The installation of software deployed through Group Policy for this user has been delayed until the next logon because the changes must be applied before the user logon. The error was : %%1274

         Warning - Group Policy (Microsoft-Windows-GroupPolicy) - 1112 - None

         The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.

    However the application has yet to install and we rebooted the computer six times. How do we get the computer to apply GP?

    Thanks,

    Jessica


    • נערך על-ידי Jessicasdd יום חמישי 18 יולי 2019 12:47 Missing detail
    יום חמישי 18 יולי 2019 12:46

כל התגובות

  • Hi Jessica,

    there is a further Setting called "Wait for Group Policy Processing".

    Unfortunately i only have a german-languaged System right now.

    Go to:

    1. Computerconfiguration\Policies\System\Group Policy\

    The Policies name should be "Wait for Policy-Processing at System Start-Up".

    Here you can define a value for the delay.

    יום חמישי 18 יולי 2019 13:21
  • For references to GP Adm template settings, I recommend gpsearch.azurewebsites.net :-)

    There's another trick to make GP work on fast computers: Make gpsvc dependend on iphlpsvc (tcp/ip helper). German, but Google can assist in translating: https://www.gruppenrichtlinien.de/de/artikel/ssd-zu-schnell-synchroner-startvorgang-nicht-moeglich/


    Greetings/Grüße, Martin - https://mvp.microsoft.com/en-us/PublicProfile/5000017 Mal ein gutes Buch über GPOs lesen? - http://www.amazon.de/Windows-Server-2012--8-Gruppenrichtlinien/dp/3866456956 Good or bad GPOs? My blog - http://evilgpo.blogspot.com And if IT bothers me? Coke bottle design refreshment - http://sdrv.ms/14t35cq

    יום חמישי 18 יולי 2019 14:21
  • Is this on the local computer or on the server? I'm not finding it in the local computer.

    Thanks,

    Jessica

    יום חמישי 18 יולי 2019 15:05
  • its on the server
    יום חמישי 18 יולי 2019 15:10
  • Hello,

    Thank you for posting in our TechNet forum.

    >>Is this on the local computer or on the server? I'm not finding it in the local computer.
    The policy Pat_360 mentioned is "Specify startup policy processing wait time", for local group policy, we can find it under Local Computer Policy -- Administrative Templates -- System -- Group Policy.






    Best Regards,
    Daisy Zhou

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום שישי 19 יולי 2019 06:59
    מנחה דיון
  • Hi,
    If this question has any update or is this issue solved? Also, for the question, is there any other assistance we could provide?


    Best Regards,
    Daisy Zhou

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום שני 22 יולי 2019 07:06
    מנחה דיון
  • No this is not solved.

    I tried the installation on another Windows 10 computer to see if it was going to be an issue with that one also and it installed on the first restart. The difference was it was still on version 1607. I think the one I am having trouble with is on the latest update, or at least 1803.

    I am going to try to set these other options on the one in question and let you know:

    Local Computer Policy - Computer Configuration - Administrative Templates - System - Scripts

         Run logon scripts synchronously - Enabled

    Local Computer Policy - Computer Configuration - Administrative Templates - System - Scripts

         Specify maximum wait time for Group Policy scripts - Enabled - 0 seconds (directs the system to wait until the scripts have finished, no matter how long they take.)

    Local Computer Policy - Computer Configuration - Administrative Templates - System - Group Policy

         Specify startup policy processing wait time - Enabled - 60 seconds (the default time is 30 seconds and it doesn't seem to be long enough so I'm gonna start at 60 and go from there.)

    I will repost as soon as I get a chance to test it.

    Thanks,

    Jessica

    יום שני 22 יולי 2019 14:05
  • Ok I was finally able to get back to that computer and test the settings and no they didn't make a difference. It runs the logon script because it maps his directories properly but will not install the program. I'm going to do some more searching to see if maybe someone else is having a similar issue. Thanks, Jessica
    יום שלישי 23 יולי 2019 12:49
  • Hi,
     
    Please try to change policy setting "Specify startup policy processing wait time" to 90 seconds or higher, then run command "Gpupdate /force /boot" to see if it helps.


    Best Regards,
    Daisy Zhou


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום רביעי 24 יולי 2019 06:53
    מנחה דיון
  • Hi Daisy,

    That also did not work.

    I am actually going to give up for now and just manually install it on that computer. We are doing a full upgrade next year to Windows 10 computers and hopefully by then this won't be an issue. But for now I can't justify spending anymore time on it for one computer.

    Thanks,

    Jessica

    יום שישי 26 יולי 2019 14:23
  • Hi,
    OK. Thank you for your update.

    As always, if there is any question in future, we warmly welcome you to post in this forum again. We are happy to assist you!

    Have a nice day!


     
    Best Regards,
    Daisy Zhou

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    יום שני 29 יולי 2019 10:45
    מנחה דיון