none
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

    Diskusi Umum

  • My Windows 7 64 bit desktop is several years old. The other day, without warning, both my CD drives stopped working. I discovered the error above (in title). First, I simply attempted to have Windows update the drivers (both from the PC and from the Web). The response I received was that the drivers were up to date. Next, I did a system restore to a point when I knew the CD drives were working - no help. I next attempted to repair Windows from the install CD using a portable CD drive. When I plugged it into the USB port(s) I got the same error message. I also did an uninstall and let the system search and reinstall - no help. I've been searching for the correct drivers but, so far have been unsuccessful. The drive description is "Optiarc DVD RW AD-7280S ATA Device". Type = DVD/CD-ROM drives; Manufacturer = Standard CD-ROM drives; Location 1 (Channel 1, Target 1, Lun0). Driver provider - Microsoft; Driver Date - 6/21/2006; Driver version - 6.1.7601.17514; Digital Signer - Microsoft Windows. File version - 6.1.7600.16385 (win7_rtm.090713-1255) The driver location is (of course) C:\Windows\system32\DRIVERS\cdrom.sys 

    Any suggestions will be most welcome. Thanks in advance

    11 Mei 2018 17:00

Semua Balasan

  • Error 39 is usually more of a generic error.. In that it is typically more likely a registry corruption error.. You may have a hard disk that is failing.. that's likely the cause of the issue.. 

    Have you run a chkdsk C: /F to see if it locates errors? 

    Alternately have you checked to make sure you don't have any infection? 

    I would suggest running Malwarebytes to see if you have any infections on the system as well. 


    Rob

    11 Mei 2018 17:10
  • Hi Rob,

    My primary (C) drive is an SSD. Even though it is several years old I don't think it is failing. Just to play it safe, I did run chkdsk and (sigh of relief) if found no problems. I also loaded the trial version of Malwarebytes and ran it. It found a whole bunch of stuff (147 items) that I told it to quarantine. One of the items was a program I tried to use to fix my CD issue. It never worked and I thought I had completely uninstalled it. Anyway, when I tried to restart my PC it hung up. I ended up forcing a shutdown and restarted in safe mode. I uninstalled Malwarebytes and restarted my PC again. This time everything came up as normal and, low and behold, my CD drives are now working fine. I quickly created a system restore point and backed up my registry. I still have no idea exactly what happened but, thanks to your suggestions, my problem seems to be solved.

    Thanks,

    Ken 

    11 Mei 2018 21:44