none
Connected Users not showing up in Remote Desktop Services

    Pertanyaan

  • We just setup a new Windows Server 2016 as a Terminal Server. Our users are able to use Remote Desktop with no issues. However, I am unable to see the connected users in Server Manager. I was able to always view connected users in Server 2008. Should I be looking under Server Manager\Remote Desktop Services\Collections and then look at Connections? Or am I looking in the wrong place? Thank you.
    Kamis, 12 Juli 2018 15.40

Semua Balasan

  • Hi,

    From your description it sounds like you are looking in the correct place.  For specific collection you would look at Server Manager -- RDS -- Collections -- <collectionName> -- Connections

    Please note the display isn't updated automatically so you need to click Tasks -- Refresh under the Connections window.

    What is your configuration?  Is this a single server with all RDS Role Services installed on it, or do you have multiple servers with different RDS Role Services installed on each?  Please list out your servers and the Role Services on each.

    Thanks.

    -TP

    Kamis, 12 Juli 2018 16.13
    Moderator
  • Hi TP,

    This is a single server that has multiple users logging into it. Here is what I show for RDS Services

    Kamis, 12 Juli 2018 16.27
  • Hi,

    Did you create a session collection?  If you chose the Quick Start option when creating the deployment then a collection named QuickSessionCollection should have already been created.  Otherwise if you chose Standard option then you need to create a session collection.

    -TP

    Kamis, 12 Juli 2018 16.38
    Moderator
  • Hi TP,

    How can I check if QuickSessionCollection is already created? And if it is not, how do I create a session collection? Thanks for your help, I appreciate it.

    Kamis, 12 Juli 2018 16.43
  • Hi TP,

    How can I check if QuickSessionCollection is already created? And if it is not, how do I create a session collection? Thanks for your help, I appreciate it.

    You would see it in Server Manager under Collections.  If you just see Collections with nothing listed then you don't have any collections created yet.  Click Tasks -- Create session collection and follow the wizard.  You only have 1 RDSH (itself) so select it when the wizard prompts you.

    When you first create the collection it will be in Remote Desktop mode, which means it is publishing Full Desktops.  If you publish a RemoteApp the collection will automatically switch to RemoteApp Programs mode.  To switch back to Remote Desktop mode you simply unpublish all RemoteApps from the collection.

    My guess is you are currently using your server to publish full desktops, so follow the wizard, don't enable UPD (since you aren't using them right now) and that will be it.  After creating the collection please take a look in the collection properties and see if there is anything you would like to modify.

    In addition please make sure you have things configured properly in RDS Deployment Properties, especially make sure you have the licensing mode set and your RD Licensing server FQDN is in the list on the RD Licensing tab.

    Thanks.

    -TP

    Kamis, 12 Juli 2018 16.54
    Moderator
  • Went through the Collection Wizard and got an error at the end:

    However, now I can see my users

    Kamis, 12 Juli 2018 16.59
  • Hi,

    It is likely that you have one or more group policy settings applied to your server that conflict with what the RDS deployment or collection configure and RDMS failed when it tried to apply these.  This may or may not cause issues, depending on the specific settings.

    What I would suggest is to check for any group policy settings under Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services and consider making them Not Configured.  After doing this and running gpdate /force on your server, try changing some setting in the collection properties, clicking Apply, and see if any error is generated.  After the Apply finishes toggle the setting back and click Apply again.  Repeat the same with RDS deployment properties -- change some small setting and then toggle it back.

    -TP

    Kamis, 12 Juli 2018 17.10
    Moderator
  • ITs all working great now. Thanks for your help!
    Kamis, 12 Juli 2018 17.13
  • ITs all working great now. Thanks for your help!

    You are welcome.  Please click Mark as answer on the posts that I proposed above.

    Thanks.

    -TP

    Kamis, 12 Juli 2018 17.17
    Moderator