Outlook 2016 prevent previous search popup


  • Is it possible to prevent search from displaying previous search results when I click on the search field? Every time I start to search, I have to click away before I can start typing my search text. I know there's an option for displaying results as I type, but that setting is different than what I'm talking about. This only started to happen in 2016 - it didn't happen in 2010 or 2013.


    Senin, 06 Maret 2017 13.20

Semua Balasan

  • Hi,

    Do you mean Outlook 2016 will display previous search results when clicking into the search box? In theory, Outlook won't display any search result when you just click into the search box.

    What type of email account are you using? If you are using an Exchange account, do you have cached Exchange mode enabled?

    If I've misunderstood something, please feel free to let me know.


    Steve Fan

    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact

    Selasa, 07 Maret 2017 06.16
  • Thanks, Steve. Outlook 2016 displays previous searches, not the results. I'm on Exchange.

    I'm still hoping for a way to stop it, but it isn't a huge deal. First world problem, know what I mean? I think it's bothering me more than some others because I've set my search so that when I click the search field, it automatically displays the fields I search the most like this:

    It also automatically shows previous search queries, but it's a pop-down so that it covers everything below the top field.

    Selasa, 07 Maret 2017 12.58
  • I see, these are the search criteria added via the More button under the Search tab:

    These criterias are remembered next time when searching once enabled. We can easily close them via clicking the 'X' button next to the criteria.

    Hope this helps.


    Steve Fan

    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact

    Kamis, 09 Maret 2017 09.54
  • Sorry, I was unclear when I posted that image. I set up the search criteria on purpose. I finally figured out how to save the pop-down image that shows the problem.

    Those are previous search results. As soon as I click the Search field, this pops down and covers the To, From, Subject, and Body search fields I set up, so I have to click again to make that pop-down go away before I can type in those fields.

    Kamis, 09 Maret 2017 13.27
  • Thank you for the update.

    According to my knowledge, there is no option available to disable the recent searches feature in Outlook. We can only clear the recent searches MRU via deleting the following registry key:


    We may try to create a .reg file as per the following Microsoft KB article to delete the registry entry as a workaround. However, you will have to run the .reg file frequently as the search MRU creates once you search.,-modify,-or-delete-registry-subkeys-and-values-by-using-a-.reg-file


    Steve Fan

    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact

    Jumat, 10 Maret 2017 02.21
  • TR-CPC - Did you find a solution to this?  This is extremely frustrating to me as well.  I search my email EXACTLY as you do.  I have added a few criteria like subject, date, from, to, etc and this pop up infuriates me in a way I cannot describe.  The fact that it is delayed by a second or two is the most frustrating part.  I click in the search box, the search options appear, then i click in the from box to search from a certain person, and boom, in the time it took my computer to process the click, the pop up appears, and my click is on some pointless recent search and it sends my computer into an unnecessary search.  Then I have to close the search and start all over.  And then I scream profanities at my computer.

    The only workaround i've found is to train myself to click in the extreme far right region of the search criteria, to avoid clicking the popup if it appears.

    Kamis, 15 Juni 2017 19.59
  • kleeb,

    It's always about the workaround, isn't it? :-)

    I didn't find a solution, so I've basically been doing what you're doing and learned to live with it. However, my situation doesn't sound as painful as yours because my search box pops up immediately, so it doesn't add much time for me to close the search box.

    FWIW, I start to see outlook drag when I have over 5000 or so messages in my inbox. I've gotten into the habit of moving miscellaneous emails (ie, emails I don't already have a specific folder for) from the previous month into a folder named for the year. That seems to keep my inbox pretty snappy. I also set my search default to Current Folder instead of Current Mailbox. That sometimes means I have to hunt for the correct folder, but I generally know where to look so it's worth it.

    Kamis, 15 Juni 2017 20.19
  • I have found that if I click directly on the magnifying glass (not just a random spot on the right) that the recent search terms still pop-up but they pop-up BELOW the search fields that I have setup, like yours. I still don't like it but it doesn't slow down my searches with a 2nd click to get to my search fields. 
    • Disarankan sebagai Jawaban oleh Old Haird Kamis, 14 Juni 2018 12.35
    Rabu, 09 Agustus 2017 14.01
  • m_acree, nice work. That definitely helps.

    Now if only I could search subfolders of shared folders again, life with Outlook 365 would really be great.

    Rabu, 09 Agustus 2017 14.05
  • Hi Steve,

    This is yet another example of Microsoft adding "features" which are not only useless but also break previously available function.  Do you test anything that you add?

    Get rid of this popup!  Who on earth keeps searching the same thing over and over?

    Senin, 09 April 2018 17.33
  • I agree.

    The popup needs to go away.

    Previously, if I wanted to view previous search criteria, I'd click in the "Search Current Mailbox" box and then down arrow to bring up the popup. This is most useful on the rare occasions you have very specific criteria you want to edit. For example:

    from:SoAndSo contents:workorder received:>4/22/2018 received:<4/28/2018 category:ToDo


    from:SoAndSo contents:workorder received:>4/22/2018 received:<4/28/2018 category:Done


    Senin, 30 April 2018 15.17
  • Furthermore to this point, if you do the equivalent of a slow double click in the search area the prior searches go away. 

    I agree with every negative comment made on this thread and it is really a shame that Microsoft software creators do not really seem to be serious users of their own software.  If they were they would make these rather simple fixes immediately.  I would love to have a monopoly like theirs so I could ignore what customers care about. What a privilege!

    • Disarankan sebagai Jawaban oleh sami ho Jumat, 29 Juni 2018 15.12
    • Saran Jawaban dibatalkan oleh sami ho Jumat, 29 Juni 2018 15.12
    Kamis, 14 Juni 2018 12.40
  • this question issued since mid of 2017 and till now Microsoft does not have a solution!!!! very unacceptable behavior by Outlook 365 inventor.



    Jumat, 29 Juni 2018 15.17
  • Hi,

    did anyone reply to your issue after all? it seems they till now does not understand how frustrating this matter is?

    Microsoft we need a solution!!!!!!


    Jumat, 29 Juni 2018 15.19
  • did anyone find a solution! please


    Sabtu, 28 Juli 2018 19.10
  • please, this is extremely frustrating, we need a solution to the same ASAP. ! 
    Selasa, 31 Juli 2018 10.14
  • Noting that this thread has been fairly inactive (apart from Hossam!) for a while, has anyone managed to come up with a solution to disable the pop-up drop down list of previous search strings? The workarounds described in this thread, while useful in some circumstances, do not help me with my issue.

    Does anyone have any suggestions on how best to get Microsoft's attention - this pop-up is very aggressive / persistent and annoying (and of extremely limited value add!)!

    Do MS monitor these forums? if so, a response would be greatly appreciated.

    Thanks in advance!

    (PS - maintain the rage Hossam - i'm right behind you!)

    Rabu, 08 Agustus 2018 04.25
  • PS - further to the above, if Microsoft are resistant to removing the drop down pop-up completely, perhaps you could just fix it so that it only appears when the cursor hovers over (or clicks in) the search field?

    Rabu, 08 Agustus 2018 05.28
  • Indeed, a very frustrating behaviour.

    I find this wordkaround (slow doubleclick) the best workaround. But again the popup box needs to be able to be disabled.

    Jumat, 07 September 2018 05.15
  • I hate this too. My workaround is to use the keyboard shortcut ctrl+E and then hit tab twice. This puts the cursor in the first box below the main search box (usually for me the From: field) and the popup goes away. 

    Works for me but everytime I forget and use my mouse, I curse all over again. 

    Rabu, 26 September 2018 09.39