none
IE 11 does not open in desktop mode on Server 2012 R2 RRS feed

  • Question

  • We've built our first 2012 R2 servers. IE11 will open in metro if it's not set for desktop mode. It will fail in desktop mode. It will however open if you go to an admin command prompt, go to c:\program files\internet explorer and run iexplore.exe. When trying desktop mode in the event app logs, event ID 102, task category (101) appears with the message "the program iexplore.exe version 11.0.9600.16518 stopped interacting with Windows and was closed". I have tried everything I've found using Google: reset, use software rendering, etc and nothing helped. Any suggestions?

    Ben JohnsonWY

    Thursday, March 13, 2014 6:54 PM

Answers

  • Running the regsvr32 command didn't help.

    Emptying the temp folder didn't help.

    How do you select "always" in IE on the desktop? Just Curious.

    What DID fix this is that Enable Enhanced Protected Mode had been turned on. Turning it off fixed all these IE problems. THANKS!


    Ben JohnsonWY

    Friday, March 14, 2014 1:04 PM

All replies

  • Hi Ben,

    Your issue can occur if the IE setting is incorrect, or the temp folder need clear up. If you are not choose Always in Internet Explorer on the desktop, IE may use Metro mode. Also disable enhanced protected mode for a test.

    This issue may cause due to some registry problems occurred.

    To resolve this issue, follow the below steps:

    a. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
    b. Type regsvr32 actxprxy.dll in the Open box, and then click OK.
    c. If the command was successfully executed, you will receive the message ‘DllRegisterServer in actxprxy.dll succeeded’ window.
    d. Restart the Internet Explorer

    If the above given steps also did not help then try to disable the antivirus and firewall and try installing Internet Explorer 11 manually.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Friday, March 14, 2014 10:22 AM
    Moderator
  • Running the regsvr32 command didn't help.

    Emptying the temp folder didn't help.

    How do you select "always" in IE on the desktop? Just Curious.

    What DID fix this is that Enable Enhanced Protected Mode had been turned on. Turning it off fixed all these IE problems. THANKS!


    Ben JohnsonWY

    Friday, March 14, 2014 1:04 PM