none
IE 11 ignoring pop-up allow exceptions from group policy RRS feed

  • Question

  • I see a ton of postings on the web about IE9 ignoring group policy pop-up blocker exceptions, but I'm having the same issue with IE11.

    The policy settings I have attempted to use is called "Pop-up allow list", which is enabled and lists my site in the form of "http:// mysite.com" (excluding the space after //, which I've added only so this message would post). 

    Afterward, I can see on a Windows 7 test computer that a registry entry has been made in "HKCU\Software\Policies\Microsoft\Internet Explorer\New Windows\Allow" for the site I wish to exclude.  I take this as proof my group policy setting has been applied.  But, it has no effect.  The site still doesn't work, and the URL is still not listed in the pop-up exceptions list in IE. 

    I also tried using the same Group Policy setting under the computer policies, which likewise resulted in a new registry entry in "HKLM\Software\Policies\Microsoft\Internet Explorer\New Windows\Allow".  This also fails to work, and does not result in the site in questions appearing in the exception list.

    In looking through the registry, I see that any manually added pop-up exceptions are stored in "HKCU\Software\Microsoft\Internet Explorer\New Windows\Allow".  If I manually add my site here, or via the IE gui, then the site works as expected.

    What am I missing here? Am I doing something wrong, or is this a bug?

    Friday, August 29, 2014 6:47 PM

All replies

  • Hi

    If you deploy a reg key to add the values through GPO? is this something you would look at? I have also had trouble with IE11 and GPO, even downloading the new admin templates and installing and running the IE config tool on a DC does not always work.


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, August 30, 2014 5:03 PM
  • You're not missing anything.  I can't get this to work on IE9 or IE11.

    However, what I found is this:

    Going through the GPO - the policies go to:

    HKCU/SOFTWARE/POLICIES/MICROSOFT/INTERNET EXPLORER/NEW WINDOWS/ALLOW

    Internet explorer must not look at that.

    However, when you add the key manually in IE9 or IE11 it populates in the...:

    HKCU/SOFTWARE/MICROSOFT/INTERNET EXPLORER/NEW WINDOWS/ALLOW 

    which works fine.

    So Microsoft should add a fix for this or you'll need to add the reg values through GPO.  However, I found that if you use the site to zone assignment and add value 2 for the sites that you want to allow popups then things are o.k.  Just add them to the trusted sites until MS gets this fixed.  Since this seems to have been an issue for many years I'm not sure when you should expect this.

    Thursday, February 26, 2015 2:42 PM
  • I see the same behavior.  Previously, this failed to work in IE9, then Microsoft fixed it:

    https://support.microsoft.com/en-us/kb/2635543?wa=wsignin1.0

    Now IE11 has the same issue.  You could open a case, and see what their plans on for fixing it.  Or just use Group Policy Preferences to push out the reg hits.

    Monday, March 16, 2015 8:28 PM
  • If you use the Group Policy Preferences to set the Pop-Up Allow List everything works as aspected.

    You'll find the preferences in User-Configuration/Preferences/Control Panel Preferences/Internet Settings, there you have to create a new entry by right clicking in the white pane and choose IE 10 (goes for IE 11 too).

    Thursday, June 25, 2015 11:47 AM
  • 1. Don't use http: etc, just put mysite.com.  This is mentioned in the GPO Help.  This could be why they are not working.

    2. Policies are stored in different places from user settings.

    3. You don't see the policy settings in Internet Explorer.

    Cheers.

    Thursday, April 11, 2019 9:38 PM
  • Ok I found out what the issue is here... the GPO is creating REG_SZ values but the browser expects REG_BINARY.  That's why this doesn't work when using the GPO.  So it looks like a bug...
    Friday, June 21, 2019 2:28 PM