locked
Failed to update Help for the module(s) 'Microsoft.PowerShell.Operation.Validation' with UI culture(s) {en-US} RRS feed

  • Question

  • I am trying to update the help files for PowerShell, and I am running into the following error:

    C:\WINDOWS\system32> Update-Help
    Update-Help : Failed to update Help for the module(s) 'Microsoft.PowerShell.Operation.Validation' with UI culture(s) {en-US} : The value of the HelpInfoUri key in the module manifest must resolve to a container 
    or root URL on a website where the help files are stored. The HelpInfoUri 'https://www.msn.com/?ocid=NEFLS000' does not resolve to a container.
    At line:1 char:1
    + Update-Help
    + ~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Update-Help], Exception
        + FullyQualifiedErrorId : InvalidHelpInfoUri,Microsoft.PowerShell.Commands.UpdateHelpComman

    Possibly useful information regarding my PowerShell version:

    PS C:\WINDOWS\system32> $PSVersionTable
    
    Name                           Value                                                                                                                                                                                
    ----                           -----                                                                                                                                                                                
    PSVersion                      5.1.14393.0                                                                                                                                                                          
    PSEdition                      Desktop                                                                                                                                                                              
    PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}                                                                                                                                                              
    BuildVersion                   10.0.14393.0                                                                                                                                                                         
    CLRVersion                     4.0.30319.42000                                                                                                                                                                      
    WSManStackVersion              3.0                                                                                                                                                                                  
    PSRemotingProtocolVersion      2.3                                                                                                                                                                                  
    SerializationVersion           1.1.0.1    

    How can I fix this?

    Wednesday, August 3, 2016 5:40 PM

Answers

All replies

  • Hi Charlie,

    you have a module with an Update-link that is invalid. Run this to find out which:

    Get-Module -ListAvailable | ? { $_.HelpInfoUri -like 'https://www.msn.com/?ocid=NEFLS000' }

    To fix this you need to either remove this module or fix the path. Try checking manually whether there is a new version available.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, August 3, 2016 5:48 PM
  • Hi FWN,

    Thank you for your help. I am having some trouble finding a download link for this module online. Furthermore, trying to uninstall the module runs into issues:

    PS C:\WINDOWS\system32> Get-Module -ListAvailable | ? { $_.HelpInfoUri -like 'https://www.msn.com/?ocid=NEFLS000' } -Verbose
    
    PS C:\WINDOWS\system32> Get-Module -ListAvailable | ? { $_.Name -like 'Microsoft.PowerShell.Operation.Validation' } -Verbose
    
    
        Directory: C:\Program Files\WindowsPowerShell\Modules
    
    
    ModuleType Version    Name                                ExportedCommands                                                                         
    ---------- -------    ----                                ----------------                                                                         
    Script     1.0.1      Microsoft.PowerShell.Operation.V... {Get-OperationValidation, Invoke-OperationValidation}                                    
    
    
    
    PS C:\WINDOWS\system32> Uninstall-Module -InputObject (Get-Module -ListAvailable | ? { $_.Name -like 'Microsoft.PowerShell.Operation.Validation' })
    Uninstall-Module : Invalid value is specified for InputObject parameter.
    At line:1 char:1
    + Uninstall-Module -InputObject (Get-Module -ListAvailable | ? { $_.Nam ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (Microsoft.Power...tion.Validation:PSModuleInfo) [Uninstall-Module], ArgumentException
        + FullyQualifiedErrorId : InvalidInputObjectValue,Uninstall-Module
     
    
    PS C:\WINDOWS\system32> Uninstall-Module -Name 'Microsoft.PowerShell.Operation.Validation'
    PackageManagement\Uninstall-Package : No match was found for the specified search criteria and module names 
    'Microsoft.PowerShell.Operation.Validation'.
    At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:2046 char:21
    + ...        $null = PackageManagement\Uninstall-Package @PSBoundParameters
    +                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Microsoft.Power...ninstallPackage:UninstallPackage) [Uninstall-Package], Exception
        + FullyQualifiedErrorId : NoMatchFound,Microsoft.PowerShell.PackageManagement.Cmdlets.UninstallPackage
     
    
    PS C:\WINDOWS\system32> Remove-Module -FullyQualifiedName 'Microsoft.PowerShell.Operation.Validation'
    Remove-Module : No modules were removed. Verify that the specification of modules to remove is correct and those modules exist in the runspace.
    At line:1 char:1
    + Remove-Module -FullyQualifiedName 'Microsoft.PowerShell.Operation.Val ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ResourceUnavailable: (:) [Remove-Module], InvalidOperationException
        + FullyQualifiedErrorId : Modules_NoModulesRemoved,Microsoft.PowerShell.Commands.RemoveModuleCommand

    Wednesday, August 3, 2016 11:30 PM
  • Just ignore the error.  Many module either have no online updateable help or the url has been removed.

    \_(ツ)_/

    Wednesday, August 3, 2016 11:41 PM
    Moderator
  • I would love to ignore the error... Unfortunately, the updating process stops when encountering that error. Other help files do not get updated because because of it.
    Thursday, August 4, 2016 4:53 AM
  • Hi,

    >> Other help files do not get updated because of it.

    Get-Module -ListAvailable | Where HelpInfoUri | Update-Help

    Update-Help -Module your module names

    We could temporary use the above method as a workaround.

    Best regards,


    Andy_Pan

    Please mark the reply as an answer if you find it is helpful. If you have feedback for TechNet Support, contacttnmff@microsoft.com.




    Thursday, August 4, 2016 6:24 AM
    Moderator
  • Update-Help  -Force -Ea 0


    \_(ツ)_/

    Thursday, August 4, 2016 8:56 AM
    Moderator
  • Problem seems to be that there is no module with HelpInfoUri like 'https://www.msn.com/?ocid=NEFLS000; module 'Microsoft.PowerShell.Operation.Validation'  has the following value for HelpInfoUri: ' http://go.microsoft.com/fwlink/?LinkId' .  What should its value be?  .or. What can be done to fix it?
    Thursday, August 4, 2016 10:30 PM
  • Was Charlie Brown question ever answered?

    Get-Module -ListAvailable | Where HelpInfoUri | Update-Help
    Update-Help : Failed to update Help for the module(s) 'Microsoft.PowerShell.Operation.Validation'
    with UI culture(s) {en-US} : The value of the HelpInfoUri key in the module manifest must resolve
    to a container or root URL on a website where the help files are stored. The HelpInfoUri
    'https://www.msn.com/?ocid=NEFLS000' does not resolve to a container.
    At line:1 char:49
    + Get-Module -ListAvailable | Where HelpInfoUri | Update-Help
    +                                                 ~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Update-Help], Exception
        + FullyQualifiedErrorId : InvalidHelpInfoUri,Microsoft.PowerShell.Commands.UpdateHelpCommand
    Or is there a free download of powershell 3 for Windows 10 community?

    Friday, September 9, 2016 6:30 PM
  • Yes and the answer is clearly marked.

    Your error is due to a module that no longer has access to its update site either due to web filtering or an old and deprecated module.

    The error clearly indicates that the URI is "Invalid" -  FullyQualifiedErrorId : InvalidHelpInfoUri,Microsoft.PowerShell.Commands.UpdateHelpCommand


    \_(ツ)_/

    Friday, September 9, 2016 6:50 PM
    Moderator
  • Update-Help  -Force -Ea 0


    \_(ツ)_/

    For those looking to understand what -Ea does, it suppresses the errors. The article/source below shows a way to use this, save the errors, and display at the end for this exact scenario.

    Source: https://www.microsoftpressstore.com/articles/article.aspx?p=2449029&seqNum=6

    The UpdateHelpTrackErrors.ps1 example from link above:

    $error.Clear()
    Update-Help -Module * -Force -ea 0
    For ($i = 0 ; $i -lt $error.Count ; $i ++)
      { "`nerror $i" ; $error[$i].exception }

    • Proposed as answer by PeterHof3 Wednesday, October 25, 2017 8:21 PM
    Wednesday, February 22, 2017 9:53 PM
  • Update-Help  -Force -Ea 0 -Ev what
    $what.Exception


    \_(ツ)_/

    Wednesday, February 22, 2017 10:24 PM
    Moderator
  • Update-Help  -Force -Ea 0 -Ev what
    $what.Exception



    I love that people just want to know how to make the thing work and not why it broke. 😉 Thank you for the help!

    Incidentally, I found an error trying to update 'Provisioning' module. This was my error:

    `Failed to update Help for the module(s) 'Provisioning' with UI culture(s) {en-US} : Unable to retrieve the HelpInfoXML file for UI culture en-US. Make sure the HelpInfoUri property in the module manifest is valid or check yournetwork connection and then try the command again.
    Hopefully others who have a similar error will be able to use your simple solution and snag-identification method.

    • Proposed as answer by Apsistec Sunday, December 30, 2018 12:31 PM
    Thursday, March 23, 2017 4:56 AM
  • In the current modules folder for that module by adding a folder named 'en-US' and try again.


    \_(ツ)_/

    Thursday, March 23, 2017 5:44 AM
    Moderator
  • https://blogs.technet.microsoft.com/heyscriptingguy/2012/09/24/where-is-powershell-updatable-help-for-windows-modules/

    I'm in my third day of learning Windows powershell and after receiving the same error and digging around (with much help from this thread) I came across ^this link^ (srz for no hyperlink, my account hasn't been verified) and "June" who apparently works closely with the Powershell team.

    My understanding now is there are many modules of which have no files associated with help...yet.

    Saturday, July 22, 2017 8:15 PM
  • This worked for me, thx

    Friday, February 2, 2018 1:49 PM
  • Had the same problem, and ran a short script to see what modules are giving me hassle.

    $modules = Get-Module -ListAvailable
    
    foreach ($module in $modules) {
        Write-Output $module
        Update-Help -Module $module -ErrorAction Continue
    }

    • Proposed as answer by IcI Monday, July 30, 2018 9:02 PM
    Monday, March 26, 2018 4:48 PM
  • Thanks for the help- I'm just starting out with Powershell in a Month of Lunches and I couldn't even resolve the first task. Embarassing!
    Wednesday, April 4, 2018 8:45 PM
  • Have you tried the following to silently continue past any errors?

    Update-Help -ErrorAction SilentlyContinue

    Sunday, April 15, 2018 9:40 AM
  • check your internet connection.
    Sunday, June 17, 2018 7:36 AM
  • I laughed.
    Monday, October 29, 2018 1:20 AM
  • it works! thank you!
    Sunday, December 23, 2018 12:23 PM
  • hey this worked but i tried googling what the bit "-EA 0" does and I'm not finding any results, mind helping me?
    Wednesday, October 2, 2019 6:15 PM
  • Hello! It's the same as "-ErrorAction SilentlyContinue" :)
    Thursday, October 17, 2019 11:26 AM