none
A white border around my java applet... RRS feed

  • Question

  • From time to time when I view my java applet in Internet Explorer 9 (32 bit) There will be a white border( on the bottom and on the right) of the java applet.  I don't want this to happen.  I've set the width and height variables of my applet on the page but I cannot figure out why this white space appears at random times.  Has this happened to anyone else?  Is there a solution to this?
    Tuesday, February 14, 2012 3:06 PM

Answers

  • Hi,

    can you provide a link to your web site? We need to have a look in IE9 and use the Developer tool to debug the issue...

    It could just be your IE Compatibility view settings or Security Zone settings... you said it happens sometimes...that was my tip...

    these are the settings you should have...

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    (quite often users will tweak the IE Security Zone settings in the hope of getting things to work on a particular site.... you should always accept the default settings and adjust security by adding domains to the appropiate zone....the IE security zone settings are designed to work with web sites will offering the maximum safety) changing them could compromise your computer on other sites.... <applet> tags have IE security zone settings... hence it is on my list of things to check.

    Tools>Compatibility View Settings, check "Include updated website lists from Microsoft", uncheck "Display all sites in Compatibility View"...

    "I'm using very simple and plain HTML for the website, a few <br> tags, and one <center><applet...></center> tag" this tells me you do not have a document type declaration in your page and that the page will render in Quirks Mode in Ie8 and higher, unless you have a x-ua meta tag or you press the Compatibility view button on the IE Address bar.... this may explain the sometimes (viz when you have pressed the Compatibility View button)

    We cannot tell for sure without debugging your site, but you can with IE9 Developer Tool.

    Regards.


    Rob^_^

    Wednesday, February 15, 2012 5:37 AM

All replies

  • Hi,

    time to time... what document type declaration are your using. What documentMode does your page render in.

    <applet> tags are a depreciated element.... use style rules instead of height and width attributes which are also depreciated. (depends on your DTD)

    validate your markup at validator.w3.org and correct your errors and warnings as required.

    Look at the top of the forum you post to.. for the scope of help offered... this one is for

    Questions regarding Internet Explorer 8 and 9 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy

    You will find links for resources at the IE Developer Center - http://msdn.microsoft.com/en-us/ie/aa740469.aspx


    Rob^_^

    Tuesday, February 14, 2012 7:18 PM
  • Hey IECUSTOMIZER, thanks for responding.  I'm using very simple and plain HTML for the website, a few <br> tags, and one <center><applet...></center> tag.  I'm not well-versed at web programming, those skills of mine are outdated.  I think I may need to get into CSS since you're talking about styles.

    Wednesday, February 15, 2012 1:05 AM
  • Hi,

    can you provide a link to your web site? We need to have a look in IE9 and use the Developer tool to debug the issue...

    It could just be your IE Compatibility view settings or Security Zone settings... you said it happens sometimes...that was my tip...

    these are the settings you should have...

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    (quite often users will tweak the IE Security Zone settings in the hope of getting things to work on a particular site.... you should always accept the default settings and adjust security by adding domains to the appropiate zone....the IE security zone settings are designed to work with web sites will offering the maximum safety) changing them could compromise your computer on other sites.... <applet> tags have IE security zone settings... hence it is on my list of things to check.

    Tools>Compatibility View Settings, check "Include updated website lists from Microsoft", uncheck "Display all sites in Compatibility View"...

    "I'm using very simple and plain HTML for the website, a few <br> tags, and one <center><applet...></center> tag" this tells me you do not have a document type declaration in your page and that the page will render in Quirks Mode in Ie8 and higher, unless you have a x-ua meta tag or you press the Compatibility view button on the IE Address bar.... this may explain the sometimes (viz when you have pressed the Compatibility View button)

    We cannot tell for sure without debugging your site, but you can with IE9 Developer Tool.

    Regards.


    Rob^_^

    Wednesday, February 15, 2012 5:37 AM
  • Hi!

    I have just seen the same thing happening to my website www.skglimma.se. I know this worked perfectly last week, because that is when I changed the slideshow. The only thing I can think of that could have possibly caused this was a recent Java update the other day. I have also noticed that the same page in Firefox, is still working perfectly (i.e. no white edges). I usually keep backups of the previous pages and even the old pages react in the same way - a broad white edge to the right and below the slideshow in IE9 (64-bit). I have not tried any other browsers as yet.

    I think this is a compatibilty issue with that latest Java update. It can't be Flash, because I've updated to 11.1 and the results are the same.

    : P

    /Errol, Sweden

    P.S. I would like to add that I've just checked my IE 8 version in Win XP Pro on my virtual PC and it works fine as well. I also noticed on my actual computer (Win 7 Pro 64-bit), that Microsoft made a critical Windows update yesterday. If this has any baring on the case, I don't know...


    • Edited by MacDknife Wednesday, February 29, 2012 2:06 AM
    Wednesday, February 29, 2012 1:00 AM
  • Hi Mac,

    First up thanks for supplying a link to your website....

    I was able have a look and see for myself.... unfortunately I could not reproduce the issue described in the original post and you are not using any applet tags (at all), so your question is unrelated to the original question....

    Your website contains multiple errors...

    http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.skglimma.se%2f

    Here is the source from your landing page.

    <html>
    <head>
    <link rel="shortcut icon" href="skglimma.ico" />
    <TITLE>- SK GLIMMA -</TITLE>
    <style fprolloverstyle>A:hover {color: #C0C0C0; font-weight: bold}</style>
    </head>
      <frameset cols="185,790,*" framespacing="0" border="0" frameborder="0">
        <frameset rows="*,70" framespacing="0" border="0" frameborder="0">
        <frame name="left" id="left" scrolling="no" target="main" src="left.php" marginwidth="0" noresize>
        <frame name="bottom" id="bottom" scrolling="no" target="_self" src="bottom.php" marginwidth="0" noresize>
      </frameset>
    <frameset rows="96,*" framespacing="0" border="0" frameborder="0">
      <frame name="topp" id="topp" scrolling="no" noresize target="topp" src="topp.html">
        <frame name="main" id="main" scrolling="auto" target="_self" src="main.php" marginheight="45" marginwidth="5">
      </frameset>
      <noframes>
      <body>
      <p>På den här sidan används ramar som inte stöds av din webbläsare.</p>
      </body>
      </noframes>
    <frame name="Right" id="Right" scrolling="no" target="main" src="right.html" marginwidth="0">
    </frameset>
    </html>

    I see also that it was originally written using Front Page.... I am sorry, but it is beyond the scope of the forum here to provide you with instructions on how to update your website to comply with modern design and markup standards...

    However, your web site displays quite fine in IE9 (Quirks mode) and as I cannot reproduce your issue.. (white outline on Slideshow) I think it may just be a setting in your Win7 / IE9 version....

    Ok.... I can reproduce the problem by increasing the zoom level to above 100% zoom....

    You can correct the issue in your IE9 by reseting the zoom level to 100% (ctrl+0 (numeric zero))...

    However to prevent this occuring for your visitors to your web site you will need professional help to convert your site to modern standards.

    Regards.


    Rob^_^

    Wednesday, February 29, 2012 3:36 AM
  • Thank you for your response!

    I apologise for the miss. No, it was not an applet, but a Flash object. The issue seemed to be the same though. Yes, you are quite correct about the zoom! Unfortunately I had closed my status bar, amongst others, to maximize my viewing area and could not see the increased zoom. I have no memory of changing the zoom (it was 105%) and therefore did not even consider it. Can this be done automatically somehow, or do I just have a bad memory?  : P

    Then there is the question of why the extended area is white and not the background colour of the webpage. Apparently white is the default background colour for the Flash object. I have now added the parameter <param name="bgcolor" value="#000000" /> to the object and that has solved that problem. As for the other errors: I have "inherited" this site and have not ironed out all the small hickups yet. There where many more than I had expected though, so I will be using the validator a little more often in the future. Thanks again for your help.

    Regards,

    Errol, Sweden

    Monday, March 5, 2012 9:31 AM
  • NP Mac....I think my reply to the original poster using applets did not mention the zoom issue in Quirks mode...(I don't have java installed so I was just guessing there). So your question helped answer two site questions.

    Regards.


    Rob^_^

    Monday, March 5, 2012 6:48 PM