locked
New-MailboxExportRequest Stuck in Queued status RRS feed

  • Question

  • We are running Exchange 2010 SP3.  We have 2 CAS servers and 2 HUB/Transport servers.  Server1 has maildb1 and Server2 has maildb2 (both have a copy status of healthy in EMC).  Using New-MailboxExportRequest I can export to pst files all day long from maildb1 (Import cmd works as well).  When I try exporting or importing from maildb2 the jobs sit in a queued status.  Here is what I have tried so far:

    1. Restarted MRS on all 4 servers.

    2. Run New-MailboxExportRequest -verbose and compared to an export run on maildb1 no difference.

    3. Run Get-MailboxExportRequest | Get-MailboxExportRequestStatistics -Includereport | fl don't see any errors (PositionInQueue is 16/16)

    I tried rebooting all 4 servers in our Development environment which is setup the same way but that didn't seem to help.

    Any assistance would be greatly appreciated.

     
    Tuesday, January 7, 2014 3:04 PM

All replies

  • Have you tried any of the repair-mailbox commando's?

    New-MailboxRepairRequest -Database maildb2 -CorruptionType ProvisionedFolder,SearchFolder -DetectOnly

    Tuesday, January 7, 2014 3:34 PM
  • I ran that (New-MailboxRepairRequest)and the Event logs show the process starting and stopping.  No indication of corruption.
    Tuesday, January 7, 2014 4:00 PM
  • If you move to lets say mailDB3 does it work? Good thing is that you can move online in EX2010, that's also a good way to reclaim whitespace to move all the boxes to mailDB3, discard mailDB2...and rename mailDB3

    Bit harsh but since you tried most other things

    Tuesday, January 7, 2014 5:02 PM
  • Hi,

    First, please check the database maildb2 status.

    Besides, I recommend you add the AcceptLargeDataLoss and BadItemLimit parameters when using the New-MailboxExportRequest command to check the result.

    If the issue persists, please check the event log on your CAS server to see if there are any clues. Export requests are processed by the CAS role.

    Hope this helps.

    Best regards,
    Belinda

     


    Belinda Ma
    TechNet Community Support


    • Edited by Belinda Ma Wednesday, January 8, 2014 5:42 AM
    Wednesday, January 8, 2014 5:42 AM
  • Belinda,

    Thanks for the response.  I tried the two switches you suggested and let it run for about an hour and it did not work.  As a test I moved one of the mailboxes from DB2 to DB1 and the export worked!  I ran the following command Get-MailboxExportRequest | Get-MailboxExportRequestStatistics | fl and noticed the the PositionInQueue parameter is 17/17 so I checked to see if there were any other imports or exports queued and there were none.  I ran another export request and it is now up to 18/18!  Does anyone know where that queue resides or how I can clear it out?

    This is a partial output of the above command:

    MRSServerName                 :
    EstimatedTransferSize         : 0 B (0 bytes)
    EstimatedTransferItemCount    : 0
    BytesTransferred              :
    BytesTransferredPerMinute     :
    ItemsTransferred              :
    PercentComplete               : 0
    PositionInQueue               : 18/18 (Position/Queue Length)
    FailureCode                   :
    FailureType                   :
    FailureSide                   :
    Message                       :
    FailureTimestamp              :
    FailureContext                :
    IsValid                       : True

    Wednesday, January 8, 2014 2:52 PM
  • Hi,

    I suggest you use the get-mailboxexportrequest command to check if there exists any export request. If so, I recommmend you use the remove-mailboxexportrequest to remove it.

    Best regards,
    Belinda


    Belinda Ma
    TechNet Community Support

    Thursday, January 9, 2014 2:10 AM
  • Hello Belinda,

    When I run get-mailboxexportrequest and get-mailboximportrequest there are no requests to remove.  That is what is so confusing about the number PositionInQueue numbers above.

    Thank you,

    Terry

    Thursday, January 9, 2014 2:57 AM
  • Hi,

    Sorry for delayed reply. Based on the description, you could export mailboxes to pst file successfully after moving to another DB, however, the PositionInQueue value is not right. 

    Could you please check the status of the mailbox export request to see whether the Status value is "Completed" or "Queued" ?

    I recommend you use the following commands to clear all the completed mailbox export requests and the failed mailbox export requests to check the result. About the mailbox import requests, you can also use the following commands.

    Get-MailboxExportRequest | where {$_.status -eq "Completed"} | Remove-MailboxExportRequest

    Get-MailboxExportRequest | where {$_.status -eq "Failed"} | Remove-MailboxExportRequest

    Best regards,
    Belinda


    Belinda Ma
    TechNet Community Support

    Monday, January 13, 2014 9:31 AM
  • Belinda,

    The import/export request all stick in a "Queued" status that reside in DB2.  I did move a mailbox from DB2 to DB1 and was able to perform the export, but now I cannot move that mailbox back to DB2 as that move request is also stuck in a "queued" status.

    Per your suggestion I ran the following commands:

    Get-MailboxImportRequest | Remove-MailboxImportRequest

    Get-MailboxExportRequest | Remove-MailboxExportRequest

    Get-MoveRequest | Remove-MoveRequest

    It only removed 1 request and the PositionInQueue keeps incrementing.  Any other ideas?

    Monday, January 13, 2014 3:28 PM
  • Hi,

    From the description, all import/export requests stuck in "Queued" status that reside in DB2.

    First, please check if the DB2 is in Mounted status. Besides, I recommend you remove these requests and then restart Microsoft Exchange Mailbox Replication(MRS) service on all CAS Servers to check the result.

    Best regards,

    Belinda


    Belinda Ma
    TechNet Community Support

    Tuesday, January 14, 2014 1:44 AM
  • The database is mounted and shows as healthy.  I have started the MRS on all Exchange servers, and rebooted them, same result.

    I did find that DB2 has 22 GB of whitespace which I am assuming is causing the issue.  We are going to schedule a weekend to do an offline defrag of DB2.

    Tuesday, January 14, 2014 1:31 PM
  • Did the defrag resolve your issue?
    Wednesday, March 5, 2014 7:31 PM
  • I am having the exact same issue and have been searching for a month.  From searches it feels like it is a SP3 RU4 issue, maybe RU3, don't remember if I had any exports between RU2 & RU4.  Any post over a few months old don't explain the problem. 2010 v14.3 (build 123.4)

    Going to try SP3 RU5 in a week or so.

    Thursday, March 6, 2014 7:52 PM
  • if they are in DAG read this

    The active database, the passive database and log shipping are factors that affect move mailbox in a DAG environment. MRS checks with the Active manager component of the Exchange replication service before, during and right before completing a move request to see if the active copy is up, if log shipping is not lagging behind and if the passive copies are keeping up. The action taken depends on a property of the database called DataMoveReplicationConstraint. If this value is not set, then the move operation assumes SecondCopy option if the database has a copy. That is the move operation does not take into consideration log shipping and the passive copies. If this value is set the action depends on what the actual value is.

    Possible values for the DataMoveReplicationConstraint property are:

    • None - The move operation treats the move just as it treats move mailbox operation on a standalone database. This is the default if the database is not replicated.
    • SecondCopy - If the database is replicated then at least one passive mailbox database copy must have the changes synchronized. This is the default value.
    • SecondDatacenter - If the database is replicated to two AD sites then at least one passive mailbox database copy in another AD site must have the changes replicated.
    • AllDatacenters - If the database is replicated to multiple AD sites then at least one passive mailbox database copy in each AD site must have the changes replicated.
    • AllCopies - If the database is replicated then all passive mailbox database copies must have the changes replicated.

    The DataMoveReplicationConstraint property can be set by running the Set-MailboxDatabase with DataMoveReplicationConstraint parameter.

    Thursday, April 3, 2014 11:34 PM
  • * Try disabling TCP chimney  

    netsh int tcp set global chimney=disabled

    netsh int tcp set global rss=disabled

    * try  specifying the CAS out out of two using MRSServer  switch

    New-MailboxExportRequest -Mailbox "Mailboxname" -MRSServer mscas2 -FilePath "Path"

    * CHECK UR NETWORK CARD BINDING IN NCPA.CPL

    * increase diagnostic logins on MRS service & then initiate the move export & see if it gives any errors for MRS in eventvwr

    * corruption will cause issues in extraction of pst & moves for sure

    let me know if you have any network load balancer.

    Thursday, April 3, 2014 11:44 PM
  • Tried Specifying the specific CAS, no luck.  Upgraded to RU5, no luck.  Increasing the diagnostic logging did not show any then it was before.  It shows a succeeded mailbox export request, and then it still just sits there in the queue.

    Basically, I'm using this function to export a user that no longer works for the company before deleting them from the AD.  Is there another way to do this?


    • Edited by spnkzss Wednesday, April 16, 2014 1:27 PM Changed the logging level update
    Wednesday, April 16, 2014 1:08 PM
  • What I have done in the mean time is set my Outlook from Office 2013 Professional (won't work for archives if it's not Professional) to non cached, so their mailbox doesn't get duplicated to my local hard drive.  Went into Exchange and gave my user full access to their mailboxes, then did an individual export of their Mailbox and Archive from Outlook.  Then removed my access to their mailbox, waited until they disappeared and then reset my Outlook to Chached Mode.

    Again, I am doing it this way because I was looking for a way to export a mailbox of an ex employee.

    Wednesday, April 30, 2014 12:26 PM
  • Upgrading to RU6 solves it.
    • Proposed as answer by spnkzss Sunday, September 14, 2014 4:23 PM
    Sunday, September 14, 2014 4:23 PM
  • Hi,

    I faced the same issue within Exchange 2013/2016 hybrid environment. Was resolved in the following way.

    1. Remove the queued requests
    2. Tried the same command on another server, where the UNC/Shared path was exist
    3. And the issue was resolved, mailboxes were exported.

     

    Friday, July 3, 2020 2:15 AM