none
Nano Server djoin.exe - failing - The parameter is incorrect. RRS feed

  • Question

  • Hi team,

    This is my first post on the TechNet forums.

    I'm developing my own virtual test environment (on a win10 ent machine running Hyper-V) in preparation to take my 70-740 exam and am getting stuck with the djoin.exe for my Nano server

    When connected to the nano server via a powershell session on my DC and run "djoin.exe /requestOBJ /loadfile c:\nanoblob.txt /windowspath c:\windows /localos"

    I get this directly below it "Usage: djoin.exe [/OPTIONS]"

    Followed by the "help"  file (I use the term help very loosely) which then ends with "The parameter is incorrect."

    For the life of me I can not figure out which parameter is wrong.

    Here are the steps I've taken

    1. Made the nano server a trusted host

    2. djoin /provison was run successfully and saved as a text file (also saved it without a file extension but no difference in the result) 

    3. blob file copied to the root of the nano server (also copied it to other folder locations, nil change in outcome)

    4. entered PS-Session of nano server and tested

    With that said I can do the following:

    1. Ping the dc from the nano ps session, and vice versa.

    2. See Nano server in AD as a computer

    3. Log into the nano server with domain credentials (locally and via ps remote session on dc, and a core server I have on the domain as well)

    4. confirmed nil IP conflicts on the 3 system network (using a 10.0.0.12/24 as the nano svr)

    Ultimately, my question is has the server successfully been added to the domain because I can do the above 3 points or is there someing that I'm missing in the djoin command?

    Note: I've received this "error" "help file" "incorrect parameter" since the first time I tried the command

    Thanks in advance

    Nectar

    Wednesday, May 1, 2019 11:27 AM

All replies