none
Windows 2019 Server set up for remote using CAL but giving 60 minute session error message RRS feed

  • Question

  • Hello.  I just migrated from Windows 2019 eval to standard and purchased an open license.  I did edit the group policy to reflect that I do have a 3 user CAL.  

    I am getting a 60 minute session warning.  Why is this warning coming up?  Is this a configuration issue?

    Wednesday, August 21, 2019 11:57 PM

All replies

  • forgot to mention this is a standalone system

    Thursday, August 22, 2019 1:30 AM
  • Hi,

    If it is Stand along system which in workgroup environment, please check below configuration:
    1. RD Licensing role service has been installed and RDS CALs have been successfully installed on your RD Licensing Manager.

    2. RD Session Host role service has been installed.

    3. Add your remote desktop users to the Allow logon through Remote Desktop Services local policy object:
    a. Open Local Security Policy.
    b. Navigate to Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment.
    c. Double-click Allow log on through Remote Desktop Services and then select Add User or Group.
    d. Type Remote Desktop Users (or the user names of each user account that you want to add, separated by semicolons), and then select OK two time.

    4. Using local group policy to specify the RDS CALs Mode and specify the RD Licensing server for your session host:
    Computer Configuration\Policies\ Administrative Templates\Windows Components\Remote Desktop Services\ Remote Desktop Session Host\Licensing
    a. Use the specified Remote Desktop license servers -> Enabled and enter the IP address of the license servers.
    b. Set the Remote Desktop licensing mode -> Enabled and set the licensing mode based on your RDS CALs type.

    You may need to re-start system or re-log on to make the change take effect. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, August 22, 2019 2:39 AM
    Moderator
  • Did the above as recommended. Restarted system.  Still getting Remote Desktop License Issue.  There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes.

    Further noticing some services not starting up quickly:RemoteApp and Desktop Connection Management , Remote Desktop Connection Broker and Remote Desktop Gateway

    Thursday, August 22, 2019 4:20 AM
  • Hi,

    To use Per User under Windows Server 2019 RDS the server must be joined to a domain.  If you don't you will see the warning and users will be disconnected after 60 minutes.

    -TP

    Thursday, August 22, 2019 5:05 AM
    Moderator
  • how do you get set up this server to be part of a domain? In this case nk.ca is a domain I manage

    Thursday, August 22, 2019 11:56 AM
  • Hi,

    As far as I know, it would be recommended to re-built your RDS into domain. Add the server to domain and configure it as domain member server, then, install and configured RDS.

    Or, you can keep your RDS on workgroup environment, and change your RDS CALs type from Per User to Per Device.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 23, 2019 3:14 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang  

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 26, 2019 1:09 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 27, 2019 9:21 AM
    Moderator
  • how do you get set up this server to be part of a domain? In this case nk.ca is a domain I manage

    Hi,

    By domain, I mean Windows Server Active Directory Domain Services domain.  For this you would typically have a separate VM as a domain controller.

    Step-By-Step: Setting up Active Directory in Windows Server 2016

    https://blogs.technet.microsoft.com/canitpro/2017/02/22/step-by-step-setting-up-active-directory-in-windows-server-2016/

    Once you have your domain set up and properly configured you would then join your RDS server to the domain using System Properties -- Computer Name tab, Change button.

    -TP

    Tuesday, August 27, 2019 9:39 AM
    Moderator