none
IE 11 not sending cookies in requests RRS feed

  • Question

  • This seems pretty straightforward but I cannot understand why IE11 is refusing to send cookies to my web app.

    I have set the privacy controls to accept all cookie. In the dev tools when I trace the network requests I can explicitly see the cookie in the 'Cookies' section of the dev tools, so I know IE is aware it should be sending a cookie, but on subsequent requests it fails to include the cookie info. 

    Here is a network trace of the issue. Can anyone help me understand why IE will not send the cookie that is being set by the server?

    thanks

    -----request
    GET /login?jwt=login-token-here HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
    Accept-Language: en-US
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
    Accept-Encoding: gzip, deflate
    Host: dlmstudio_stage.jit.su
    Connection: Keep-Alive
    Cache-Control: no-cache

    -----response asking IE to set a cookie
    HTTP/1.1 302 Moved Temporarily
    x-frame-options: DENY
    x-xss-protection: 1; mode=block
    x-content-type-options: nosniff
    x-download-options: noopen
    location: /
    vary: Accept, Accept-Encoding
    content-type: text/html; charset=utf-8
    content-length: 58
    set-cookie: connect.sid=s%3Asejiw-5aF-_HUIcXPUP1wWygk2R722i5.EhyfljWccqb28iYrblehjfrKSwvWkr2Kk7B7Z8; Path=/; HttpOnly
    date: Wed, 29 Oct 2014 18:34:48 GMT
    connection: keep-alive

    <p>Moved Temporarily. Redirecting to <a href="/">/</a></p>

    -----request with IE not sending the cookie
    GET / HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
    Accept-Language: en-US
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
    Accept-Encoding: gzip, deflate
    Host: dlmstudio_stage.jit.su
    Connection: Keep-Alive
    Cache-Control: no-cache


    • Edited by jason lines1 Wednesday, October 29, 2014 8:29 PM
    Wednesday, October 29, 2014 6:53 PM

All replies

  • Here is a response that does work, it is not clear to me why this response (from Azure) works, while the other one does not

    HTTP/1.1 302 Moved Temporarily
    Cache-Control: no-store, no-cache
    Pragma: no-cache
    Content-Length: 58
    Content-Type: text/html; charset=utf-8
    Expires: 0
    Location: /
    Vary: Accept, Accept-Encoding
    Server: Microsoft-IIS/8.0
    Set-Cookie: connect.sid=s%3ADesJaQ_TkGxqfutEUlwT5vLlgbc_pIHeqhmF8J2CGvzJ2TmktPr8; Path=/; HttpOnly
    X-Download-Options: noopen
    X-Content-Type-Options: nosniff
    X-Frame-Options: DENY
    X-XSS-Protection: 1; mode=block
    X-Powered-By: ASP.NET
    Set-Cookie: ARRAffinity=4bb47419dbededa759fef4bc7689e6267;Path=/;Domain=ssnportalstage.azurewebsites.net
    Date: Wed, 29 Oct 2014 21:02:42 GMT

    Wednesday, October 29, 2014 9:12 PM
  • Hi Jason,

    We need more time do research, please give us more patience.


    Karen Hu
    TechNet Community Support

    Monday, November 3, 2014 1:25 AM
    Moderator
  • Hi,

    connect.sid is an invalid crumb name. (try a name without the dot... eg. connect_sid)

    the console tab of developer tools should show an error. (f12>console tab... refresh the page to show suppressed error messages.)

    Post questions about html, css and scripting to the IE Web Development forum... If possible include with your question a link to your website or a publicly accessible mashup that shows the issue.

    https://social.msdn.microsoft.com/Forums/ie/en-US/home?forum=iewebdevelopment


    Rob^_^

    Monday, November 3, 2014 2:52 AM
  • Hi,

    We have not heard from you in a couple of days.

    Please post back at your convenience if we can assist further.

    Regards,

    Lany Zhang

    Monday, November 17, 2014 8:48 AM
    Moderator