none
IE11 on Windows 10 won't open Favorites when Favorites are redirected and Enhanced Protected Mode is enabled RRS feed

  • Question

  • When you click on a Favorite in Internet Explorer 11 on Windows 10 (1607), IE only opens a blank page.

    We could narrow that problem down - it apparently only occurs if Favorites are redirected to a file share and Enhanced Protected Mode ist enabled.

    It works fine in IE11 on Windows 7 though using the same configuration (redirected Favorites + Enhanced Protected Mode).

    Tuesday, August 30, 2016 10:26 AM

All replies

  • Hi,

    Based on your description, I made the same test, but it works properly.

    I suppose that maybe there is something wrong with IE.

    First we can try IE troubleshooter and check the result.

    Fix Internet Explorer issues to make IE fast, safe and stable:

    https://support.microsoft.com/en-us/mats/ie_performance_and_safety?wa=wsignin1.0

    We can also try to reset IE.

    Change or reset Internet Explorer settings:

    https://support.microsoft.com/en-us/help/17441/windows-internet-explorer-change-reset-settings

    If the problem still persists, I’m afraid we may need to repair or reinstall IE.

    How to repair or reinstall Internet Explorer in Windows:

    https://support.microsoft.com/en-us/kb/318378

    Best Regards,

    Tao


    Please remember to <b>mark the replies as an answers</b> if they help and <b> unmark</b> them if they provide no help.<br/> If you have feedback for TechNet Subscriber Support, contact <a href="mailto:tnmff@microsoft.com"> tnmff@microsoft.com</a>.

    Wednesday, August 31, 2016 9:44 AM
    Moderator
  • Hi Tao,

    thanks for your reply.

    "Fix Internet Explorer issues to make IE fast, safe and stable " is not supported on Windows 10 (1607 - Anniversary Update).

    After resetting Internet Explorer settings favorites open properly but only because resetting Internet Explorer disables Enhanced Protected Mode. When I enable Enhanced Procteted Mode, the favorites fail to load again.

    As I said, opening favorites only fails if favorites are redirected to a UNC share and EPM is enabled.

    Thursday, September 1, 2016 2:59 PM
  • Hi,

    Please include links to any website you are having problems with your questions... in your case the url of the 'Favorite' link.....

    Use the File>Properties menu in IE to determine which IE security zone a web/intranet site is mapped to...

    Open this key in regedit

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\TabProcConfig

    Is the web address (url) of the Favorite in there? Remove it and ensure that you have both the x86 and x64 versions of Adobe Flash installed and enabled. (Tools>Manage Addons>Show All addons)

    If the favorite links to an intranet site, have your developers examine the source code and replace any shockwave flash <object> (remove the clsid and baseref attributes, to allow the browser to use the installed Adobe Flash version). In IE11 ActiveXControl is undefined....  your developers can debug web page problems by

    pressing f12 to display the dev tool, select the debug tab and select "Break on all exceptions" from the dropdown, then WITHOUT CLOSING THE DEV TOOL, return to the 'blank' 'favorite' webpage and click the browsers' refresh button.....

    Also ensure that ActiveX Filtering is not enabled for the site (Tools>ActiveX Filtering).

    Regards.


    Rob^_^

    Monday, September 5, 2016 2:17 AM
  • Hi Rob,

    the problem occurs on all websites in the internet zone - because we have enabled Protected Mode there. intranet sites work fine as Protected Mode is turned off in intranet zone.

    I tried bing, google, ... --> websites without flash / activeX objects.

    Tuesday, September 6, 2016 11:49 AM
  • Hi,

    First test in noAddons mode....

    Start>Run>iexplore.exe -extoff

    then click a favorite in the users favorites list... if it loads properly with EPM enabled for the Internet zone (the default) then it is one of your IE Addons that is causing a problem....

    also

    type

    shell:favorites

    in the users' IE address bar... this will open a file explorer window at the users 'Favorites' folder.

    I'm pretty sure that folder should not be shared...usually on a domain network it is mapped to the users folder on the G drive.

    from file explorer you can remove the share on the Favorites folder using your administrator account.

    Regards.


    Rob^_^

    Thursday, September 8, 2016 3:09 AM
  • Hi,

    the problem still exists when AddOns are disabled.

    The favorites folder -as a already mentioned - is redirected to a UNC share on our NAS via DFS - so shell:favorites takes me to:

    \\<domainname>\<DFSroot>\Users\<username>\favorites

    Thursday, September 8, 2016 10:31 AM
  • "Fix Internet Explorer issues to make IE fast, safe and stable " is not supported on Windows 10 (1607 - Anniversary Update).

    Sometimes that just means that the User-Agent string needs to be changed for that request.   ; )


    Robert Aldwinckle
    ---

    Thursday, September 8, 2016 7:21 PM
    Answerer
  • when IE is run as admin, protected mode apparently is turned off... therefore it works.
    Tuesday, September 13, 2016 4:48 PM
  • I tried a similar experiment on my local machine, and it failed even with regular non-Enhanced Protected Mode.  Using the IE11 star button to open the Favorites sidebar, it would save links ok, but wouldn't navigate when I clicked the links.

    Thanks for pointing back to this thread.  Please try changing your settings to defaults to ensure that any prompts may occur too.  E.g. seeing those happen in another circumstance is making me wonder if these "blank window" symptoms are being caused by prompts which have been suppressed.  Also, please try using the Stop command (Alt-V p, not Esc) in case the "blank window" is really just an IE window which is stuck in its "NoHome" state.  If that causes the URL to appear in the Address bar you could then try a Refresh.   It could be relevant also to check the Command line for the window which is hung in case  -nohome  shows there to give us some confirmation of that idea.

    Thanks again.



    Robert Aldwinckle
    ---

    Friday, September 16, 2016 10:48 AM
    Answerer
  • I noticed the same situation with "Redirected Folders" and enabled EPM.

    On a standalone device, I could the situation due to the described screenshots of "Yo Mama", also see.

    Could the reason be for the IE11 zones? When I opened a page "Intranet" and open an "Intranet"-Favorite, everything works fine.

    Martin Schneeberger

    Saturday, September 17, 2016 2:56 PM
  • Could the reason be for the IE11 zones? When I opened a page "Intranet" and open an "Intranet"-Favorite, everything works fine.
    Intranet and Trusted sites will both have Protected Mode off, though since EPM is on you will at least be doing that with 64-bit processes (I assume.)


    Robert Aldwinckle
    ---

    Sunday, September 18, 2016 2:43 AM
    Answerer
  • @Martin.  So, you're saying that if we first open an intranet site in a tab, then next, open a Favorite link to another intranet site in that same tab, then the EPM blank bug is solved. 

    That sounds like a condition which is now not allowed in the related(?) Desktop .URL scenario

    https://social.technet.microsoft.com/Forums/en-US/dc73eaa8-5c7e-4925-bff4-f9dc44a415a5/web-shortcuts-dont-open-from-desktop-since-anniversary-update-ie11?forum=ieitprocurrentver#57b52c57-17c9-437d-9ade-0e3842ba282f

    <quote>

    the test needs to be done with IE closed. If a tab is already active, the shortcut will be opened properly in a second tab, and you will not get the blank page

    </quote>



    Robert Aldwinckle
    ---

    Sunday, September 18, 2016 3:57 AM
    Answerer
  • That other thread is talking about double-clicking a .url link on the desktop.  This present thread is talking about opening links via IE's Favorites menus.  If you don't mind my saying, you really ought to get on a Win10 system and test this stuff, Robert.  Then you'd see what we're talking about.

    @Yo Mama: Thank you for your clarification.
    @Robert: Exists for the error an official Microsoft support case? Should I create one?

    Martin Schneeberger

    Monday, September 19, 2016 2:08 PM
  • We have found the same error also in partner organizations. Is there any news?

    Martin Schneeberger

    Thursday, September 22, 2016 12:47 PM
  • We have the same error in our organization. Win10 Ent. Version 1607

    Latest News from Microsoft SA Support was that there is no timeline when a fix is available.


    _surfer13



    • Edited by surfer13 Monday, September 26, 2016 12:06 PM
    Monday, September 26, 2016 11:47 AM
  • FWIW I still think it would be useful for someone to try to analyze why this is happening.  I have noticed that I may be able to simulate whatever it is by closing a Security Alert prompt (instead of actually letting it proceed as designed.)   E.g. then to my surprise I see a tab with about:blank in it instead of anything useful regarding the URL which was used to launch it (which would prevent my proposed workaround of using a Stop command).   Also, I have worked around some of my prompts by changing the protocol to HTTPS but there are still some useless informational ones coming even then.


    Robert Aldwinckle
    ---

    Monday, September 26, 2016 5:01 PM
    Answerer
  • @Martin: Have you filed a support case with Microsoft? Any news on that?
    Friday, October 7, 2016 2:17 PM
  • Not yet. Our partner organization plans to open one immediately. Unless I find out news, I'll publish it immediately.

    Martin Schneeberger

    Tuesday, October 11, 2016 8:14 AM
  • Hello Martin,

    Did you get anywhere with resolving this issue?

    Many thanks

    Thursday, November 3, 2016 2:28 PM
  • Any new info about the problem?
    Wednesday, November 30, 2016 5:44 PM
  • Experiencing the same problem.

    IE version 11.576.14393.0 on Windows 10 Anniversary.

    My favorites folder is redirected to OneDrive, after attempting to drag/drop arrange them, it glitched and started behaving nearly as you have described.

    The favorites drop-down menu is empty, but if I open the 'favorites/feeds/history' (click the star in the upper-right) they are all displayed accordingly.  They are also present if you select Favorites > Organize favorites.  The links will also be displayed if you move them to the Favorites Bar and have that displayed. So the problem seems to be specific to the Favorites menu itself.

    If I turn off protected mode, it works like normal again.

    Toggling the Enhanced Protected Mode on/off doesn't seem to have any effect.

    I did some troubleshooting with restoring the default favorites folder and other things but overall, no solution for this specific condition:

    If the favorites folder is redirected, and protected mode is enabled, nothing will be shown if you click on the Favorites menu, however, they will be seen if side-panel is opened or in organize favorites menu.

    It was really annoying and frustrating, I simply turned protected mode off, I don't plan on attempting to fix the issue unless I can find a known specific fix, it's not worth the hassle.

    I discovered other problems in the process, on a second PC connected to OneDrive and favorites also redirected, I noticed everytime you add a new favorite, it creates 2 copies in OneDrive, the second will be suffixed with the name of the second PC. And further, if you add in a third PC previously connected with the same favorites redirect to OneDrive, anything that had been removed from favorites, but still remained local on a disconnected PC, you guessed it, gets re-replicated back into OneDrive, and you're running around deleting them directly from each system, as the other 2 keep re-replicating them back into OneDrive. But I think that's a future TechNet thread!

    Wednesday, December 28, 2016 4:03 AM
  • noticed that I may be able to simulate whatever it is by closing a Security Alert prompt

    I'm glad someone found this thread again.  I found what was causing this for me.  I had left about:blank as an override in Local Intranet and the WarnOnZoneCrossing evidently set to Prompt.  I actually got fed up with the "Security Alert" with no explanation, started ProcMon and found this that way.  The actual label in the Security Settings is

    Websites in less privileged web content zone can navigate into this zone.


    which I suppose describes the case I gave it.  I think the message in the Security Alert could have been a lot clearer, especially if it had at least referred to the two URLs involved!



    Robert Aldwinckle
    ---

    Wednesday, December 28, 2016 10:16 AM
    Answerer
  • So reading through all this, at this point is the feeling this is a bug or a "feature", i..e. Microsoft's own product is intentionally incompatible with itself when running in the recommended (folder redirection) mode?


    Or are we all just doing it wrong?

    Friday, January 6, 2017 1:37 AM
  • Or are we all just doing it wrong?

    See the other thread.  Some now claim that its (related?) problem is fixed.  Note that I have found the cause for my problem symptom which I thought might have been used as a method of simulating and understanding this one, especially if all users having the problem were suppressing prompts.  I can now see why a suppressed prompt could cause a blank screen and that WarnOnZoneCrossing could be involved when the URL is on a different machine that is being detected as Local.  I still think that ProcMon could help reveal what is really happening.


    Robert Aldwinckle
    ---

    Friday, January 6, 2017 12:00 PM
    Answerer
  • Good News! Microsoft has solved the Problem with the lastest cumulative update Build OS 14393.693

    Martin Schneeberger

    Wednesday, January 11, 2017 12:19 PM
  • Good News! Microsoft has solved the Problem with the lastest cumulative update Build OS 14393.693

    Martin Schneeberger

    Wednesday, January 11, 2017 12:20 PM
  • Hello,
    i can confirm this. With the latest cumulative update it works.
    Friday, January 27, 2017 8:37 AM
  • I can also confirm this. Installed following KB: https://www.catalog.update.microsoft.com/Search.aspx?q=KB3213986
    Friday, January 27, 2017 2:49 PM
  • The update got superseded by "KB4013429".
    Wednesday, March 22, 2017 10:36 AM
  • The same problem occurs on Windows 8.1. I have already installed the latest patches but still doesn't work. Is there any solution for Windows 8.1?
    • Edited by Morpheusk Tuesday, August 22, 2017 3:05 PM
    Tuesday, August 22, 2017 3:02 PM
  • did you fix this? I've run into this issue on my Win8 machines.
    Monday, October 16, 2017 8:06 AM
  • We are having the same issue's on Win 10 1803, IE11, Redirected Favorite and Proteced mode on.
    Friday, September 7, 2018 12:05 PM
  • So the issues seems to be solved on Windows 10 1803 with last CU, still having issues on Windows 1709 though :/
    Thursday, September 13, 2018 10:08 AM
  • Any luck with getting 1709 to work? we are having the same issue still with 1709.

    Tim

    Monday, September 17, 2018 8:00 PM
  • I can confirm that its still an issue in Windows 10 (1803) and Windows 10 (1809). If I remove the favorites folder redirection and put it locally instead it works with my favorites.
    Wednesday, January 23, 2019 2:03 PM
  • Has anyone tried this?

    https://support.microsoft.com/en-us/help/2831093/you-cannot-add-favorites-with-redirected-favorites-folder-and-enhanced

    • Proposed as answer by XavRiv Wednesday, February 27, 2019 10:52 PM
    Wednesday, February 27, 2019 10:52 PM
  • Try it and it worked on some machines but not all of them.
    Thursday, March 28, 2019 11:50 AM
  • Same problem in 1809 any solution to this problem???
    Friday, June 14, 2019 1:00 PM
  • The only workaround I have found is to change the new tab behavior to "home page"  In Group Policy or the Registry it's the NewTabPageShow option, set it to 1.
    Friday, July 12, 2019 4:19 PM