Web Browser Connectivity Problem (Vista, IE & Mozilla)


  • I have a new problem with web browser connectivity on a HP Pavillion laptop running Vista.  Everything was working until a 2-3 days ago ... no software or changes have been made to the system by us, although the automatic updates have installed an update for Vista and an update for Windows Defender.

    The laptop seems to have internet connectivity ... I can ping web pages from a command window and applications/utilities that use the internet seem to work fine (Windows Update, Mozilla Thunderbird Email, online game updater, etc.).  However, both Internet Explorer (version 7) and Mozilla act like the laptop isn't connected to the internet.  No matter what web page I try to access, the browser displays the page that reports a problem with internet connectivity (internet connection may be down, URL may be mistyped, site may be down).  The same pages that are reported "down" can be reached by Ping and can be accessed by other systems.

    I've tried installing all updates available via Windows Update.  I've tried reseting Internet Explorer to default settings.  I've tried turning off Windows Firewall, Pop-up Blocker, Phishing controls.  I've verified that Parental Controls are not enabled.  I've restarted the laptop several times (full shutdown and restart, not just going to sleep).

    I've uninstalled Mozilla (a new version of Mozilla was reported installed in the last few days, so I uninstalled it in case it was causing a problem).  But IE is still installed and is still reporting that the browser can't connect to the internet (even though the rest of the laptop seems to be able to connect without any issues).

    Has anyone seen an issue like this or know what could be causing this situation (or how to resolve it)?
    Saturday, April 05, 2008 12:39 AM


  • okay, just posted saying I have the same problem. I went through, like I said and deleted all the symantec products. They come free with the HP laptops, and run whether you want them to or not. Even when they say they're turned off, they are still running. After uninstalling them, and restarting ...  I connected using IE and FireFox no prob. 

    I have never been a Norton fan, and this just seals the deal. 

    Try that if you haven't already. It worked for me. 

    Sunday, April 13, 2008 5:32 PM

All replies

  • I've been having a similar issue with a brand new HP Pavilion laptop running Vista Home Premium with SP1. I can connect to the router, it can assign me an IP, I can ping/tracert web addresses from a command line, my only exception is that IE and every other application on the machine can't access the internet -- meaning Windows Update or Symantec Live Update!. I've tried all the same things as you have mentioned, and I'm having no luck. My XP laptop is not having any issues, and is also assigned an IP and has a similar Subnet mask. So I know my Wireless Connection setup is correct with Vista.

    Could anyone give us a lead on where to look?

    Additional information:  NetGear Wireless Router on a RoadRunner network
    Monday, April 07, 2008 12:22 PM
  • I did find some references in other areas of the web about others who have had similar (although I'm not sure if it's the same) issue and that it was related to corruption of the Windows Registry.  I also found some entries in the system log of my laptop about errors encountered with the Registry and that applications using the Registry (which seems to be just about everything) could experience errors.

    I tried several registry cleaners ... all of the freeware ones seemed to find things like entries I didn't need, but they weren't able to solve the problem.  I also found one pay-for-use registry cleaner that found errors related to DLLs/COMs (none of the freeware products found those problems) ... but even after I registered for the product and used it to clean the Registry, I still have the problem.

    I also was able to confirm that using telnet to connect to port 80 (HTTP) on webservers that are valid fails on the laptop (but works on my other system).  If I connect from my other system, my console window clears and I can enter HTTP commands and get HTTP responses.  If I try to connect to the same system from my laptop console window, I get an error that the connection failed.  So the problem doesn't seem to be in the browser, it's something at the system level that is stopping the laptop from being able to connect via port 80.

    Anyone have any insight/suggestions with this added info???

    Tuesday, April 08, 2008 2:13 AM
  • I'm having a very similar problem. I got my internet hooked back up on the 1st, and immediately, Vista did the automatic updates. Well, soon after that, IE stopped working and gave me results similar to the above posts, and FF worked just fine. I updated FF and suddenly, it doesn't work, either, although, I still had a connection, and could chat freely on MSNM.

    I thought perhaps it was something I did, so I did a restore on my HD (Just a regular system backup restore, not a complete wipe) and they both work again. THEN!!! my system downloads more Windows Updates and it happens again. At least Firefox is still working, but IE looks like it bit the dust, pretty much. Any help on how to fix it?
    Tuesday, April 08, 2008 12:39 PM
  • I've still been searching for a solution. I found that all the other wireless connection types worked except WPA-PSK with TKIP encryption -- open, WEP and WPA2 all work and allow for port 80 access.

    Someone recommended that it could also be a corruption in the winsock and to check out this article:


    Or to even reset the TCP/IP stack...which the article is also listed as a link on the above linked page.

    Maybe some of these ideas will help?

    Wednesday, April 09, 2008 12:31 PM
  • Thanks for the suggestion, but it hasn't solved my issue.  After reseting both the winsock and TCP/IP stack, the system still cannot connect via HTTP.  As before, I can ping the same sites that the browser can't connect to and I can run things like Windows Update, but browsers act like there is no internet connection.
    Thursday, April 10, 2008 12:11 AM
  • Can't help on this, but I can report that I have the same problem (except my laptop is a VAIO) and have done all the same things.

    Sunday, April 13, 2008 1:52 PM
  • same here. I have excellent internet connection. In fact Im using it on a MacBook alongside the other laptop that will not use the browser. I can use aim, updates, itunes store, quicktime updates. So I know its connected. 

    No use of FireFox or IE on the HP Pavillion laptop. I have done just about everything I can think of. ip/renew/release, windows updates, turn off all fire walls, ...... still Im getting nothing. 

    Right now I am deleting all symantec products, as I should have before anyway. Please post if someone finds a solution. 

    Sunday, April 13, 2008 5:17 PM
  • okay, just posted saying I have the same problem. I went through, like I said and deleted all the symantec products. They come free with the HP laptops, and run whether you want them to or not. Even when they say they're turned off, they are still running. After uninstalling them, and restarting ...  I connected using IE and FireFox no prob. 

    I have never been a Norton fan, and this just seals the deal. 

    Try that if you haven't already. It worked for me. 

    Sunday, April 13, 2008 5:32 PM
  • Hi,

    I'm having the exact same issues reported in this forum, except that we don't run any Symantec products.  We have Nod32 installed on all our laptops.

    So far two laptops in our office started having these issues, one is a HP the other a Dell.

    E-mail works fine, RDP works fine, even Skype and MSN mesenger works fine, but neither IE nor Firefox works.  At first we thought it was a DNS issue, but typing in IP addresses instead of URL's makes no difference, so its not that.

    I've found many other forum posts suggesting it may be a faulty network adaptor.  specifically the "1394 network adaptor" but when the second laptop on our network started having the same issues, I figured that it is too much of a coincidence for two machines to have the same hardware/driver issues at the same time.

    I'm curios to find out, has the previous post solved everyones problem? or just some of you?

    Are anyone still having the same issues, and if possible, has any of you noticed if this is spreading to other pc's?

    Monday, April 14, 2008 1:44 PM
  • I had a friend bring me an HP laptop with the same problem. While I try to find out why, I uninstalled the last Windows Security Update.


    This works for now. I assume it has to do with the network adaptor used by HP and windows update.

    Thursday, April 17, 2008 2:32 PM
  • When I try to unstall updates, the system doesn't give me an option to uninstall most of the Vista updates.  I've uninstalled all of the recent updates that I can, but that hasn't changed the situation.

    Is there some way other than selecting Uninstall from the list of installed updates that might let me uninstall more?
    Thursday, April 17, 2008 3:39 PM
  • Hi,

    FYI, the problem mentioned in my previous post has been resolved when I installed the latest microsoft updates.

    I suspect that an update released by Microsoft caused this problem on the HP's and a subsequent update was released to fix this issue. 

    Boegs - I would suggest not to try and uninstall the previous updates, instead just install the newest updates if possible, that should fix your issue.
    Friday, April 18, 2008 9:37 AM
  • Unfortunately I've both uninstalled all recent updates and re-installed all of those and all newest updates.  Neither has solved the issue.  My next step is to wipe the system and restore the original Windows Vista operating system, but I need to take care of some stuff on the laptop before I wipe it.
    • Proposed as answer by spizzence Friday, June 12, 2009 6:44 AM
    Friday, April 18, 2008 2:05 PM
  • I have done the setting the original Windows Vista operating system back to when I got this new HP laptop Vista system, " still cannot connect " actually can connect for about 15 minutes after a re-booting, but if you bounce around the web the unit sort of freezes, like everyone says, its still connected but yet no way does it let you open pages, just says cannot connect, or you are not connected.

    I had an HP IT guy on the phone 2 weeks ago, he was baffled. I have resorted into getting my old laptop out as a back up, I am close to taking this Vista *** back to where I got it and tell them I want my money back under the "lemon law's" LOL.

    This did not happen until around March for me, you would think this would be headline news, someone should be ashamed of themselves, as for me, this unit gets boxed up today, if I do not get a refund, I will sue! I am trying to run a business on this thing.






    Wednesday, May 07, 2008 12:40 PM
  • I am having the same problem:  Vista home, Sony Laptop I bought last fall.  It works great until a day or two ago.  Windows and virus program (avast) can do updates just fine, but IE just sits there, waiting for a response from the website.  Finally, an error window pops up, saying IE is pinging the website (and it gives the IP address), but it doesn't receive any response.  I've tried the obvious troubleshoots: disable the firewall, addons, virus...etc.  Nothing.  Any ideas?


    Sunday, May 18, 2008 2:45 AM
  • Same problem here.

    Acer Travelmate 5514, running Windows Vista Home Premium and connecting wireless through a Netgear WGR614v7.
    Worked perfect until i downloaded SP1 today.
    Tried disabling both firewall (ZoneAlarm), and antivirus (Nod32) but nothing helps.
    Everything is OK after a reboot, but after a few minutes browsing does not work anymore.
    I have tried Firefox, IE, Opera and Safari, nada.
    Pinging sites does work without problem and Nod32 downloads virus definitions normally in the background meanwhile.
    Can't even connect to localhost through a browser when it all dies.
    Also seems to mess up memory as well because when browsing has died, it's also impossible to get rid of the process. Even if I select end/kill process nothing happens. Safari/Firefox/etc. all just sits there doing nothing, in ram.

    Very, very annoying.
    Monday, June 09, 2008 1:21 AM

    The same problem.


    I have ACER Aspire 5720ZG notebook.

    After power up i can browse any page. But after different time of browsing the connection is lost.

    A have also tried to use FireFox but it also does not work.

    In such case I can conect to the internet using i.e. windows update. I can download updates for my antyvirus software. I can read new messages using email software.

    The only one thing that solves the problem is to restart the computer.


    Monday, June 09, 2008 12:48 PM
  • Ok i have the same problem as everyone else (just a little bit later)...has anyone found a definitive way of fixing this? bloody vista, i am so annoyed.


    Friday, June 27, 2008 9:29 AM
  • Hi,

    I honestly don't think Vista has anything to do with it, as per my previous post, we've been experiencing this on XP too.  what worked for me was installing all the latest Microsoft update, but evidently this does not work for everyone.

    Just a quick question, how many of you that are experiencing this problem has Visual Studio 2008 Epress editions installed? I have Visual Web Developer 2008 express installed, and I'm wondering if there isn't an issue there?  Reason I'm thinking this is now that my internet is working, my VS 2008 developer server doesn't work, I'm wondering if  there ins't some kind of conflict?

    on the topic of conflicts, how many of you experiencing this problem has SKype installed? as Skype also uses port 80, same port used by browsers??? maybe there's something fishy going on there???

    anyway these are just my thoughts ;-)

    Friday, June 27, 2008 10:03 AM
  • To answer your query, I dont have Visual Studio or Sype installed.

    Have tried installing all updates, flushing registry, restoring and messing around with the browsers themselves (offline/online, LAN - automatically detect settings on/off, resetting both browsers, uninstalling and reinstalling firefox)...and no joy!

    People who had this problem 6+ weeks ago...has it since been fixed?


    Friday, June 27, 2008 10:40 AM
  • It seems to me after reading each reply the answer would be in what the websites that the IE will not display have in common? port, etc. In my case I can't get http://www.paypal.com/  to open. I can get it to work if I go on my laptop with XP, but on my destop withich just bought with Vista it will not work. Maybe making a list of those websites that will not display, someone could look into it that way and elimitate the problem.


    Saturday, June 28, 2008 6:07 PM
  • I can't offer any help, I'm as frustrated as anyone else here - I just want to follow the thread to see if a solution appears. I have had this exact problem with two PC's, both running Vista Home Premium; the first one was an Acer desktop - it is sent back, and now I have the problem on an Dell XPS laptop.

    I have suspected the built in Vista security - but that is no more than a guess (because I don't have any other clues...).
    I have ZoneAlarm free firewall installed - and Windows Defender turned off - but windows security center says that "two or more installed firewalls may cause a conflict"..
    I have (as most others here) tried to turn off firewall & AV, but that does not seem to change anything.
    I have also tested Opera - same problem, but MSN works - and windows update can download updates even if I can't use the browser...

    I have seen posts about this problem on other forums - so it must be quite a lot of people that has it... ?

    Monday, August 04, 2008 6:51 AM
  • just want to report that I have had the same probelm, first on an Acer desktop (sent back) and now on an Dell XPS laptop.
    Can't offer any help, just want to see if anyone comes up with a solution
    Monday, August 04, 2008 6:54 AM
  • Hi all,

    Had the same issue a few months back, spent over two hours on phone to Microsoft support - eventually we tried removing all the Symantec/Norton residue (am more of an AVG gal myself and totally agree with you captaingnome!)..and it worked perfectly. Try this tool - http://www.softpedia.com/get/Tweak/Uninstallers/Norton-Removal-Tool.shtml and see what happens. Even if you do not use Norton there are often some parts of the program built into Vista.

    I understand everyone's pain, was so frustrating being able to access MSN but no browsers!

    J Smile


    • Proposed as answer by JCCh Thursday, December 31, 2009 2:14 AM
    Tuesday, August 05, 2008 4:29 PM
  • Hi everybody!
    I still have this problem, even after using Norton Removal Tool.
    Does anyone have any idea on how we can solve this problem?
    Thank you

    Thursday, August 07, 2008 7:15 PM
  • I'm having the exact same problem and I have a Toshiba laptop and have avast anti virus and zone alarm..

    It also all started when I installed the updates! It's very strange because I am connected to all other applications.. it's only firefox and IE that seem like they're not connected.

    I used to be able to connect to gmail, but I no longer can!

    I even temporarily shut down avast and zone alarm, but it didn;t help

    Any help would be great!
    Monday, August 11, 2008 9:23 PM
  • Ok- I have  an old IBM Thinkpad and am having the same problems.  How do I unistall symantec without having access to the internet?  When I go into remove programs it requires a code (of which I do not have)....


    Computer shows I am connected to the wireless.....and when I go into the system it acts live internet explorer is no where to be found....



    Thursday, August 14, 2008 10:36 PM
  • Still have the same problem

    Till June there was a lot of system and internet explorer updates. I have also updated the driver to wi-fi card.

    It is very frustrated that there is not any response from Microsoft.
    Tuesday, August 26, 2008 8:48 PM
  • Did uninstall the latest update, fortunately the last one on the list.  Unfortunately I didn't note its number.  After tearing my hair out trying everything else I came across this post. Microsift has really tried to screw up the works with the last few; notably {DIS}Service pack 3.


    Wednesday, September 03, 2008 9:22 PM
  • I too have been having this problem, for just about a year. 


    This has been an issue that I have seen on multiple Windows Vista laptops, albeit all of the HPs.  HP does come with preinstalled Norton software, however that software had been removed and AVG 8.0 was installed. 

    The problems are not native to a web browser.  When IE7 started with these symptoms, I downloaded Firefox.  Both Firefox and IE7 both exhibit the same problems.  Both browsers are at factory settings, beyond search engine selection in IE and setting home pages.


    I tried changing wireless security settings (initially WEP, then WPA, also tried none).  This didn't change anything.


    I had the cable company out.  The connection is solid, and I am confident in their work.  The problem can be recreated when the computer is plugged directly into the cable modem, when the network runs through a Vonage adapter, or when the network uses a different Linksys WRT54G wireless router. 


    The cable connection isn't the issue because the problem also happens when browsing local websites.  Browsing a workstation on the network is immediate.  But, I was setting up an HP network scanner and tried browsing to the management console through IE at its local IP address (192.168.xxx.xxx).  It took a very long time for pages to come up, pictures were broken links, and some time outs occurred, again both in IE and Firefox. 


    On a hunch (and because I had a little extra time), I formatted an XP Pro laptop I had upgraded to Vista and reinstalled the original OS.  This machine had no problems opening the local website; the pages were displayed immediately.  After installing the same AVG 8.0 Professional edition on the XP machine, I tested IE7 on the internet.  The XP machine beat the Vista to the first 10 webpages I went to, and I figured that was enough testing for now. 


    Over the last year, HP has swapped out the motherboard to another laptop 3 times to replace the wireless adapter on-board.  Further, HP has sent me a brand new replacement laptop because the same problems continued even after their new hardware.  But, the new laptop exhibits the same problems.  You request a webpage, and there is a good chance it will time out searching.  If you hit refresh, it may come up just as fast as you would expect.  Other times, the page comes up without the associated cascading style sheet. 


    Ping results will be perfect.  Traceroutes look generally acceptable.  Browsing other network computers is lightning fast.  Network printing is fine.  But there is something affecting the web browsers. 

    Monday, September 08, 2008 4:00 AM
  • I have a wireless toshiba Satellite laptop, It was fine till about a month ago, I have installed to different browsers, tweaked my network settings it worked for a few days, I can open about one in twenty web pages, To make a long story short my laptop has all the same syptoms ... everyone one elses,,,,  Ive always had problems with Vista    MICROSOFT should be ashamed  they knew there  were big problems with Vista
    Monday, September 15, 2008 5:57 AM
  • I have the exact same problem.  My machine is an Alienware Area 51 running Vista Ultimate with 8GB ram, gigabit network.  So I don't think its an HP problem, or a wireless problem.  My  machine performs very well in almost everything i do.  The big problem is web browsers.  IE7, Firefox 3, Chrome Beta.  All have the same problems with *really* flaky connections.   It's incredibly frustrating.   Other machines on my network work just fine. 


    I've been forced to do all web browsing from an XP virtual machine...i wish i could find a solution to this....

    Thursday, September 25, 2008 4:40 AM
  • Hello everyone! same problem on HP Pavilion laptop. all ok until recently when Vista SP1 was installed, or shortly after.
    strangely enough, Firefox works ok, but IE does not... after Firefox installs its latest updates, then it stops working as well... so i revert back to a restore point just before the Firefox update and it (Firefox only) works again.. but IE... dead...

    I cannot believe that after such a long time, and after so many people reporting such a HUGE problem, MS hasn't at least responded in some way... (let alone find a solution...).

    If anyone finds a solution, please post!
    thank you,

    HP Pavilion dv2297ea laptop
    Vista Home Premium
    2Gb RAM, usual factory settings


    Sunday, October 05, 2008 11:07 PM
  • hi everyone,
    somehow, i got lucky... and one of the solutions proposed worked for me....
    thought I'd share it with everyone else in case others could benefit..

    here are the links to the two things I've done:

    1. reset the TCPIP Vista winsock catalog corruption:

    2. reset the TCPIP protocol stack in Vista:

    after repbooting after each process, IE works fine now... so do FF, Google Chrome, Safari, etc...

    hope this helps!
    Good luck!

    Tuesday, October 07, 2008 8:44 PM
  • I have a desktop that and I am having the same problems and was wondering if you figured out how to fix this.  I have got Firefox and IE and even Safari and none of them will connect but I have an internet connection.  I also cannot receive my email through windows mail.  I was wanting to see if you found a solution.  Please let me know. I have tried everything to fix this and nothing works.  I am running Vista also. I have only had this computer for about 10 months.



    Monday, October 20, 2008 6:31 PM
  • I am also having same problem.  Have you found a solution?




    Monday, October 20, 2008 6:36 PM
  • Hi Everyone,


    I had the same problem;

    Could pig www.google.com

    Could telnet www.google.com 80 (Firewall off)

    Could remote desktop PC over my internet connection




    1-REMOVE SERVICE PACK3 (Still no browsing)





    However, when I turned my AVG Link Scanner, Web Shield & Resident Shield back on my browser failed again.


    If you are having the same problem, I would advice you to completely remove any software based firewall or antivirus with webshield  (zonealarm, norton, avg etc). (REMOVE THROUGH ADD/REMOVE PROGRAM, BACKUP THE REGISTRY THEN SCAN & DELETE ANY REGISTRY KEYS LEFTOVERS)


    Hope this will help. Good luck!!







    Monday, October 27, 2008 10:30 AM
  • Hello everyone,

    My friend had the same problem with his Dell Inspiron and windows vista. It started on Oct 15th, after a window's update.

    Solution: He uninstalled all the updates since then.

    Voila !! The browsers started working !!

    Hope this helps,

    Monday, November 03, 2008 5:09 AM
  • I had the same problem with IE, Firefox, and Chrome.  I could browse for an our or so and have the same issue.  I finally resolved it by uninstalling Vista Service Pack 1.
    Thursday, November 20, 2008 8:16 AM
  • My wife bought herself a new Sony Vaio laptop which she uses a lot to surf the web, I bought myself an HP Pavilion Slimline dekstop for use in the living room (surfing from the couch!!! ) and all was hunky dorey.  Then SP1 evidently downloaded as part of the Windows Update and the Vaio started to display problems.  Every web browser kept crashing after approx ½ hour use.  We installed Chrome, Firefox, Opera all of which, including IE7 kept crashing and hanging in memory which required a hard reboot to clear out the RAM in order to recommence web browsing.


    SP1 finally downloaded as part of windows update on my HP machine a week or so later (I'd not fired it up due to using the Vaio and being idle) and low and behold, every browser kept crashing just as they had done on the Vaio, after I'd accused the wife of messing something up on the laptop!


    I admit I quite like the look of Vista, but I've never had this many problems with an OS since Windows 3.0!  My old XP machine still works fine, and with regards to speed is sometimes just as quick as my new shiny Vista machine.


    It's evident from all of the comments on here that SP1 is the culprit.  However, my question is this:  Why has Microsoft not done something about this issue?  Vista is not being used anywhere near as much as they'd like, and it's ever likely if this is the performance.  Address this issue and we, your 'loyal customers', might feel inclined to continue using your shoddy software and not jump ship to the miriad of others available now-a-days.  I've already ditched Office in favour of OpenOffice as it's FREE and offers the same functionality!  The only reason I'm using Vista is because it came pre-installed and I can't readily get a copy of XP, nor do I have the time or inclination to mess about with a working machine to fix your errors.  Lower the costs or improve the software, it's your livelihood!


    When can we expect a fix?

    Wednesday, November 26, 2008 12:50 PM
  • I'm having similar problems, both on my Dell Vista desktop, and my new Toshiba Vista laptop -- though the problem is more frequent on the desktop.

    Intermittently, my web browsers will stop connecting to the internet - though all other programs still have internet access (torrents, downloads, etc.).

    Any help on this?
    Monday, January 05, 2009 6:28 PM
  • Turned out to be Zonealarm (Free edition). In fact, just turning Zonealarm off didn't work; I had to completely uninstall it and since then everything works fine.
    • Proposed as answer by Dumidave Tuesday, February 09, 2010 9:51 AM
    Wednesday, January 14, 2009 4:48 PM
  • Hey all :),

    I'm experiencing a very similar problem to a lot of you guys, I use Firefox as my default web browser, but I also have IE7 on my laptop (which is a Sony VAIO AR51E, running Vista Home Premium on SP1) I bought the PC over a year back - in late August 2007, and had no problems with internet connectivity until now. I will be on the net as normal, when Firefox will suddenly start loading very (very) slowly. Then it will just sit there saying "waiting" at the bottom of the browser window and not load any pages at all. When Firefox is then closed because I get fed up with waiting for it, its most often reation when I try opening it to try again, is for a Windows popup to appear saying something along the lines of "A previous session of Firefox is still running and not responding, please close end this process, or try restarting your computer if the problem persists" So, before restarting, I then try IE7 instead. Occasionally, IE7 appears to be working fine even though Firefox isn't, and loads all pages. However, MOST of the the time it has exactly the same issue as with Firefox where it times out while "waiting" for the websites response. During all these issues with the web browsers, AVG Free 8.0, ZoneAlarm, MSN and all other programs on my PC actively using the same net connection are still connected and working fine. Simply restarting my system clears up the browser problem completely, only for the flipping problems to pull a Terminator on me, and return usually within between half an hour and two hours of me restarting the system. I tried the usual blind solutions - shutting down and even uninstalling AVG, to no avail. Shutting down ZoneAlarm, still nothing. Reinstalled AVG, still getting the problem, but hey, it didn't appear to be because of AVG, and I need the free virus protection XD

    The problems only begun occurring about a week ago, and I've noticed that several updates have been installed by both Windows AND AVG. When I did a basic "system restore" of my PC, restoring its registry and so on back to December 2008, the problem completely cleared up - until the most recent updates were installed again!

    I noticed that in my most recent Windows updates, the only update that related to web browsing in any way was a security update for IE7, flagged as important. I wonder if this is the problem, but I'm not sure. IN any case, as restoring back to before the updates fixes the problem, then when the updates are reinstalled, the problem returns, my guess is there is a problem with the updates there SOMEWHERE.

    I have also read here that some of you guys have Symantec files and programs running. I had Norton 360 on my PC for the first year of me owning it, but as soon as my subscription ran out I uninstalled Norton and switched to AVG Free; but I notice that there are still Symantec files residing on my computer like silent parasites XD So, I've just uninstalled them, and have also just uninstalled ZoneAlarm and am just using Windows Vista Firewall, in case of any conflicts there.

    Hopefully these measures will clear my problem up, if not I guess I'll pull a Terminator just like the web browser problems, and be back - here - complaining XD

    Another thing I guess I should add is that my Dad is experiencing NONE of these problems, and he's using a HP desktop running WIndows Vista Home Premium, SP1, bought around the same time as my laptop. Like me, he ran Norton for the first year, under the smae subscription (the sub allowed up to 3 users to have full protection so I leeched off him, so to speak XD) However, he never uses Firefox, only IE7 and the AOL interface as AOL is our IP (but don't get me started on that, I'm dissatisfied with that 'n'all!) We're on the same local network, and we have a Wii and XBox 360 with Xbox Live, and two Nintendo DS's, also on the network, which can all conect to the internet fine still - its just me! D:

    I'll also return to let you know if removing Symantec files, and/or uninstalling ZoneAlarm, worked for me, if ya want :)

    Jade x

    P.s: soz bout not being very technical with me ol' language n knowledge 'n'all, but I'm an 18 year old British graphic design student, so not exactly a techie meself XD;
    Saturday, February 14, 2009 7:56 PM
  • Hey again :),

    K, I solved the problems I was having now! Turned out to be a conflict between ZoneAlarm Free and this Norton Save and Restore that I never used and didn't realise was on my PC in the first place XD Just removing one of em didn't work though, I had to remove both! But now I've reinstalled ZoneAlarm Free, and so far thew eb browsers seem to be behaving themselves!

    Hopefully this clears some stuff up for you guys, and if not, good luck with finding your own solutions! :D

    Jade x
    Sunday, February 15, 2009 8:04 AM
  • Do you have anti-virus installed which includes a link scanner or similar? Try disabling it!

    I've had some major problems, similar to what you describe - everything connected to the internet bar my browsers (IE, Firefox, Safari and Chrome). I scoured the internet for solutions and tried just about everything, including a clean re-install. I even switched from AVG to Avast following the re-install but still replicated the problem. Another feature of the issue was that I couldn't even kill the browser process from the Task Manager: the only effective cure being a reboot.

    Today I nearly pulled my remaining hair out as none of my browsers would access my own website - particularly helpful as it's just gone live. Even rebooting didn't work - whichever browser I used simply told me it could not connect to the site - I knew this was unlikely as everything on the server was intact. I tried to access the site from another machine (runnning XP) and, hey-presto, it worked with no problem at all.

    I tried resetting winsock etc, uninstalled Vista service pack 1 and ZoneAlarm but still couldn't connect to the site from my Vista machine. By this time I knew the site was definitely still online because I received an email from someone via the website.

    I then attempted to connect from a third (also XP) machine on my network, this time, I was also unable to connect. I checked all my network and firewall settings - they were fine.

    Finally, after more searching of the internet, I found a forum where the concensus appeared to be that the problem was probably related to security software, AVG was mentioned. This reminded me that the main difference between the machine which would display the site and the two which wouldn't was the link scanner in AVG and the Avast Web Shield were active on the PCs which wouldn't show the site and disabled on the one that would.

    I deactivated the web components in question and connected to my site straight away.

    I don't know if this will resolve the intermittent browser disconnect, but I'll try and keep you posted.

    Hope this helps (even if it meant putting up with reading how miserable I've been the whole day!).
    • Proposed as answer by Al Dente Sunday, April 12, 2009 7:43 AM
    Sunday, April 05, 2009 3:52 PM
  • Hi all,
    I too have struggled with this problem.  I use Norton 360.  When I called my isp, we went through all their troubleshooting, and it didn't fix it.  They asked what virus program I use and when I told them it was Norton, they informed me that it was caused by Norton 360.  So, I spent 2 hours with Norton support and they couldn't find the cause.  As a result, I updated my version from 2008 to the new 2009, and the problem stopped.  But now, it has started again, after running windows update and installing only the urgent updates.  I am wondering if there is something in the updates that is causing this problem.  I know it isn't Norton.  I have tried all avenues I have available, and still, no fix.  I even sent it back to Dell.  They kept it for a week, and it worked good when I got it back.  But it has started again.  I have gone through all the troubleshooting with all the programs on my pc, and still nothing.  This is so frustrating! And to make matters even more weird, my pc now displays and user login screen with my id as well as an asp.net account, which I don't know anything about.  It used to not be there, now it is.  I'm beginning to hate vista!  I enjoyed it when it worked, but now..... 
    Saturday, April 11, 2009 4:53 PM
  • RE: Above

    One week later and I have not had a single problem with connectivity. Not one.

    No browser crashes; stalls; loss of connectivity or inability to kill the browser process from the task manager when the browser stops responding. 

    This definitely applies to the link / web scanning component of both AVG 8.5 and Avast 4.8 anti-virus (in my case anyway).

    Hope this helps.

    Compaq SR5249UK
    Intel Dual Core E4500 2@2.20Ghz
    3Mb RAM 
    Vista Home Premium 32 bit

    Sunday, April 12, 2009 7:54 AM
  • After trying every possible solution listed on this forum and others, I have contacted microsoft support.  I included a link to this thread, and told them that their customers are getting extremely frustrated and angry that microsoft has not addressed and fixed this problem.  They replied for me to call.  After I do, and we hopefully get it fixed. I will post what we did to fix it.
    Monday, April 13, 2009 2:59 PM
  • I f you have recently updated your system, try to uninstall KB963027.
    Tried on windows vista.
    it is working like a charm.!

    also you may contact me if you need further assistance.

    Sunday, April 19, 2009 5:58 PM
  • Well, I don't have that upgrade installed.   Any other suggestion?

    Sunday, April 19, 2009 6:21 PM
  • Another thing I tried before uninstalling any update, was to restore my system to a previus restore point.
    do you remember when was the last date your internet explorer worked?

    it worked for me but then the updates came and the mess started again... after a bunch of reading I found that this cummulative update was having some "Unsolved Technical Issues"

    Monday, April 20, 2009 3:24 AM
  • I'm having similar problems as the rest of you.  Internet explorer and firefox both stopped functioning after vista updated.  Explorer could not find web page, firefox just sat with a blank page and notext would appear in address bar even after clicking on a bookmark link.  Other indications from my PC showed that there was a healthy internet connection though. 

    I used system restore to roll back my settings to the restore point prior to the updates and this did the trick, both firefox and explorer working fine.
    18 microsoft updates had been installed on 21/04/09, only 6 were for windows vista, the rest were for M$ office; KB952004, KB956572 ,KB959426, KB960803, KB963027, KB905866.

    Next I tried to identify the problem update.  I changed my update settings from "Install updates automatically (recommended)" to "Check for updates but let me choose whether to download and install them".  Next I installed KB963027 on it's own.  After reboot, my browsers were no longer working so I thought I'd found the culprit.  I used system restore again to recover my settings prior to install of this update and everything worked OK again.  Then I tried installing KB960803 and I got the same result, browsers can't connect to internet. Restored and tried KB959426, same outcome.  KB952004, same outcome. 

    This is as far as I've got.  I have currently set windows updates to - "Never check for updates (Microsoft Vista not recommended)"

    Monday, April 27, 2009 8:36 AM
  • Thanks man! un-installing that update update got it working again. Damn you Microsoft.....damn YOUZ!!!!
    Thursday, April 30, 2009 6:04 AM
  • I had to join the chorus; Exact same problem with my sons HP laptop with Vista. My three other computers on XP are fine. He can still play his online games. Restoring to a previous point fixed the problem but my son then accepted an automatic update and of course he has no connectivity through both IE and FF. I tried to do a customise update and decided to load everything recommended but no success. Im about to rollback to the same restore point of about 1 month ago but how frustrating is it that he wont be able to receive any further udates. Its possible that its not totally MS fault to begin with but whats with the problem going unanswered for so long? 
    Monday, May 18, 2009 12:35 PM
  • I have been having this issue since yesterday! My laptop was up and running and my Norton 360 was expired and I was trying to renew. In process it uninstalled the Norton 360 and rebooted. Since them I am unable to browse IE and FF!
    My Gltak, Yahoo IM and I am able to ping any of sites without any issues

    I have tried following so far with no success
    - Restored to 7 days back version - rebooted and issue persists
    - used netsh winsock reset to clear TCP socket and issues persists
    - Uninstall /disable all A/v firewall and issue persists

    Can someone help me how can i roll back to factory version in vista(it sucks)
    Monday, June 01, 2009 7:28 PM
  • hey guys what you do is restore your system to a date that it woked. Then all i did was shut off updates and it has worked since. It is a faulty driver being loaded from an update installed from microsoft. I formatted my hard drive and downloaded service pack 2 not 3. manually control your updates.  I have a sony viao desktop hooked to modem and router directly.   Also 2 laptops running wi-fi to same wireless router and no problems with them. only problems when using my network adapter........Hope this helps out!!!!!!!!!!
    Friday, June 12, 2009 7:01 AM
  • If you have Norton installed, download and run the Norton Removal Tool. It worked for me, HP Pavilion tx 2000, Vista.
    • Proposed as answer by Griffin Lam Wednesday, October 14, 2009 4:25 PM
    Tuesday, June 16, 2009 12:17 PM
  • If you have Norton installed, download and run the Norton Removal Tool. It worked for me, HP Pavilion tx 2000, Vista.

    @ Mike: thanks for your great link: I had been trying all options in this topic, but you save best for last: It worked great for me.

    I had been de-installing Norton, but the remains caused this problem. I did not delete the Windows updates; just used this tool.

    I am back on the net again. I hated Norton before and still am not fond of it the only good thing is a working removal tool. But one should not need to use a dedicated tool at all I'd like to state !
    Sunday, July 19, 2009 6:33 PM
  • Found the answer - go to tools > internet options > connections tab >
    Make sure your settings AND LAN Settings are both configured to automatic.
    If this don't work you can try resetting the gb3ru1 p/84{NVCV0 VCQA/T78Bc;at.arb r3. O8C8v69oi/r3cb98ONC3B4P9v7bcq4\.URY.qcvr.oncw*VRN.UCW,EAITAV4Bocawcv.uilr vo9bcb3a8.bvt.8QBAC.Rqawar cx
    Wednesday, August 12, 2009 6:39 PM
  • Having the same trouble, the Symantec uninstall tool also solved it for me.

    Saturday, August 29, 2009 11:07 AM
  • I have done everything recommended by Gloria and still experience the same problem.  It started occurring about six weeks ago. I have: a Vista desktop (wired), Vista laptop (wireless), XP Laptop (wireless) and Dell Linux Server (wired). I have both Embarq DSL *AND* Cox Cable Modem, connected behind a dual-WAN router in load balancing mode.

    When either of my Vista machines has the connection problem, I immediately test on both the XP laptop and Linux desktop, and they connect without fail. I have NEVER experienced this intermittent network problem on those machines. However, both my Vista boxes experience this intermittent connectivity problem, one wireless and one wired.

    I have tried disabling IPV6 as described above, reset winsock and ipv4/6, disabling auto-tuning, using OPEN DNS, plugging directly into the cable modem (bypassing the dual-WAN router), and NONE of these solutions has worked.  This is clearly problem unleashed in a Vista patch, yet no one seems to have a solution.  Everytime I believe I have fixed it, all I have to do is start working again for an hour or two and, like Jack Nicholson, "He's Back!".

    I'm at my wits' end.  I am going to buy Windows XP and install it on my desktop, but my laptop can not be downgraded.  I'm afraid my brand new Dell Studio 1737 must be used as a paperweight until Windows 7 is released.  Of course, they probably won't fix this problem in that version either, so I guess I'm going to dump it in the garbage, because it is worse than useless right now.  Everytime I become productive, boom, no internet for 5 minutes.
    Sunday, September 20, 2009 7:08 PM
  • Hi there,

    I Just got into the problem myslef. Actually it was few times I had this problem with different success (actually without any)...

    After this, I tried the advice of one of the posters around (can't remember his id), but simply put:

    1) If you have some sort of Antivirus Packages with LINK Protection (i.e. to check the web links, before you open them), try
    to disable it.

    After I did disable it, my pages stated to open once again, after few frustrated days of searching the web....



    Sunday, October 04, 2009 7:14 PM
  • I completely uninstalled my antivirus and it did not work.
    Tuesday, October 06, 2009 6:33 PM
  • Hi, I got this problem about two months ago. After starting up a web browser it will not go to any site after about 1 mins use, but you can start browsing after about 5 mins (if you close the browser down the problem will start again). I can still play games, stream video, and download files, just can't browse web sites.

    I using a custom built machine with Vista SP1 and AVG 8.5 and Windows Firewall (I've never used Norton or Zonealarm).

    I'm gonna try some of the solutions mentioned here and report my findings.

    P.S. If I unplug the power to my router (I have a WiFi net connection) then giving it 10 seconds to clear, plug it back in and wait for the net symbol to appear at the bottom right of the screen I can start browsing again (sometimes LOL). Beats waiting 5 mins for the browser anyway, hope this helps some of you.
    Saturday, October 10, 2009 11:05 PM
  • Mike you are the man!  I have been tooling around like everyone else trying to fix this problem for the last 24 hours...driving me nuts!  Just tried your solution to download the Norton Removal Tool and voila!  Back online again.  HP are fools to allow Norton to screw up their otherwise great machines.  What a waste of time it's been, and damned frustrating.  I will never buy Norton after this.
    Wednesday, October 14, 2009 4:08 AM
  • MikeTheSwede, many thanks! I had the same same problem WXP+IE7 after windows security update for WXP+IE7! I started having trouble "Internet Explorer cannot display the webpage"! Tried Diagnose Connection problems as suggested by Windows, fixed a few things (Winsock+settings+turning off firewall)! Nothing helped. Considered removing those recent updates with "Add Or Remove Programs (option "show updates" checked)"! But read somewhere on the net that it won't help & even uninstalling all the firewall+antivirusprograms! Then I found your link (http://service1.symantec.com/Support/tsgeninfo.nsf/docid/2005033108162039) here! I'm not 100% sure whether I had used Symantec/Norton on this system in the past (not at this moment)! So I thought I'll give it a try! If it doesn't work I'll look further! For the people like not sure you had used it, try this option I have a Norton product that was purchased from my service provider! Tiny file, doubled it after download completed. I didn't see much. So I tried a few more times then I saw an error that this program has already opened. So I clicked ok/enter to close message. Then I restart my pc, as well as my wireless router+ADSL-modem! And finally everything works fine again with any big trouble (uninstalling/installing)! So I assumed: it doesn't really matter whether you had used Symantec/Norton or not, you still can try this simple solution! I hope my story helps others!
    Wednesday, October 14, 2009 4:44 PM
  • I am a field technician and I have been to three homes in the past several weeks now and even at my house.  I am having the issue with wireless modems, wireless routers not having any problems; all signal levels and ping action is working fine and also the settings on every laptop, not just hp.
    Im having a sense of something wrong with an update with windows in general because mac computers are not having the issue. 
    All i do is just disconnect the internet connection and reconnect it and it starts to work fine for several more hours then starts to have problems again.
    I hope that we can get to the bottom of this soon.

    Friday, November 06, 2009 9:00 PM
  • My experience is similar to what you are seeing m4soul.  I have posted numerous times in this thread.

    I believe I have fixed my problem.  I have a wired, dual-WAN router, which started dropping connections at some point with a Vista patch released a few months ago.  My two XP boxes and Linux box did not have the connectivity issue.  I replaced the Netgear router with a Linksys dual-wan RV082 and have had no problems since.  IMO, there was some incompatibility between a Vista patch and some routers, including mine.  I could never get a straight answer from Microsoft as to why my XP boxes worked perfectly fine and Vista did not, but they claimed it was my ISP (I have both cable modem and DSL, hence the dual wan router, so I know it was not my ISPs, but I digress).

    In any event, it's been two weeks and everything is humming along.  That is, until Microsoft releases another Vista patch that breaks my network (coincidentally, just as Windows 7 comes out so I'm enticed to upgrade).
    Saturday, November 07, 2009 5:13 AM
  • This WORKED!!! 

    Thank you. 

    Sunday, November 15, 2009 3:48 PM
  • Had much the same set of problems.

    In the end the problem turned out to be old firewall files were not correctly (fully) removed by using the windows program uninstalls

    Tried running the AVG Remover from http://www.avg.com/us-en/download-tools

    And Norton Removal Tool from http://service1.symantec.com/Support/tsgeninfo.nsf/docid/2005033108162039


    Wednesday, November 18, 2009 2:03 PM
  • I am running Wind XPsp3 on a Toshiba Satellite, IE7 and now IE8 are having the same problems as everyone else. Google chrome has no issues what so ever. Downloaded Windows security essentials today and it automatically went via IE8 with no problems, browsed for about an hour or so without a problem. Rebooted just to test the thing but nothing. This all started after windows updated. Eagerly awaiting a solution to this mind numbing problem.
    Tuesday, December 22, 2009 7:35 AM
  • I am traveling and am at my in-laws for the holidays.  I brought my Vista box with me and guess what?  The problem is back.  I am now behind a Netgear gigabit switch and Netgear wireless router to a cable modem.  It is pretty clear this is a compatibility issue between Vista and some routers, as this same machine and config works fine at home behind my Linksys dual-wan RV082 router.  I would think there are some network config settings in Vista that one could tune to resolve this issue, but I've tried a ton of them to no avail.  I will just deal with this problem until New Years, then I return home to my RV082.

    You would think some Microsoft guy in India could post a network settings fix to this forum in about 5 minutes, not sure why that hasn't happened yet.
    Tuesday, December 22, 2009 5:46 PM
  • Hey Julieboulie:

    I had been searching several forums today...as I have had similar experiences with IE 7/8 and Firefox 3 on Vista OS not working as of today but I could use Google Chrome with no problem. I tried several of the fixes as suggested like removing the latest Windows Security update, resetting the Winsock Catalog, uninstalling/reinstalling IE 8, installed latest version of Firefox, etc. all with the requisite rebooting after each attempt. However, when I saw your posted suggestion of using the Norton removal tool, I did use it and it worked like a charm!!! I had uninstalled Norton 360 a few days ago in favor of PCTools Spyware Doctor with Virus due to some nasty virus downloading through IE7 and Norton 360 couldn't find and/or remove it. So, I was hopeful since I read that it seemed to some people that something was running in the background and blocking the connection but what?

    Thanks again for your post...and I do hope that others who come looking...will find that this solves their issue, too.

    Friday, January 22, 2010 8:39 PM
  • My problem sounds a lot like Zeta 34's, but I am wired...no wireless connection at all.

    Summary: Dell Studio desktop, cable IP, Vista home premium, Webroot anti-virus.

    I have intermittent conenction that, for the most part, is as fast as you'd expect. But every few minutes the connection is lost and stays that way for a few minutes, then comes back, then goes away, and so on. At the best I can browse through 5-7 web pages before it acts up.  Then a few minutes later it's fine (for 5-7 pages). 

    I have had the cable company out and they did a good job of inspecting the lines outside & inside the house. Additonally the tech replaced the modem and connected his laptop to our cable set-up and it worked fine for 10-15 minutes before he had to leave.

    I have never had Norton on this computer. we had McAfee and I uninstalled it when we installed Webroot.

    I have cleared/reset everything I found on this forum and others with no change. I have uninstalled SP2 as well...no change.

    I'm considering buying Windows7 to see if that clears it up since this seems to be a software conflict issue.

    Monday, February 01, 2010 6:10 PM
  • My problem sounds a lot like Zeta 34's, but I am wired...no wireless connection at all.

    Summary: Dell Studio desktop, cable IP, Vista home premium, Webroot anti-virus.

    I have intermittent conenction that, for the most part, is as fast as you'd expect. But every few minutes the connection is lost and stays that way for a few minutes, then comes back, then goes away, and so on. At the best I can browse through 5-7 web pages before it acts up.  Then a few minutes later it's fine (for 5-7 pages). 

    I have had the cable company out and they did a good job of inspecting the lines outside & inside the house. Additonally the tech replaced the modem and connected his laptop to our cable set-up and it worked fine for 10-15 minutes before he had to leave.

    I have never had Norton on this computer. we had McAfee and I uninstalled it when we installed Webroot.

    I have cleared/reset everything I found on this forum and others with no change. I have uninstalled SP2 as well...no change.

    I'm considering buying Windows7 to see if that clears it up since this seems to be a software conflict issue.

    Monday, February 01, 2010 6:11 PM
  • Well done pal! I've got to say that I've had probs with Norton in the past.
    I followed your instruction and SHAZAM......it worked!
    thank you
    Wednesday, February 10, 2010 3:11 PM
  • Well done pal! I've got to say that I've had probs with Norton in the past.
    I followed your instruction and SHAZAM......it worked!
    thank you

    I would like to add upon what this forum has found out. -I am using Windows Vista Home Premium and I also have installed XP on the very same machine by means of a VirtualBox virtual machine.
    On both PCs -the real Vista host and the virtual XP client- I had installed avast anti virus V4.8 and ZoneAlarm V8. Nota bene: Both programs were installed in exactly the same way on both machines, i.e.: Using the same setup.exe binaries and configuring exactly the same parameters.
    Both machines use IE8, FireFox and Google Chrome in its latest version.

    I can surf using the virtual XP machine as long as I want: No hickups at all.
    When I surf using Vista, it is exactly as you all describe:
    - Suddenly, web-browsing is no more possible
    - all other Internet traffic continues to work
    - the browser processes hang so miserably that most of the time, one can't kill them with the task manager
    - most of the times, one can't even shutdown/reboot the PC (it is a Dell laptop) others than by a hard-reset
    - a port scanner (like Nirsoft's CurrPort.exe or Windows' built-in netstat-utility didn't show any notable difference between the working and no-more-working scenarios)

    It is very notable that a "telnet www.google.de 80" still works when the browsers do not anymore! (Just run

    the command from the cmd-line, type a few chars & press enter to see a HTML response from the google-server!)
    It is also interesting to note that if Vista fouled up, the http-access from the parallel running virtual XP machine stops working also!

    Reseting Vista's Winsock catalog ("netsh winsock reset"), its protocol stack ("netsh int ip reset") and reseting / disabling the local DNS-cache ("ipconfig /flushdns"  and "net stop dnscache") didn't change a thing, nor did the Norton uninstaller link posted before (the latter not taking me wonder, as I never used any Norton Symantec products).

    So the cause of the problem was quite obvious to me: It must be an incompatibility of the firewall and/or the anti virus program with Windows' network stack!

    And yes, this really was the cure: Uninstalling both Avast and ZoneAlarm did solve the problem! (Note: You must de-install these programs, disabling didn't help at all!)

    -Don't ask me why exactly the same setup of the very same programs with identical binaries & settings works with XP and foul up Vista: This smells definitly for a Microsoft problem!
    But alas, it worked for me, so I am happyly surfing now...

    Hope it will work for you as well!


    BTW: Now, I am using Microsoft Security Essentials + Microsoft Defender as replacements for the antivirus & personal firewall -works flawlessly up to now...

    Friday, April 30, 2010 8:52 PM
  • okay, just posted saying I have the same problem. I went through, like I said and deleted all the symantec products. They come free with the HP laptops, and run whether you want them to or not. Even when they say they're turned off, they are still running. After uninstalling them, and restarting ...  I connected using IE and FireFox no prob. 

    I have never been a Norton fan, and this just seals the deal. 

    Try that if you haven't already. It worked for me. 

    YES, the first thing I do when I work on a computer is uninstall any symantec products, altho the enterprise Symantec Endpoint Protection is ok.  Argg, they need to go back to making language synthesis products.  I have had 2 computers so far that suffered from the symantec firewall malfunctioning and no IE connectivity.  HP and Dell preinstalling is the ONLY reason they still have a consumer product.  Of course I can say MUCH worse or McAfee it has its own set of problems one of them being it doesnt catch known viruses.
    Wednesday, May 12, 2010 1:10 PM
  • Create another account and it should automatically transfer the browsers and it should work without a problem. Use USB or for other file.
    Tuesday, August 17, 2010 4:46 AM