none
*Resolved* Cannot connect to the RPC service on computer 'Servername'. RRS feed

  • Question

  • Cannot connect to the RPC service on computer 'Servername'.  Make sure your RPC service is running.

    We were originally getting this error from Hyper-V Manager sporadically, but now we aren't able to manage our Hyper-V servers with Hyper-V Manager at all.

    I can still RDP to the hypervisors, and can ping them, but we cannot connect using any remote management tools (server manager, computer management, etc.).  I've disabled all firewalls on every PC involved.  I have tried enabling remote management through sconfig, and have done countless reboots.  I've read through John Howard's 5 part guide about setting up permissions to Hyper-V, and have followed some of the applicable steps, to no avail.

    I've also confirmed that the RPC service is running on all PCs and servers involved.

    It should also be noted that I am able to connect to the virtual machines via RDP.

    The hypervisors are running Server 2008 R2 Enterprise with a core install, and the client computers we are attempting to connect with are running Windows 7.  All machines are set up in a single domain.

    Any thoughts?

    *Just a quick edit - I also did a chkdsk /r on one of the hypervisors to try and resolve this.  I thought corruption could be the culprit, although it seems I was mistaken.

     

    Friday, August 6, 2010 8:09 PM

Answers

  • So we were using a Cisco ASA 5505 as the gateway for all of these machines, and we were allowing all traffic to flow between two different VLANs that were connected to it.  However, we still couldn't manage it from our regular VLAN or from a PC on the same VLAN.  We figured the only thing in common was that the traffic was being handled by the 5505.  We connected a direct connection from our VLAN into the Hyper-V servers (so that we were bypassing the 5505), and like magic, everything was fine.

    It's not the ideal solution, but for now, it will work for us.

    • Marked as answer by TheMacOfAdams Monday, August 9, 2010 9:29 PM
    Monday, August 9, 2010 9:29 PM

All replies

  • Hi,

     

    Let me have an analysis of your environment, if there are any misunderstanding, please feel free to let me know.

     

    Your install Windows Server 2008 R2 Enterprise Server Core  edition and then enable Hyper-V on it, now you want to manage the remote Hyper-V computer from another client computer such as Windows Server 2008 or Windows 7, however, you get a “RPC” issue.

     

    If so, it seems that the remote Hyper-V computer and the client computer you used were in the workgroup instead of the same domain.

     

    General speaking, if you want to manage a remote Hyper-V computer easily and conveniently, you should add both the remote Hyper-V computer and the client computer into the same domain, then you can use a domain user who is a member of the local administrators group on the remote Hyper-V computer.

     

    Or else, if you do want to keep the remote Hyper-V computer and the client computer in workgroup(or different domain without trust), you need to use the following tool.

     

    Hyper-V Remote Management Configuration Utility

    http://code.msdn.microsoft.com/HVRemote

     

    In addition, you can refer to the following guide.

     

    Manage Hyper-V Server 2008 R2 in a Workgroup environemtn

    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/a3bba155-5745-44a1-91c7-a94e8a4d7842

     

    If you want to perform the further research about HVremote, it is recommend that you initial a post in the following forum so that you can get  the most qualified pool of respondents

     

    Hyper-V Remote Management Configuration Utility-Discussions

    http://code.msdn.microsoft.com/HVRemote/Thread/List.aspx

     

     

    Best Regards,

    Vincent Hu

     

    Monday, August 9, 2010 2:43 AM
    Moderator
  • So we were using a Cisco ASA 5505 as the gateway for all of these machines, and we were allowing all traffic to flow between two different VLANs that were connected to it.  However, we still couldn't manage it from our regular VLAN or from a PC on the same VLAN.  We figured the only thing in common was that the traffic was being handled by the 5505.  We connected a direct connection from our VLAN into the Hyper-V servers (so that we were bypassing the 5505), and like magic, everything was fine.

    It's not the ideal solution, but for now, it will work for us.

    • Marked as answer by TheMacOfAdams Monday, August 9, 2010 9:29 PM
    Monday, August 9, 2010 9:29 PM
  • Hi,

    I'm really tired in the testing of this, but in the end I got to resolve

    The problem was in name resolution
    because only one scenario was working.
    only when you open remote administration before the server .

    You should use the DNS server or add a record in the hosts (C:\Windows\System32\drivers\etc\hosts)

    It really works

    Wild Horse

    • Proposed as answer by ahmad_986 Monday, December 20, 2010 9:11 AM
    Monday, December 20, 2010 9:11 AM
  • Connecting to the DNS name rather than IP address fixed this error nice and quick. 

    "Cannot connect to the RPC service on computer 'Servername'.  Make sure your RPC service is running."


    Cheers, Stephen Edgar
    • Proposed as answer by saulw Tuesday, June 14, 2011 7:57 PM
    Monday, May 16, 2011 5:20 AM
  • Excellent. Was a DNS Problem. Thank you!
    Wednesday, July 10, 2019 6:13 PM