none
Internet Explorer 9 does not respect Group Policy Pop-up Blocker exceptions RRS feed

  • Question

  • I have a domain group policy that specifies sites which are exceptions to the Internet Explorer pop-up blocker, which is apparently not recognized by IE 9.  It worked in previous versions.

    The policy is User Configuration\Policies\Administrative Templates\Windows Components\Internet Explorer\Pop-up allow list.  I am using wildcards: e.g. *.microsoft.com.

    Things I have tried:

    • Created a new policy with the GPMC after having installed IE 9, thinking it required an ADM update, but with no success.
    • gpupdate, gupdate /force, and reboots, of course.
    • Verified both the original and new policies are being applied with gpresult /r and rsop.msc 
    • Cleared all user specified entries from the pop-up exception list
    • Manually added one of the sites to the list as a limited user, tested with success, removed it, and the pop-up was again blocked.
    • Verified the specified sites are present in HKCU\Software\Policies\Microsoft\Internet Explorer\New Windows\Allow

    Any suggestions?

    Tuesday, March 22, 2011 4:30 PM

Answers

  • Hi,

     

    I tested on my machine and that seem this GPO haven’t apply to IE 9 yet. You can go to https://connect.microsoft.com/ to submit this problem. And our development will investigate the problem. If they find any solution, it will improve it by update next time.

     

    Thank you for your understanding and cooperation.

     

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, March 24, 2011 9:19 AM
    Moderator
  • Thanks for the response.

    I have created bug # 653298 on Microsoft Connect, if you or anyone else wants to flag it as reproducible.

    Friday, March 25, 2011 8:37 PM

All replies

  • Hi,

     

    I tested on my machine and that seem this GPO haven’t apply to IE 9 yet. You can go to https://connect.microsoft.com/ to submit this problem. And our development will investigate the problem. If they find any solution, it will improve it by update next time.

     

    Thank you for your understanding and cooperation.

     

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, March 24, 2011 9:19 AM
    Moderator
  • Thanks for the response.

    I have created bug # 653298 on Microsoft Connect, if you or anyone else wants to flag it as reproducible.

    Friday, March 25, 2011 8:37 PM
  • I had exactly the same experience, i tried to configure exceptions to IE's popup-blocker, both as a computer and as a user policy, with no success. The setting is there in the registry, under the policy-tree, but it's not "read" by IE9. I ended up with using a Group Policy registry Prefence, which works, but it's not as good as a ordinary Group Policy.
    Tuesday, April 19, 2011 6:32 PM
  • I have the exact same issue except with IE 8. I've tried all the above as well.
    Friday, April 22, 2011 4:15 PM
  • Sorry to reopen but has this been resolved? I'm trying to move my organization to IE9 but the pop-up allow list bug is still happening on my test systems. The Microsoft Connect link above is dead so I can't see any status from that angle. Am I missing a hotfix? My web searches are coming up with nothing regarding this issue, which seems odd for a big Group Policy feature of IE.

    I'm running Version: 9.0.8112.16421
    Update versions: 9.0.1 (KB2530548)

    Thanks!

    Anthony

    Friday, June 24, 2011 8:24 PM
  • Hi,

    we're expierencing the same probs on ie8 and ie9 in two completely indepedent sites.

    Bevor we had this probs , we upgraded our domain from Win2k3 to Win2k8 r2 (not in native mode till now) and from ie7 to ie9

     

    regards, marco


    Thursday, July 7, 2011 2:14 PM
  • Hi again,

    it seems the problem will be resolved for ie8 with http://support.microsoft.com/kb/2526430/en-us.

    We're running ie9 on win7 and this fix istalled, but the problem still exists.

     

    regards, Marco

    Thursday, July 7, 2011 2:31 PM
  • Hi

    Are there any news on this subject for IE9

    Thx Jörg

     

    Tuesday, July 12, 2011 9:31 AM
  • Any update on this issue? Experiencing the same problem on Windows 7 SP1 + IE9
    Tuesday, August 9, 2011 7:30 PM
  • I am having the same issue. When I make this change, should I see the websites listed in IE9 popup blocker settings?

    I do see the change in the registry.

    HKCU\Software\Policies\Microsoft\Internet Explorer\New Windows -

    You will see the sites under the Allow key.


    Jason
    Thursday, August 11, 2011 8:55 PM
  • Same issue. Win 7 Ent x64 SP1 IE9 Pop-Up Allow List GPO setting does not populate this list en the clients.
    Tuesday, October 4, 2011 7:04 AM
  • I had the same problem.  Here is the fix that worked for me, please understand that it is completely unsupported by Microsoft.

    What worked was creating a group policy preference for IE 8 that included the pop-up blocker settings on the privacy tab.  The same registry entries are shared between IE8 and IE9, but the policy won’t apply to IE 9 because it is filtered to only apply to IE 8.  The solution is to modify the InternetSettings.xml file in sysvol and change the string min="8.0.0.0" max="9.0.0.0" to min="8.0.0.0" max="9.1.0.0"

    A very good explanation of how to do it, with some screen shots, can be found here.  The instructions are for setting the home page, but pop-up blocker settings work as well.

    http://www.grouppolicy.biz/2011/03/how-to-enable-group-policy-preferences-support-for-ie9/

    Friday, October 14, 2011 1:06 PM
  • I haven't tried it, but the issue of the preferences not applied to IE9 might be fixed by http://support.microsoft.com/kb/2530309/ ?
    Friday, October 14, 2011 1:17 PM
  • I haven't tried it, but the issue of the preferences not applied to IE9 might be fixed by http://support.microsoft.com/kb/2530309/ ?
    I just tried that.  Still doesn't fix the websites not being applied by the GPO to Popup Blocker Settings in IE9.
    Friday, October 14, 2011 3:30 PM
  • Well, the preferences started to be applied to my IE9 after installing the hotfix and creating a new GP object. The filter  max value is now increased to 10.0.0.0.
    (The hotfix was installed on a management PC where GP Editor runs. Nowhere else did I install it.)

    Saturday, October 15, 2011 2:15 AM
  • I've managed to get around the IE9 and Pop-up blocker issue as follows:

    Scenario: Running 2008 R2 SP1, with Windows 7 SP1 + IE9 clients. Setting Pop-up exceptions on this GPO (even with the KB2530309 fix) does not work:

    User Config > Policies > Admin Templates > Windows Components > Internet Explorer - Pop-up allow list - Enabled

    To get around this problem, install KB2530309, then navigate to:

    User Config > Preferences > Control Panel Settings - Internet Settings

    Right click Internet Settings > New > Internet Explorer 8 (Note: With the KB2530309 fix, this applies to both IE8 and IE9).

    Select the Privacy tab > Settings. Enter your Pop-up exceptions here and apply changes.

    Now run gpupdate /force on your workstation or restart your workstation. Pop-up exceptions will now work correctly with IE9.

    • Proposed as answer by hilde1124 Thursday, May 2, 2013 3:09 PM
    Thursday, November 3, 2011 9:01 PM
  • Thanks for your instructions, Michael.  This worked for me in my environment.  
    Friday, January 20, 2012 3:25 PM
  • Thanks! this worked for me! it doesn't populate the exception list as I expected, but once I tested it, everything worked perfectly!

    It also is working for me with IE10!

    Thursday, May 2, 2013 3:09 PM