locked
ipv6 and public network RRS feed

  • Question

  • Hello,

    I don't understand why my homelab server are on public network progile if I let them on DHCP for ipv6 DNS. I need to put ::1 and it's working perfectly then. (it happens on different OS)

    Why I have to do it ?


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    • Edited by matteu31400 Wednesday, May 27, 2020 4:06 PM
    Wednesday, May 27, 2020 4:05 PM

Answers

  • OK I find the issue.

    It's ipv6 is priority on ipv4 and my ipv6 DNS is pointing to my ISP box and ipv4 DNS my domain controler.

    When I log with vmware console, it opens session with cached credential.

    I tried with new account and I can't logon with vmware console :

    It's writen : no authenticating server available now... because it's trying to find with ipv6 and it sends request to logon to my box...

    I disable DHCP ipV6 on my box and all is ok :)


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    • Edited by matteu31400 Monday, June 1, 2020 10:04 AM
    • Marked as answer by matteu31400 Monday, June 1, 2020 10:04 AM
    Monday, June 1, 2020 10:02 AM

All replies

  • Hi ,

    If possible , could you please upload some screenshots? It would be helpful for us to identify the problem if you could upload the screenshots.

    Based on my understanding, if you obtain IPv6 and DNS automatically, then you will see public network in network and sharing center, is that right? Like the following picture:

    Please feel free to let me know, if my understanding is wrong.

    What does the network and sharing center show when you set IP address manually? 

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   


    Thursday, May 28, 2020 6:42 AM
  • Thank you for your answer.

    I have some more informations.

    If my ipv6 DNS is auto and I restart the server -> I can't connect to RDP and network profile is public (it's not firewall issue).

    If my ipv6 DNS is ::1 and I restart the server -> I can connect to RDP and network profile is domain.

    If my ipv6 DNS is auto and I restart the server -> I can't connect to RDP but if I change dns ipv to be ::1 rdp is ok without reboot.

    It's this settings yes :

    (sorry it's french language)

    My error message when I try to connect to RDP with ipv6 dhcp after restart


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    Thursday, May 28, 2020 7:46 AM
  • Hi ,

    From the “Network Location Awareness service”, please change the Startup type from “Automatic” to “Automatic (Delayed start)”  and then check the results.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Friday, May 29, 2020 6:53 AM
  • I already tried it but I forget to mention it ^^.

    The same issue appears.


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    Friday, May 29, 2020 8:21 AM
  • Hi,

    Did you configure option of "00023 - DNS Recursive Name Server IPv6 Address" in your DHCP server? If yes, what's the IP address of DNS server you are pointing to?

    Could you please post the result of running ipconfig/all at the command prompt on your machine to let us know the machine’s configuration? Posting both ipconfig/all results when your ipv6 DNS is auto and ::1.

    Note: since this is a public forum, everyone could view your information, please remove private information that might leak your privacy.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Friday, May 29, 2020 8:50 AM
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, June 1, 2020 1:44 AM
  • Sorry for late answer !

    Thank you for your answer :)

    My gateway is my personnal box (ISP box). This issue happens on my homelab and I don't use Windows DHCP.


    I did some more test :

    If I log in into the VM with vmware console and then I try to connect with RDP -> it's ok.


    Merci de marquer comme reponses les interventions qui vous ont ete utile.




    Monday, June 1, 2020 9:15 AM
  • Hi ,

    Unfortunately, I am not a moderator of this forum,so I have no permission to move this thread to RDP forum.

    You could mark the useful reply as answer to end this thread up and open a new thread in the RDP forum.

    Here is the link of RDP forum:

    Remote Desktop Services (Terminal Services)

    In addition, since RDP's error message is talking about NLA, you might uncheck NLA and then check if the error still occurs.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, June 1, 2020 9:44 AM
  • OK I find the issue.

    It's ipv6 is priority on ipv4 and my ipv6 DNS is pointing to my ISP box and ipv4 DNS my domain controler.

    When I log with vmware console, it opens session with cached credential.

    I tried with new account and I can't logon with vmware console :

    It's writen : no authenticating server available now... because it's trying to find with ipv6 and it sends request to logon to my box...

    I disable DHCP ipV6 on my box and all is ok :)


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    • Edited by matteu31400 Monday, June 1, 2020 10:04 AM
    • Marked as answer by matteu31400 Monday, June 1, 2020 10:04 AM
    Monday, June 1, 2020 10:02 AM